[Solved] LiveTV Shuttering?

#1

Hi,

I ordered a TV dongle from the official shop, I use it on my Vero4K. Video is shuttering, making it impossible to watch. The audio is alright.

If I use TVHeadend client on Kodi on my Windows 10 PC, I don’t have any issue. It’s only on the vero4K.
I don’t really know where to look to resolve this. Can you help me?

#2

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Can you also confirm if stuttering occurs just with live streaming or also with recordings.

#3

Arf. I think there’s something I didn’t configure well…
Since I rebooted the vero 4K according to your instructions, I have a “no signal” message… :grimacing:

Here are the logs so far:
https://paste.osmc.tv/yoquhocohe

For your question about the recordings vs. live, I cannot test it anymore :confused:

#4

No idea why Tvheadend keeps giving me “no signal” after a reboot?

#5

Sorry for not getting to this yet.
What region are you in?

Sam

#6

Hey Sam,

I’m in France.

#7

If you can ssh in to the Vero, https://osmc.tv/wiki/general/accessing-the-command-line/ does

sudo systemctl restart tvheadend

fix it?

#8

Hey,
I just tried. Restarting the service doesn’t change anything. I still have a No Signal :confused:

#9

Could it be as simple as a poor antenna or antenna connection?

#10

Does it impact recordings as well?

Sam

#11

Ok. Here’s what I’ve done:

  • Deactivated TVHeadend client in extension management
  • Uninstalled TVHeadend server in OSMC app store
  • I did: rm ~/.hts/*
  • Rebooted Vero4K
  • Installed TVHeadend server in OSMC app store
  • Rebooted Vero4K

Then, I followed this guide: Watching live TV with a USB DVB tuner or network TV tuner

So, I selected French as my language, 192.168.0.0/24 as my authorized network, selected network 3 (Sony CXD2837ER DVB-T adapter) and Generic as pre-defined muxes (previously, I used the realtek adapter).

The scan finds 57 muxes and 40 services.

I activated the TVHeadend client, and tested the live tv. Everything worked smoothly.
Then I rebooted the Vero4K just to test if it’s ok after a reboot and… yes :grimacing:

So it seems that my problem was that I used the realtek adapter in the first place :expressionless:

I’m sorry I wasted your time since I found the solution myself :see_no_evil:

Thanks, and I hope this post will eventually help someone else.

Now I’ll go back to bed :sleeping_bed:

2 Likes
#12

Waaait.

I just tried it again. And if the reboot problem is no longer here, I still have the shuttering issue…

After some time, I have to reboot the vero4k to have a smooth experience with live TV. No problem with the audio, only the video is shuttering. Lots of artefacts, and lots of lags.

I’ll try to send you a debug link.

#13

Here’s a debug log link:
http://paste.osmc.tv/epihokevuw

And here’s a recording of the live TV with the shuttering I’m experiencing:

#14

Yup, that’s crap. It’s the sort of result I get if the antenna signal strength is poor.

#15

You’re saying that by the video or by the logs?

Because if I reboot the device, everything is much better for some time (say 10/15 minutes).

#16

The video is crap. What signal strengths are you getting from the status tab of the tvheadend webui?

#17

68.6dBm after a reboot.
28.3dB s-t-n ratio.
I have no issue at all.

Then, after a while… The signal drops to 47.5dBm with 30.8 db s-t-n ratio. That’s when the video shuttering occurs.

If I reboot the vero4k, I go back to a higher signal.

#18

Testing here - I get problems when the signal strength is less than about 40dB. But if I select ‘Force old status’ in the DVB Input settings I have no problems. Try that.

2 Likes
#19

grahamh, would you marry me?

Thanks a lot. This solved my problem.

3 Likes
#20

Hi,
I’m experiencing the same issue.
Where can I find the mentioned settings:

?
I can’t see it under DVB Inputs -> TV adapters in my Tvheadend web interface.

I’m using Realtek RTL2832 TV adapter with OSMC Vero 4k