[SOLVED] - NFS root apt-get error - At least one invalid signature was encountered

If you run NAS4Free like I do to store you NFS root there is a server setting on the share config page.

Map to root - Map all users to root, all users will have root privileges.

Previously, and I have used this config for a long time, this was set to Yes. Simply setting it to No made all my systems happy again. No apt complaints even from upgraded machines and I can install as normal again.

Thanks Sam for an amazing distro!

*ORIGINAL POST BELOW

After updating my home full of Pi’s (a 1, a 2 and several 3s) all of them fail when running apt update and I am unable to install anything.

I was previously running fully updated 2017.10-1 (?) and I also tried a fresh install of 2017.12-1 but it did the exact same thing as the machine I had updated.

Updates were done on the command line (had 5 to do) via ssh.

All of my Pis use NFS root which has been working great for ages. I should mention checking similar systems at my brother’s house where he also uses NFS root suffers the same issue.

Here is the output from a brand fresh install of 2017.12-1. During setup I got the message:

OSMC could not automatically connect to the Internet.

Connected via ssh to confirm and got:

Updating APT cache. Please be patient.
apt-get update was unsuccessful. If you are planning to install a package, please run apt-get update first and verify it was successful

I attempted manual network setup (I have no idea why this was necessary - I’m online) but that generated a toast message that I missed.

osmc@osmc:~$ ping google.com
PING google.com (172.217.1.14): 56 data bytes
64 bytes from 172.217.1.14: seq=0 ttl=57 time=23.606 ms

Tried again via My OSMC - Network add-on unhandled exception - see log

Here’s the log:

ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<–
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type ‘exceptions.IndexError’>
Error Contents: list index out of range
Traceback (most recent call last):
File “/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/networking_gui.py”, line 308, in onInit
self.populate_wired_panel()
File “/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/networking_gui.py”, line 588, in populate_wired_panel
self.current_network_config = self.get_wired_config()
File “/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/networking_gui.py”, line 575, in get_wired_config
return osmc_network.get_ethernet_settings()
File “/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/osmc_network.py”, line 52, in get_ethernet_settings
nfs_settings = get_non_connman_connection_details()
File “/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/osmc_network.py”, line 221, in get_non_connman_connection_details
(name, address, netmask) = data[0]
IndexError: list index out of range
–>End of Python script error report<–

So that’s a thing.

I do have an IP and as shown above I can ping things on the net so I tried apt update and got this:

osmc@osmc:~$ sudo apt update ### HAD TO STRIP THIS DOWN DUE TO 5 LINKS IN POST RESTRICTION

Err:2 http://ftp.fau.de/osmc/osmc/apt stretch InRelease
At least one invalid signature was encountered.
W: GPG error: http://ftp.fau.de/osmc/osmc/apt stretch InRelease: At least one invalid signature was encountered.
E: The repository ‘http://apt.osmc.tv stretch InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Since not everyone has this issue I assume it’s NFS related but don’t really know.

I am doing a full install to SD card now as well since this system is not in a usable state anyway.

Will update here shortly whether or not the SD install works 100% correctly or not.

UPDATE

Fresh install to SD card and all problems disappear. Problem appears to be NFS root related.

Generating locales (this might take a while)…
en_CA.UTF-8… done
Generation complete.

osmc@osmc:~$ sudo apt update
…snip…
Get:4 http://ftp.fau.de/osmc/osmc/apt stretch InRelease [4,667 B]
…snip2… stupid link restriction…
Get:15 http://ftp.fau.de/osmc/osmc/apt stretch/main armhf Packages [26.4 kB]
Fetched 13.3 MB in 18s (714 kB/s)
Reading package lists… Done

If you use NFS booting, you cannot configure networking via My OSMC. Instead, networking for eth0 is handled by the kernel. As such, you’d need to edit cmdline.txt to configure networking.