[SOLVED] Only black screen on new Vero 4K+ never GUI


tl;dr: Replacing the old HDMI extender with a new one that had “EDID Copy” functionality solved this for me; it was not an issue with the Vero device or OSMC.

I recently received my Vero 4K+, and I cannot get HDMI video to display through my Denon AVR-X3000. I DO indeed see 1080p video if I connect directly to a computer monitor via HDMi, however I need to display via the Denon AVR. Despite having a completely black screen, I can hear audio through the AVR speakers when I use the Vero remote (the various GUI navigation sounds). At no point am I able to change settings in the GUI, as I simply get no video signal. I can ssh into the device and I’m comfortable mucking with the CLI. Links to logs below.

Things I have tried:

  • can successfully see 1080p HDMI video on a computer monitor
  • swapped 3 different HDMI cables and two different ports on the AVR device.
  • after my initial lack of success, I re-flashed the Vero with the Oct. update, but still no HDMI video.
  • I have updated via the command line, but no dice.

Logs after re-flashing with the Oct. update:

Logs after apt updating and rebooting:

Any thoughts on how to proceed? Direct output to the television itself is not is not an option (all ports, etc) are inaccessible behind a wall), and I have successfully used the OSMC rPi build on the same setup. I recently retired my trusty rPi 3 in favor of this new machine! Any help is appreciated. Thanks!

Edit: Plugging directly into the television gives me a video signal.

As requested, here is the grab-logs -z

Also, here is the -A

My television is a Samsung UN60FH6003F

Edit, final:
After connecting directly to my television, I was able to turn off CEC in the Vero. This allowed me to see video when connected through the AVR. Thanks to @Buckeye for the suggestion!

Here are the logs after successful video:

Thanks everyone!


To rule out configuration issues on the Denon, have you connected the Vero directly to the TV? (You only mentioned connecting it to a computer monitor).


Your AVR is not passing through the capabilities (EDID) of your display. Although it shouldn’t matter, make sure both the TV and AVR are powered on before starting your Vero.


Both are powered on first. Is there a config file I can edit to force the issue? Right now, the Vero is a paperweight.


I can try to directly connect later but leaving it that way isn’t a permanent solution. I need to plug into the AVR to get sound to the speakers and music to the other zones.


Well it is just a test to see if the AVR is to blame.
Next steps would be to ensure TV and AVR are on before you boot the Vero
If it works directly connected to the TV but you can not get it going via AVR then the next step is to save the EDID when connected to the TV and force the Vero to use that.


One more point, when you are directly connected to the TV please run grab-logs -Z to upload the EDID info and report URL here.


Okay, will do. It will be about 5 hours before I can try this. Once I find the EDID, how can I force the Vero to use it? I can try that, also.


We might be getting ahead of ourselves. I was assuming the EDID is not coming through but it may be you just have an old TV - (maximum 1080i resolution). If so, then the only problem is: why is it not displaying at 1080i?


Just last week I upgraded to a Denon AVR-X3500H, I should imagine the specs are similar to your X3000.
I initially got a similar problem where I got a black screen but could hear the audio when trying my Vero 4K+ through it,
in my case the black screen was caused by CEC switching my TV to a different HDMI port, I had to turn off CEC on my TV and then got a picture on the tele to carry out the rest of the setup (since then I’ve turned off CEC completely on my Vero as it was waking my TV up during the night and I haven’t had time yet to figure out which setting on which device is causing this)


Plugging directly into the television works fine. I have video and audio.

Here is the link to grab-logs -z (I didn’t see a Capital “Z” option)

Also, here is the -A


I can successfully see video if I plug in directly to the television. Still cannot when I attach via the Denon AVR.


My Samsung television does not seem to have an option to turn off CEC on the TV, however (!) once I connected the Vero to my TV, I was able to turn off CEC on the Vero. This turned out to be the key, as afterwards I was able to connect through the AVR. Thanks for the ideas!


After turning off CEC on the Vero, I am able to see video when attached through the AVR. Here are the log files afterwards:


For future reference, is there a way to turn off CEC via ssh, in case I need to do this again but don’t have GUI access through the television?


If you compare the EDID to the log when it is directly connected you will see that still it is not identical. So either the AVR messes it up or a cable issue.


I will try another cable, however I’ve tried 3 different ones already, on 3 different HDMI ports on the AVR.

Given that we have the EDID from when it is directly connected, is it possible to force this via a config file when going through the AVR?


Well first make sure that you have chosen 1080p60 as resolution in Kodi.
Then when connected to the TV and you are getting the picture run

sudo cp /sys/class/amhdmitx/amhdmitx0/disp_cap ~/.kodi/userdata/
sudo chown osmc:osmc ~/.kodi/userdata/disp_cap


We can force video mode, yes.
We can also override the EDID; but I’m not sure why this is necessary.


Well maybe not an EDID overwrite but at least the dis_cap as this is what his AVR delivers

====================== Display Cap =================== g0gjk991

---------------------- Display Cap END --------------- g0gjk991

====================== Display Mode =================== Q72ho215

---------------------- Display Mode END --------------- Q72ho215

====================== EDID =================== wE0go885
Rx Brand Name: ��B
Rx Product Name: 
Manufacture Week: 10
Manufacture Year: 2016
Physical size(cm): 0 x 0
EDID Version: 1.0
EDID block number: 0x0
blk0 chksum: 0x00
Source Physical Address[a.b.c.d]:
YCC support 0x00, VIC (native 3):
ColorDeepSupport 0x00 10/12/16/Y444 0/0/0/0
3 4 5 16 
Audio {format, channel, freq, cce}
Speaker Allocation: 0x00
Vendor: 0xc03
MaxTMDSClock1 0 MHz
RR_Cap: 0
LTE_340M_Scramble: 0

checkvalue: 0x00000000

---------------------- EDID END --------------- wE0go885

While his TV says

====================== Display Cap =================== g0gjk991

---------------------- Display Cap END --------------- g0gjk991

====================== Display Mode =================== Q72ho215

---------------------- Display Mode END --------------- Q72ho215

====================== EDID =================== wE0go885
Rx Brand Name: SAM
Rx Product Name: SAMSUNG
Manufacture Week: 41
Manufacture Year: 2011
Physical size(cm): 16 x 9
EDID Version: 1.3
EDID block number: 0x1
blk0 chksum: 0x1d
Source Physical Address[a.b.c.d]:
YCC support 0x03, VIC (native 16):
ColorDeepSupport 0xb8 10/12/16/Y444 1/1/0/1
16 4 5 3 32 34 7 
Audio {format, channel, freq, cce}
{1, 1, 0x07, 0x07}
Speaker Allocation: 0x01
Vendor: 0xc03
MaxTMDSClock1 225 MHz
RR_Cap: 0
LTE_340M_Scramble: 0
checkvalue: 0x1dd60000

---------------------- EDID END --------------- wE0go885


That’s off…