[SOLVED] Only black screen on new Vero 4K+ never GUI

Yep, and that seems to be after CEC off (not sure if it really has an impact or is coincident)

But Early when no picture was working the Denon transmitted a more complete but still wrong EDID

====================== Display Cap =================== g0gjk991

---------------------- Display Cap END --------------- g0gjk991

====================== Display Mode =================== Q72ho215

---------------------- Display Mode END --------------- Q72ho215

====================== EDID =================== wE0go885
Rx Brand Name: DON
Rx Product Name: DENON-AVR
Manufacture Week: 0
Manufacture Year: 2013
Physical size(cm): 60 x 34
EDID Version: 1.3
EDID block number: 0x1
blk0 chksum: 0x33
Source Physical Address[a.b.c.d]:
YCC support 0x03, VIC (native 5):
ColorDeepSupport 0x80 10/12/16/Y444 0/0/0/0
5 2 3 4 1 6 7 17 18 19 20 21 22 16 31 14 35 15 36 29 37 30 38 
Audio {format, channel, freq, cce}
{1, 7, 0x7f, 0x07}
{7, 5, 0x1e, 0x00}
{2, 5, 0x07, 0x00}
{11, 7, 0x7e, 0x01}
{10, 7, 0x06, 0x00}
{12, 7, 0x7e, 0x00}
{9, 5, 0x02, 0x00}
Speaker Allocation: 0x5f
Vendor: 0xc03
MaxTMDSClock1 80 MHz
RR_Cap: 0
LTE_340M_Scramble: 0

checkvalue: 0x33990000

---------------------- EDID END --------------- wE0go885

That does seem odd!

Normally, I have an hdmi-over-cat5 extender in the mix. Could that be causing issues? I hadn’t thought it could, since every other device I’ve thrown at the combo has worked. Although I can short-term connect the Vero directly to the television, I can only connect the TV to the AVR via the 6 meter length of cat5e.

So the clean EDID you only got when you connected the Vero with a short cable to the TV? If that is the case than neither the Vero nor your AVR is at fault but just athe hdmi-over-cat5 extender not transmitting proper EDID

That’s possible. I have never had any issues with any device using this setup until now, including an rPi with Sam’s OSMC build. Luckily, I’m getting a new extender shortly. I will update this post regardless of the outcome. Thank you for your help.

Vero is a much more capable device and needs to know more about your display capabilities so we can send the best possible video signal.

Awesome, I’m super excited to test with my new HDMI extender. It is advertised as having EDID copy features, and supports full 1080P. One reason I bought the Vero 4K was to future-proof this part of my setup. Thanks, I’ll update again after I connect everything.

A few days testing with my new HDMI extender and all is great! Thanks everyone for the support. For completeness, attached is a log capture with the new extender in play. The new extender has a “Copy EDID” function, which did the trick.


Lesson learned: use good equipment in conjunction with your Vero.


Hey there, I’m having a slightly similar issue to yours, and I’m also using an HDMI extender, and I’m wondering if I have this same lack of EDID copy feature. It was working fine for over a year, so I dont understand what changed…

Can you say what new extender you got that worked? I’d like to try a new one to see if that solves the problem, and getting one that did work for you would be good idea.

It was a unit from Amazon US; I can attach a link later but I’m not sure if it’s against forum policy.

I’m not home ATM, but I can say it was a consumer unit that specifically advertised EDID copy features. It was under 65USD. So far it has been great.

You’re welcome to link to the product.
It may help other users in the future who have the same / similar line of products.

We can always override EDID on Vero or force video modes, but I’m not sure how well your extender will respect this.


Maybe it was this one?

I notice this one has EDID Copy, and it lists similar devices that are more expensive that do EDID passthrough.

Yes, that is the one I bought.

Ok, I bought a different device:


I just got it and it seems to work. It has an EDID button on it, but I have not pressed it. The manual is incomprehensible, if someone understands this, I’d love to know what it means:

EDID buttons purposes, such as connection after launch the PWR, STA indicator light, long PWR at
the receiving end, the STA indicator light, long display no image or color, the transmitter power
on the monitor of the HDMI port and transmitter HDMI port connection, long press EDID until
the STA lights flashing, flashing stop and restart the power.

You gotta love these Chinese to English translations done by a computer and then proofread by a Chinese speaking person who’s only English skills are to say ‘Hello’…

I think you’d be better off finding the Mandarin manual and putting that through Google Translate.

They probably did the same – but Google Translate is improved regularly…

Here’s what I did with my set:

Take the unit that connects to the AVR and temporarily connect it to the television. Once connected, press and hold the EDID copy button. On my device an LED flashed. At this point, the unit has copied the EDID from the television.

Connect it to the AVR, and the other on the television in the normal configuration. The unit attached to the AVR should now be “spoofing” the EDID.

Good luck!

1 Like

Thanks @kinggrowler for the explanation of what you did, that will be helpful!

Two months later, the one I bought to replace the broken one… has now broken too.

Is yours still working fine? Maybe I need to get the one you have, because the ones I’ve been buying have been crap.

Yes, it is still working fine, although I don’t watch every day. So far it’s been working like a champ:

J-Tech HDMI Extender