[SOLVED][RPi 2][WIFI] Connected but no internet

#1

Hello,

I connected a wifi dongle to my RPi 2 and it is connected to my internet box but it says “no internet” and I can’t ping google.com or even the gateway.
However, when I am connected to my phone (as hotspot), it is connected to the internet.
I have tested several modifications (of configuration and I modified the box wifi to wifi b/g/n to b/g) and I have tried to go as close to the box as possible, and I have no clue of what’s going on.
If anyone has any idea…
PS: I don’t know what log I can provide, but tell me and I will gladly provide.

Thanks,

Raysko

#2

How to submit a useful support request - General - OSMC

#3

Here are some logs
http://paste.osmc.io/ulaqazewex

What I did:
I connected the wifi dongle.
I disabled / enabled the adapter
I connected to the box (no internet)
I connected to my phone (internet)
I reconnected to the box (no internet)

Thanks for any suggestion or help!

#4

Hi,

[  496.741155] wlan0: send auth to b0:e2:35:e7:8f:7c (try 1/3)
[  496.761912] wlan0: authenticated
[  496.767358] wlan0: associate with b0:e2:35:e7:8f:7c (try 1/3)
[  496.776532] wlan0: RX AssocResp from b0:e2:35:e7:8f:7c (capab=0x431 status=0 aid=2)
[  496.782505] wlan0: associated
[  646.772068] wlan0: deauthenticating from b0:e2:35:e7:8f:7c by local choice (Reason: 3=DEAUTH_LEAVING)

Seems to be connecting then dropping out, you could try connecting via the commandline:

Thanks Tom.

#5

So, after investigating, I can connect to my home router and on the internet when the connection does not have encryption (no password protection).
I don’t know why, but some guy says it may be related to a wpa_supplicant issue.

#6

HI

This would suggest your router is using tkip rather than aes, tkip is insecure:

I assuming your router is provider by your ISP, I would see if there is a a firmware update.

Thanks Tom.

#7

Thank you for the tip!
I switched to AES encryption (by default it was on TKIP/AES, that is why…)
Again, a BIG thank you!!
Ray

1 Like
OSMC branded WiFi dongle not running (rbp3, osmc)