Solved: RPI-2 with fresh NFS install - kernel panic

see the picture for what I see, this is fresh rpi2 install of alpha4. network is set to dhcp with ip reservation for the nfs share.

my nfs exports settings:
/var/hda/files/nfs-shares/osmc x.x.x.x(rw,async,no_root_squash,no_all_squash,insecure,no_subtree_check)
ìdentical to what I use on my RPI-B which works fine on NFS install…

anyone that can point me in the right direction?

Same error for me, SD install. Kernal panic comes after reboot. Have reinstalled 10+ times and the error happens random for what i can see.

not just me then, at least that’s something…

hope there’s a simple solution, really want OSMC running.

tried 2 different microsd cards and same problem

Wait until the next Pi2 build and let me know if still unresolved

S

Try the exports as listed here https://osmc.tv/help/wiki/nfs-boot
I just did an nfs install using them with no problems

@sam_nazarko new build of osmc? New to pi, can you update the firmware of the pi?

Updated fw with rpi update, now missing cpu message is gone. Still kernal panic after dist-upgrade though :frowning:

tried the suggested exports, no change.
hope next build will work. :smile:

The current build works! This problem is specific to your setup. Here’s my working export

/media/raspbmc 192.168.0.0/24(rw,async,no_root_squash,no_subtree_check,insecure)

tried making the changes you suggested, but it still kernel panics…

nfs server is Fedora 19

log on server says:

Feb 19 01:04:02 amahi rpc.mountd[1504]: authenticated mount request from 192.168.1.20:702 for /var/hda/files/nfs-shares/osmc (/var/hda/files/nfs-shares/osmc)
Feb 19 01:04:07 amahi rpc.mountd[1504]: authenticated mount request from 192.168.1.20:952 for /var/hda/files/nfs-shares/osmc (/var/hda/files/nfs-shares/osmc)
Feb 19 01:04:17 amahi rpc.mountd[1504]: authenticated mount request from 192.168.1.20:821 for /var/hda/files/nfs-shares/osmc (/var/hda/files/nfs-shares/osmc)

and my regular Pi works fine, it’s just when I try to use osmc on my regular Pi or Pi2 it fails…

I have also tries numerous sd cards, kernal panic every time with my pi2.

It always occours efter reboot, not at the same time. Sometimes I have been able to update it all through and the kernal panic came after entering licence reboot.

NFS install works fine for me on my Pi 2.

Have you restarted your NFS server since changing exports ?

Do you have correct permissions on the nfs exported directory ? You should chmod a+rwx the directory which the export is sharing. Do you disable certain NFS versions on your NFS server ?

Almost certainly this problem is going to be file permissions, export settings or other configuration options of the NFS server.

1 Like

weird thing is, raspbmc works perfectly on nfs share with exact same settings, never disabled anything on nfs-server, file permissions are the same on both shares, they’re in the same subfolder with same owner/group.

of course I restarted nfs server before testing and I also tried the permission change you suggested…

this is driving me nuts, will try a clean install.

You have to realise that OSMC uses a completely different kernel than raspbmc - 3.18 vs 3.12 and there are a lot of differences between these kernels. Default nfs root mount options may be different and thus incompatible with your current NFS server configuration, but rest assured NFS is working for all the devs who have tested NFS installs.

It may take a little bit of investigation to figure out what the issue is at the server side - I would start by verifying which NFS versions your server is configured to support because it’s possible osmc is trying to use a different nfs protocol version.

versions server is running:

program 100003 version 3 ready and waiting
program 100003 version 4 ready and waiting

verified that OSMC runs if installed to microsd only, but still hoping I can fix this snafu…

force nfsv3

YES! :smiley:

silly me never thought of forcing nfs version…

added ,vers=3 rw to cmdline.txt and now it works perfectly, finally I can really enjoy my new rpi2 :smile:

thanks a lot for all answers and to you Sam for giving me the final piece.

now to get the sql db working and shares imported!

weird that my old Pi B works without this fix :stuck_out_tongue:

Will make this default

S

1 Like

btw, dhcp works, but /etc/nameserver doesn’t populate.

it just had:

nameserver ,

fixed by manually adding dns ip though :slight_smile:

Resolv.conf will be rewritten on each boot so your fix will be short lived however if you run an OSMC update the name server bug is already fixed in the most recent updates.