[Solved] (Vero4k) Long delay after pressing play

Hi everybody,

I’ve got an issue for some months where it takes a long time (10 secs) after pressing play for movies to start playing. All of my files are stored on a Synology NAS using NFS.

I’ve read this Vero4k+ long delay after pressing play, but I don’t have this setting on.
I’ve read the log, there’s some errors, but I cannot understand what are they and how to fix it :confused:

Log upload:



try kernel mounts (fstab or autofs), rather than kodi soft mounts. IMHO autofs is the easiest way to set it up:

Thanks Tom.

Won’t that affect my current library?

Edit: path substitutions… I’ll give it a try @Tom_Doyle, thanks.

1 Like

Have you tried without your custom cache setting?
Have you checked your network speed with iperf3?

Nope. How do I change that?

No, I didn’t checked my network speed, but I have no other speed problems.

I did try the kernel mounts and it did improved things a lot!
But I screwed my database when trying to change paths instead of using path substitution :laughing:

I’m currently trying to do the same thing with my music database, but I really don’t want to damage anything.

Well be removing it from advancedsettings.xml where you included it.

Then just stick to path substitution.

I forgot about that. Sorry.

Well, after switching to kernel mounts instead of kodi soft mounts, it was solved.
But, after a few weeks, the problem is back.

I tried removing the cache settings as fzinken suggested. It did not improve anything.

It’s not really a “problem” as everything is working, but I don’t understand why and it’s kinda annoying…

Would suggest to investigate your network with iperf3 and maybe if using wireless change channels.

Yes, I’ll test it. Thanks.

Did you solved the problem ?

After two years, I suspect the answer is yes.


Yes, as Sam suspected :smile:
The problem was the wifi. I managed to force the vero4k to use 2.4GHz or 5GHz (can’t remember which one), as my home wifi is using the same SSID for the two frequencies.
And that solved it.

Sorry I didn’t came back to edit.

I wish it was another solution because I have the same problem but it’s connected with ethernet and network IS ok (tested with iperf3)

In this case, I’d suggest a new post with some logs so we can assist you further.


1 Like

I’ve found a script for Kodi to purge texture cache https://kodi.wiki/view/Texture_Cache_Maintenance_utility ive ran it with “p” argument and it took about 1 to 2 hours.
Now my problem IS solved as it gave me back 7 GB of free space !