Some User Profiles not working after updating to Krypton


My previous installation of 2017.12-xx started crashing, so I decided to make clear re-install of my RPi2B from scratch.
I used the OSMC_qt_host_installer.exe and I did install 2017.01-1.

I did system update, restart, I dd all the system setup under Master user and scan NAS for movies/series … I took several hours :frowning:
Then I created profile for “parents” and “kids”… however when I tried to login to any of these profiles … it crashed and I saw blue screen with :pensive: smile

Any idea? Why 2017.01-1 profiles crash?
Im gonna do install 2016.12-1 now… hopefully profiles will work. :osmc:

I moved your post to this thread as I assume it is related

Actually the “crash profile” crash is also in the 2016-12 release of some kind as well :frowning:

I just did clean install of 2016-12, I can create profiles and login to them, but if I do steps as below the Kodi crash!

  1. clean install + login as Master
  2. create profiles: kids and parents
  3. login as kids and setup profile
  4. logout kids … crash
  5. login as parents + setup profile
  6. logout parents … crash
  7. login as parents … OK
  8. login as kids … crash
  9. login as kids … OK
  10. logout kids … crash
  11. login as kids … OK
  12. logout kids … crash
  13. login as parents … crash
  14. login as parents … OK
  15. logout parents … crash
  16. login as parents … OK

So, every time I login to the same profile as it was logged previously … it is OK and logout is OK too …
But, if I login as different profile as it was logged previously … it crash on login and on logout …

I think I’ve found the problem.

I’ll build a quick test build for Pi 2 if anyone is willing to test.

I have the same issue after updating to Krypton as well (but on a pi 3B). Have 2 profiles, neither will log in. Have the error log here, hope it may be of help.


I’m having the same sad-face issue after the upgrade to krypton. Pi3. Have only one profile (the master user).

Just to add another set of logs:

Then this is a completely different problem.

Thanks, that worked!
Changed in my profiles.xml to

Using two profiles with MySQL database setup. Running Pi2. Managed to recreate the issue after reinstall and restore of .xml files(didn’t try without MySQL setup however). Sorry, don’t have log files, as they were overwritten when it worked again.


Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.


Yes, it works! Thank you for fixing this so quickly.

Worked for me as well!

Great, thanks for the feedback. Glad to get this finally squashed.
I’ll make this fix available to users soon.

Awesome. I was just updating and wondered why I don’t get my profiles to work. Taking a look at the forums and there you go, magic Sam has already fixed it a couple of minutes ago. Thanks a lot!! <3

After update received via modification of /etc/apt/sources.list file problem still appears. I have two profiles and during logging to anyone I can still see only sad face. I have raspberry 1.
Any idea what I should do?

Debug log.

I applied the update but both profiles are sad face. How do I re-install the Krypton Update and start over again with a single profile and default skin?

I may have spoken too soon. It does now allow me to log in to my other profiles, but I am seeing all kinds of PVR add-on errors that did not exist before. Not sure how to get rid of this, I don’t have any PVR hardware, and I don’t want to use any of the Live TV/PVR functionality. How can I get rid of this?

Update again and PVR issue should go away

These are just test builds. My interest was in resolving the profiles problem first

Update with the test build? I removed the test source earlier and tried an update, nothing came down.