Sound delay after pause

Hello OSMC. I have a Vero4K+ and am very pleased with it. However I have a problem where after resuming from pause, the video plays but there is around 3 seconds delay before the audio kicks in. I have the Vero plugged into a Philips B5 4.1 soundbar, which then passes the video to the TV. Audio is set to passthrough.

I have tried the Kodi settings to keep audio alive and send a silent signal, but it makes no difference. I don’t think it is a decoding issue in the soundbar as no other device I am passing through it does this.

I appreciate this may be more of a Kodi issue but posting here first to see if anyone has any ideas…


Does this happen with all audio formats?

I suspect that keeping the audio device alive will only benefit you for PCM, as with bitstreaming the AVR has to switch in to that mode to decode it.


It does it with surround formats (both DD and DTS). But not for files with DD 2.0.

There is also a shorter delay after skipping

This may just be a delay in the AV locking on to the audio signal. We did make some improvements in this area a few months ago.

When you press Play again, how quickly does the light on the AVR change to reflect the surround sound stream?


The display on the soundbar is a bit basic - it will just flash up quickly with the type of audio it thinks it’s receiving (e.g. Dolby, DTS, PCM). It is not flashing anything up when coming out of pause however. This is also the case with my other devices except there is only a very short delay with them (PS4, Mede8er).

Thanks for replying so quickly btw.

No problem.

@grahamh — can you think of anything we can do to improve this?

The delay may simply be due to the current buffer stream and it takes a bit of time to form and send a complete packet.

Could you also go to My OSMC -> Logs and upload a full set of logs and give me the URL so I can check your audio settings?



Thansk Sam. Logs uploaded to:

In my experience, there is always a bit of a lag but not as much as 3 seconds. Will investigate.

1 Like

This happens to me as well, but only about 1-2 seconds. The length of delay probably depends on the AVR.

It would be great if this could be reduced, but I realize it may be caused by the AVR.

Tomorrow I will test my PS4 using bitstream as a comparison (usually I leave in PCM).

So I’ve been playing with the settings and disabling passthrough while leaving the channels at 7.1 removes the delay, and as far as I can hear performs exactly the same as far as surround experience.

The difference between the Vero and other devices (e.g. the PS4 which is set to output linear PCM) is that the AVR/soundbar does not indicate that it is receiving a surround signal. So I don’t really understand what is going on but if it works I’m happy.

That suggests the AVR is taking a while to decode the received audio. IIRC Vero switches to stereo PCM on pause. I’ll have a look to see if there’s a way to stop it doing that.

The only disadvantage to doing this in my case is a loss of Atmos. Afaik, sending bitstream 5.1 / 7.1 vs PCM will sound the same, but you can’t send Atmos over PCM.

I guess I could turn off everything except Dolby Digital Plus and True HD since those are the only formats that would contain Atmos, and send the rest PCM.

I have this same issue with my Vizio sound bar, but it isn’t specific to the Vero 4K+. I’ve experienced this since I got the Vizio six years ago, and it’s been consistent across machines (2 Windows machines, 3 Raspberry Pis, and now a Vero 4K+). No amount of fiddling with settings on either Kodi on the Video have ever made it any better. I figured if I got a better sound bar someday that would solve the issue. '-)

So before I said that my PS4 was set to Linear PCM, however this is actually just for games and the Blu Ray player is set to Bitstream. Hence why the AVR indicates Dolby or DTS rather than PCM. There is no audio delay when resuming.

Bit of an off-topic question but does anyone know why Kodi requires you to tell it which audio formats your AVR supports, whereas other devices (e.g. the PS4) don’t? My AVR only decodes standard DTS and Dolby but TrueHD sources play fine.

My guess is that it would be difficult, if not impossible for Kodi to know what your AVR supports. While EDID can report that, what if you are using optical, or HDMI to a TV and passed via optical to the AVR, or…

It can be done, but it’s low on the to do list. aud_cap via sysfs tells us the supported audio formats, so we can use this

We can handle it on the fly with udev possibly


Thanks Sam. I was just wondering really, not making a request or anything.

ALthough sorting the audio delay with passthrough would be good :slight_smile:

Hi Graham, I’m sure you have probably forgotten all about this in the last 11 months, but did you ever get a chance to look into this?

As I now pass audio through the TV via ARC, I cannot use the PCM workaround (ARC doesn’t support multi-channel PCM). So I am back to having the few secs delay when resuming from pause. As said before, other devices such as the PS4 and the TV’s Netflix app do not have this problem.

Obviously it’s not a huge deal, but just a bit annoying when you pause in the middle of some dialogue and then have to rewind because you miss a bit of the conversation…

There is a Add-on called Unpause Jumpback that will automatically rewind a user specified amount of time whenever you unpause. It can be kind of handy even if you don’t have this problem.

In my experience the sound stays muted for the duration of the jumpback. It’s a bug i found a while back but cba to report it.

Also an issue probably related Is that sometimes audio starts before the video… video is still adjusting and then when the video starts it cuts of half a word if someone starts talking right away.

Not sure if I explained it so that it makes sense