Source not connecting

I have been having problems with my second Vero+ not connecting to the internet properly.
I eventually tried reloaded the system and restoring a backup.
It now appears that problem was my vpn stopping any traffic to the internet, for which I need to speak to VPNUnlimited.
Now however the host can connect to the second vero, but the second one cannot connect to my host vero.
I have tried re loading the userdata advanced/settings, sources and shares files but still no luck.
Logs are at
Can anyone see what I’ve done wrong?
The 2 vero’s are called osmc and bedroomosmc

From whichone are you trying to connect to whichone by which technology?

hi Fzinken,
from bedroomosmc to osmc (other way is working)
using file manager I cannot see my media and I cannot add source

Did you install any server (DLNA, Samba or NFS) on the osmc one?

samba is installed on the osmc one and it says it’s running.
However while I can see the bedroom samba shares on my mac the osmc shares is showing but won’t connect

Could be a SMB version issue or wrong credentials.
Do you know how to login with ssh then we can do some test on command line.

yes can ssh in using my MacBook.

run sudo apt-get install smbclient and smbclient -U osmc -L <ip of osmc> and see what you get

is this on the host (osmc) or the bedroom one?

On the bedroom one (assuming you try to access the files on the osmc one)

Domain=[WORKGROUP] OS=[Windows 6.1] Server=[Samba 4.5.16-Debian]

Sharename       Type      Comment
---------       ----      -------
osmc            Disk      OSMC Home Directory
IPC$            IPC       IPC Service (Samba 4.5.16-Debian)
Lounge          Disk      Auto-mount Volume
MyMedia         Disk      Auto-mount Volume

Domain=[WORKGROUP] OS=[Windows 6.1] Server=[Samba 4.5.16-Debian]

Server               Comment
---------            -------
FVP-4000T:5          Samba Server
OSMC                 Samba 4.5.16-Debian

Workgroup            Master
---------            -------
WORKGROUP            FVP-4000T:5

Ok, so you should be able to add them with smb:\\<ip of osmc> \Lounge in your sources.
But maybe also check on the bedroomosmc your credentials file /home/osmc/.kodi/userdata/passwords.xml if it has the right credentials for osmc.

When I try to add I get

osmc@bedroomosmc:~$ smb:\ \Lounge
-bash: smb:\ command not found


osmc@bedroomosmc:~$ /home/osmc/.kodi/userdata/passwords.xml
-bash: /home/osmc/.kodi/userdata/passwords.xml: No such file or directory

That was not meant for the commandline. Just in Kodi add Sources and then`Add Network Location, add the server address and folder.

That would be nano /home/osmc/.kodi/userdata/passwords.xml to open it in editor

Ok I understand.
the passwords file is empty, just trying to add the network location now

can’t add lounge. says File exists, then says could not retrieve directory information. This could be due to the network not being connected. Would you like to add it anyway?

Can you post a screenshot how you entered the information?
File Exists could come from a protocol issue. You could try under Settings > Services > SMB Client to set min/max to Version 1

I entered the info using file manager/add source
Don’t know how to get a screen shot in kodi so here’s a photo.

I’ve just been checking on my MacBook finder.
Bedroomosmc shows up as samba shares and I can browse all files/locations.
osmc shows up as Samba shares but It won’t connect.
It also shows up under network connections and I can browse files/locations and also under osmc as (I think) a connected drive? and again I can browse all files.
Still can’t connect from bedroomosmc.