SSH problems when trying to connect from iOS Apps


i own 2 Vero 4K, sometimes when they crash, i just use SimplePi or Command Pi from my iPhone to restart the devices.
i was able to do this, with both my 4K’s but lately, only one of them will connect.

they are both connected to the same network, today i tried with a fresh build, the problem is the same.
it’s probably network related, just wanted to hear if someone else have any troubleshooting ideas - ssh from putty works fine.

They shouldn’t really be crashing; but perhaps the IP address of one of the devices has changed, or the device has locked up completely?

Hi Sam,

yeah well sometimes they freeze up, and i have to unplug the device, that do not happen so often, so that’s okay.
but when they do, i would like to reboot them remotely…

i tried changing the IP, also tried connecting when the device is functional, it’s really strange that the other device is working perfectly…

Well you write Putty is working. So I doubt it is a IP Adress problem. Suggest next time to login into with Putty and then try simplepi and after simplepi not working check sudo journalctl -f

i get this :

Oct 19 15:13:10 osmc-bedroom sshd[2473]: fatal: no matching mac found: client hmac-sha1,hmac-sha1-96,hmac-md5,hmac-md5-96,hmac-ripemd160, server,,,hmac-sha2-512,hmac-sha2-256, [preauth]

Are both of your Vero’s up to date?
This would indicate that your simplepi client has an issue with the latest encryption

Yes they are both updated, the other one shows

Oct 19 15:25:44 osmc sshd[1306]: Accepted password for osmc from port 55662 ssh2
Oct 19 15:25:44 osmc sshd[1306]: pam_unix(sshd:session): session opened for user osmc by (uid=0)
Oct 19 15:25:44 osmc systemd[1]: Starting Session c5 of user osmc.
Oct 19 15:25:44 osmc systemd[1]: Started Session c5 of user osmc.
Oct 19 15:25:44 osmc systemd-logind[297]: New session c5 of user osmc.

So you are saying that with same client connecting to two different Veros (both on the latest software version) you get this two different results?

Yes, if you can send me the ssh command to write the software version, i can send them to you

Post the URL’s

grab-logs -a
cat /etc/ssh/sshd_config | paste-log

Not working :


Ok so actually the two Vero’s have been updated slightly differently with one of them not have applied the security update.
From the non-working one can you post ls -lah /etc/ssh/ | paste-log

Hmm okay, i just checked the My OSMC for updates, there were none.

Ok, to be honest the “not working” Vero is actually the one that has the security patch correctly installed. And it is not that easy to refered that. Also as that would make it more insecure I would not recommend it and would suggest to check if there is an updated version of simplepi that support the newer keys.

Ok, thanks - i will try resetting the working one, and get back to you :slight_smile:

What do you mean with resetting?

Reinstalling OSMC from a USB drive made with the OSMC installer
exactly as i did with the not working one, earlier today, as i thought it would help.

Ok, it might solve your issue temporary

don’t think it can solve my issue, as the one with the fresh build is not working :slight_smile: just want to rule that out

[quote=“Ben1984, post:19, topic:39352”]
don’t think it can solve my issue, as the one with the fresh build is not working :slight_smile: just want to rule that out

Ok, but then you have two not working ones and can then try to find a new simplepi version :wink:
If there is no newer simplepi version we can discuss other solutions