Strange 'line' on left side of picture

Since a short while now (few weeks/month), I noticed a strange line on the left side of the image displayed on my TV. I know for sure it wasn’t there before, so perhaps it appeared after a (recent) update.

First I thought it was just a corrupt line, didn’t pay attention to it really, but it seems that the vertical line that should be on the far right of the image, is displayed as the first line on the left. It looks like a one pixel line, but I’m not really sure, could be more.

It’s not fixed by calibrating the video in the Kodi settings.

I’m using a Vero 4k with a Philips TV set (2010-ish).
Any thoughts in how this can be fixed?

Does this happen on all videos? If not, post the mediainfo of the videos with problems.

I have seen similar issues on videos where the number of horizontal pixels is not a multiple of two, or if it is not a multiple of the MPEG-4 block size.

A sample file to produce the problem would be great.

It’s also happening in the Kodi Menu’s. Not only when playing movies.
Actually that’s where I noticed it first.
I shot a video of it: Vero 4k line issue - YouTube
Look for the scroll bar ‘rolling over to the left side’.

I was about to say that I only has seen that on an old Philips (pink/purple line) - but a with a Pi1 and a HD-ready TV (1360x768).
So, the new Philips sets does this as well? Try turning the TV off and then on to force a new EDID-handshake. Sort of works on the ancient set I struggle with.

I rebooted the Vero today (It choked on a corrupt video file), that didn’t solve the issue.
Will try to power cycle the TV and report back.

Note that I didn’t have this issue before and have been using the Vero since March or so with some issues related to older Philips TV sets, that got sorted out with/by Sam.

I have a green line since I switched an old Philips TV to PC to disable overscan. Otherwise it would try to zoom the picture etc… I try to ignore it. The TV is 10 years old and I lost the remote (using a cheap replacement universal remote) so not much options to go mess in the config.

Check if you can change the config of the source from PC to something else.

If it happens on Pi too, it could be a fault with the TV or a settings issue.
Can you post some logs so we can learn more about the TV and just before this can you try enabling Force RGB under Settings -> Display?

What’s the model of the TV?


Yes, model info of the Philips TV would be helpful.
Meanwhile I found this

I had a TV once that also had a green line. My issue now is different.

I have Philips 56PFL9954H a 21:9 model.
Force RGB is already enabled because of another issue wirh funky colors.
What log should I post?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

In addition:

A screenshot taken with OSMC and one with a digital camera from such scenario would be fine:

  1. login to osmc via ssh and start command
    kodi-send --action=takescreenshot
    (might be be you’re asked where to place the picture file)

  2. take a screenshot with your mobile phone or any camera

upload both pictures here. With thx in advance.

The TV’s manual ( tells in chapter

6.4 Picture, page 262

that you can easily adapt the position of the picture with the cursor keys of your original remote control. Have you tried this?

Sorry about the lack of logs &c. Here goes:

Link to Upload Log:

Screenshot of Kodi

Photo of TV at same screen (notice scroll bar on the left side)

Rebooting does not seem to have any effect. Also turning the TV off/on does not do anything it seems.

But… Today I came home my girlfriend was watching something and after that the line was gone. It seems playing the movie I watched yesterday somehow ‘reset’ the line. Playing and stopping an episode of the series she watched and the line returns. So I tried this again, but second (and more) time the line does not disappear. Hopefully the logs tell us something already.

I will try to experiment more to reproduce.

I’m using the aspect setting ‘Niet op schaal’ (dutch for not to scale) which is a PC setting without overscan. Been using this mode for years now. When using a setting with overscan, the line disappears in the overscan.


The log shows that Vero is doing the right thing. Nothing abnormal from the log.
Please do some testing and keep up posted.

Well, I’ve two supplementary notes:

  1. Your default GUI display resolution is currently DESKTOP:
     <screenmode default="true">DESKTOP</screenmode>

So, go to GUI->Settings->System->Display and change the resolution to 1920x1080p.

  1. It looks like you manually calibrated the 1920x1080p 23.98fps resolution.
            <description>1920x1080 @ 23.98 - Full Screen</description>

I don’t know whether this is part of the problem with your TV or part of a solution. In case this is unwanted, change the GUI resolution to 1920x1080 with refresh rate 23.98, go to the calibration menu at the bottom of the menu where you can change back the deviations to 0.

My guess is that has something to do with manual calibration settings getting lost with the latest update.

So whatever screen calibration adjustments were done, they get lost sooner or later (still no idea when it happens, seems random). If you have multiple adjustments „outside the norm“ and one of them suddenly stops working, the result would probably look like it does here.