Struggling with a fresh install

Hi all,

My SD card pooped out on me today and I’m struggling to install OSMC on my RPi using a new card. I believe OSMC installed correctly, but I’m not able to connect to the internet. I’m getting the “no internet” message on My OSMC>Networking.

I’m using the OSMC wifi adapter. It sees my SSIDs and I’d like to connect to the 5G SSID. This has worked before, but now I get “no internet”. I seem to recall there are some things I need to do to configure the OSMC dongle but I’ve long since forgotten how to do that and I’m struggling to fine the right thread here.

I’m hoping this is the only issue I need to address to get things up and working again. If so, maybe I’ll spend some time learning how to make backups so that if this happens again, I’ll be better prepared.

Thanks very much for any help.

https://discourse.osmc.tv/search?q=@frogfan%20wifi%20order:latest

There is a searchbar at the top of the site and you can “@” a username in the search.

With a bit of help from @darwindesign, I came across this thread/post. Another case of OSMC dongle won't connect at 5G - #111 by sam_nazarko

Hello again.

I really appreciate everyone’s help, and I’ll try to be more careful to search before I post additional questions.

My problem now is accessing my SMB shares. I got good direction here a month or so ago, but when I try to apply the same steps on my new configuration, I get the error “Operation not permitted”. Here are the logs from my most recent session:

https://paste.osmc.tv/mocepumahi

Thanks again very much for your assistance.

Ed

https://discourse.osmc.tv/search?q=smb%20%22Operation%20not%20permitted%22

OK. I’ll go through these posts to see if I can find out what’s wrong. The first one seemed to say that I need to set the minimum and maximum SMB versions to SMBv3. I did that, and I still get “Operation not permitted”. So, the search continues.

Please note this: I went through the exact steps prescribed awhile back to me and they did not work, either, even though they did work at the time they were prescribed. Something is different with the new installation. I did note that the “new” version I’m trying to run had the min SMB version unset and the max was set to SMBv3. I can’t remember how these were set in the old version I was running.

I also scanned the logs I posted and found this:

Dec 02 14:31:44 osmc sudo[496]:     osmc : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/usr/bin/mv /var/tmp/config.txt /boot/config.txt
    Dec 02 14:31:44 osmc sudo[496]: pam_unix(sudo:session): session opened for user root by (uid=0)
    Dec 02 14:31:44 osmc mediacenter[319]: mv: failed to preserve ownership for '/boot/config.txt': Operation not permitted
    Dec 02 14:31:44 osmc sudo[496]: pam_unix(sudo:session): session closed for user root

This excerpt seems to suggest a problem but my lack of technical knowledge prohibits me from understanding it. Is the SMB version issue related to the “failed to preserve ownership” issue?

If you could give me a quick steer on the above, I’ll continue to slog through the posts you link to try to find my problem.

Thank you.

Hi,

I would try min version smbv2, if that fails try smbv1.

Thanks Tom.

Thanks Tom. No joy. Operation not permitted with min version set to SMBv1 and SMBv2. (Max version set to SMBv3.

There is something different about the “new” version I’m running from the old one. I did not get this error with it. Adding SMB shares was quite straightforward: Videos>Files>Add videos…>Browse>Add network location…, then enter
Protocol: Windows network (SMB), Server name: ServerName. Then “OK”.

That puts smb://ServerName/ on the list of sources to browse, but when I click on it, I get “Operation not permitted”. On the “old” system, when I clicked on smb//ServerName, I got a list of shared directories.

I feel like I’m running out of options to try. I’ve read through the posts you link to, and I can’t find anything helpful.

Thank you again.

Ed

You would need to enable debug logs with component specific for SMB. Try to connect and then upload the logs for us to help.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • enable component-specific logging for all components

  • enable event logging and notification event logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshots:

Thanks very much for your help and patience. I did as you requested. Here are the logs:

paste.osmc.tv/ifiwuvexuh

Sorry, I missed the last page of your screenshots and hence missed some of the component logging. I think these logs include everything you’re looking for.

paste.osmc.tv/qududozime

Apologies for any confusion.

This seems to be the respective error.
Not sure if it is a Kodi issue or not. I don’t have a system on my side to test.
I only can suggest to move to use kernel based mounts (fstab or autofs) to avoid these issues.

Dec 02 17:51:39 osmc mediacenter[327]: SPNEGO login failed: {Access Denied} A process has requested access to an object but has not been granted those access rights.

Thank you, @fzinken

I have to say I’ll do almost anything to avoid the Linux command line :grin:.

That said, this strikes me as a very curious problem. I had been running the latest November release and adding shares (and accessing existing shares) since it came out and even before that, in October. The last time I had a problem was when Windows update deleted support for SMBv1 and I had to go though the process I described above to add shares.

Because of this, I don’t understand how it could be a Kodi problem. I’m no expert, but it seems like the problem is being caused by a default setting in the October release that I installed, that perhaps pre-dates the fixes I made in October.

I see that OSMC is telling me it has an update is ready. I’m going to install it and try this again. Failing that, I guess I’m going to have to get up on the Linux command line. :stuck_out_tongue_closed_eyes:

Thanks again for your help.

I updated to 2020.11-1. When the RPi rebooted, it failed to connect to my wifi network, so I booted it again and it did. Not sure what happened there; it’s off topic here but I thought I’d mention it.

I tried to add the shares again. No joy. Operation not permitted.

Ed

I would venture a guess that you don’t have guest sharing allowed on Windows (which is stock for security reasons just like SMBv1 being disabled) and in your old setup you didn’t have to enter credentials in that other thread because that was already previously done and they were stored in your passwords.xml. If this is the case then you would go back to the network source you added, context menu, edit, then add a valid username and password from your PC.

This is it!

Here’s what happened. Several years ago when I first set OSMC up, I used fstab to mount some videos. To do that, I had to enter a username and password. To your point, that username and password was saved and used when I began to use SMB to access videos. I didn’t enter a password and didn’t need to, not because I set up the files without passwords, but rather because I already had access to the computer itself due to the fstab I set up.

So, I set up a user and password for OSMC on my server and supplied to credentials when I defined the share. All of the shared directories are now accessible.

Thank you!

1 Like

Remember to disable all the component specific logging

Done! Thanks again!

Just to summarize my experience – and to complete my understanding – I struggled with two issues with my fresh install. One was the SMB “Operation not permitted” problem. The solution to this problem is highlighted directly above.

The other problem I had was with establishing and maintaining an internet connection. I’m using the OSMC 5G wifi adapter, and I had to do two things to make it work (if you’re not using that adapter, I suspect you won’t need to do these things):

Add the following line to the config.txt file:

dtoverlay=sdhost

This can be done within My OSMC and it disables the onboard RPi wifi adapter.

In addition to the above, I had to run the following command from the Linux command line:

sudo mv /lib/firmware/mt7610u_sta.template.dat /lib/firmware/mt7610u_sta.dat

My Linux knowledge is very sparse, and I don’t know what the above command does. I can say that, before running that command, the OSMC adapter saw 10-15 SSIDs, in my neighborhood, some 2.4G and some 5G, including my 2.4G and 5G SSIDs. After running that command, the adapter saw only two SSIDs, both 5G and, thankfully, one of them was mine. Right now, if I wanted to connect at 2.4G (I don’t), I could not do it. I’ll also note for completeness that I often lose internet connectivity if I reboot OSMC and have to re-enter my credentials for my SSID. This was not a problem with my “old” installation. I may have forgotten another setting or command from the old installation.

I had done both of these things in the old installation but I forgot about them. I suspect if I’d maintained backups of my SD card, I would have saved myself, and others here who helped, considerable time.

Again, my thanks to the group here for the great support. I really enjoy using OSMC.

If you used the backup tool in the My OSMC add-on then you would have still had to deal with the wifi issue, but your Kodi configuration would have been restored. If you had pulled the SD card and imaged the whole thing on a PC with something like Win32DiskImager then that would have covered the OS as well.