Stuck on "Please stand by"

My Vero 4K is stuck on “Please stand by”. Was thinking that maybe the boot image got corrupted, so downloaded the most current boot image, and burned it onto a brand-new 64GB SD card. No joy, keeps staying “Please Stand By” on boot. Tried two different HDMI cables on two different monitors.

Any ideas ?

Can you show a screenshot of the SD card content so we can verify it was working properly?

Do you have a USB to try?

What was the last thing you were doing when the device was working?


Quick reply, thanks ! I think you’re looking for a copy of the original SD card that was in the device when it failed ? Sure, I can get that for you.

“Do you have a USB to try”. Not sure what you mean by that. a USB disk drive ? Sure. I take that back, I have a USB key available, which should be equivalent. I guess I would have to put the boot image on that ?

Here’s a screenshot of the original SD card that was in the Vero 4K

“What was I doing on the Vero 4K when it failed ?” Unsure. This is my family’s main show-watching device, and they informed me that when they went to use it a few days ago, it simply wouldn’t “come one”. I examine it, and the red light was solid on the front.

Here’s what I just tried:

  1. I used rufus to write a verk 4k disk image to a 32GB usb key.
  2. I removed the SD card from the Vero 4K, and inserted the USB key.
  3. Turned on the Vero 4K, red light lit for about 10 seconds then went out (I’m guessing that it was building from the USB key). During the 10 seconds, screen was blank
  4. Red light came back on, and screen says “Please stand by”
  5. Screen says “Please stand by” for 8 seconds, then goes blank. At same time, the red light comes on.
  6. Repeats and repeats…

Hmmm… this is interesting. After it cycled for about 10 to 15 “Please stand by” messages, it came up with a pretty blue “OSMC” screen that says

“You have XX seconds to power down before device is formatted…”

And now it says “Installing files…”

Ended up with a Unhappy Face icon in the center of the screen. Power cycled the Vero 4K to see if that helped, ended up with same frowny face on the screen.

The screenshot you’ve showed is the contents of a Raspberry Pi SD card image and this won’t reinstall OSMC on a Vero.

That probably explains why it would not initially reinstall.

The sad face on boot is odd. But could be indicative of a corrupted download or bad installation medium. Could you try on the SD card using that Vero image and when prompted by the installer if you’d like to redownload the image, press Yes.

  1. Deleted everything in my temp directory (all previously downloaded images)
  2. Re-ran OSMC installer, selected “Vero 4K”
  3. Selected 2nd-newest Image available (figuring maybe newest wasn’t a good idea while troublehsooting this)
  4. Watched as it downloaded the image for me
  5. Selected 64 GB micro SD card, successfully wrote image to SD card
  6. Inserted that SD card into Vero 4K, booting now…
  7. Included screenshot of contents of the SD card after writing to it

  1. Booted device from SD card (previous post)
  2. Red light stayed on for 8 minutes solid.
  3. Red light went off (presumably because install was finished ?_
  4. “Please stand by” flashed briefly on the screen
  5. Red light came on briefly
  6. “Please stand by” flashed briefly on the screen
  7. Red light came on briefly
  8. “Please stand by” flashed briefly on the screen
  9. Red light came on briefly
  10. “Please stand by” flashed briefly on the screen
  11. Red light came on briefly
  12. This kept repeating…
  1. After watching “Please stand by” cycle onto the screen about every 9 seconds for 5 minutes
  2. I decided to repeat the procedure (downloading Vero 4K image) onto a USB Key rather than SD Card
  3. On initial boot, said “Please stand by again” (just once)
  4. Immediately switched to OSMC screen saying “You have 60 seconds to power down before the device is formatted”
  5. I dutifully waited the 60 seconds…
  6. said “Formatting device”
  7. then “Installing files”
  8. Rebooted a few times, showing linux-like boot screens
  9. Then flashed a sad face a few times (guessing that these were individual boot attempts ? Though the light on the front never came on during the sad face sequences, unsure if that’s relevant)
  10. Going to let the sad face continue to flash for a while…

Is the device connected directly to the wall?

I’m not sure I follow. Ah, perhaps you mean the network connection ? Nope. I’m relying on wireless (wifi).


Sam is talking about the PSU Is it directly plugged into the wall power socket? Or is it plugged into an Extension Power cable?


1 Like

Thanks for the clarification @Tom_Doyle. The provided power supply (i.e. “wall wart”) is plugged into a power strip. It is not plugged directly into an AC outlet. I’m dying to know how that would influence the outcome here, always fun to learn new things about small electronics :slight_smile:

We don’t recommend using power strips or extension chords as it usually leads to problems after some time.

Can you try powering the device directly from the wall?

Okie doke.

  1. Will power directly from wall socket
  2. Will re-download install image for Vero 4K to USB stick
  3. Will plug USB stick into Vero 4k (plugged into wall) and reboot to trigger install
  4. Will report back when complete.

If you’ve been using a power strip, the damage may be done.

The reason why we don’t advise that they are generally used is because we’ve found that cheap and cheerful ones will damage the power supply (and potentially the device) by fluctuating voltage which is slightly ironic…

The good news is that this is generally rare, and usually only the power supply is damaged in the process.

Keep me posted


No joy, eventually seeing the same sequence. “Please stand by”… (reboot?) “Please stand by”…