Stuttering after 2018.08 update

I’m using OSMC on an Pi1 Rev B (I know, I know).
This has been running remarkably well for a long time.

But after installing the 2018.08 updates this morning everything started to stutter. Before this it was running the 2018.07 release

By everything I mean:

  • skin, including skin sound effects
  • videos (mostly get-iplayer downloads): again video and sound. Videos are streamed from an NFS source.
  • live streaming seems to be better, although I noticed the odd minor hiccup even there just now.

Any ideas what could be the cause. Possible solution?
Can I give any more useful information?

1 Like

In designing our forum here, we made certain that when every user makes their very first post they are prompted to read this
https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

2 Likes

I’m having the exact same problem, on a Raspberry Pi B+. When I stop the stuttering video, then go to System Info, it shows the System CPU usage at 100%. Eventually it calms down, but the stuttering problem remains.

6 posts were split to a new topic: Pi3 stuttering with August update

Same problem here on a Pi2:
https://paste.osmc.tv/fegaguyeki

Good morning

A similar situation I have. The stutter is already in the idle. Working isn’t possible. CPU utilization is usually 100%.

Raspberry Pi Model B Rev 2

https://paste.osmc.tv/dizavupudi

Thank you for your support.

Regards

Andreas

Uploaded the log: https://paste.osmc.tv/afiqajaxis

As I mentioned this is on a Pi Model B rev 2 (512MB).
CPU generally 100%, with Kodi taking 90%+ and when playing downloaded video (BBC getiplayer) FPS is 10 or lower.

Can you show the output of top or htop?

Sam

Output of top while playing a video (BBC-iplayer) from NFS share).
Kodi logging is switched off now.

 top - 12:34:40 up 3 min,  2 users,  load average: 3.62, 1.70, 0.68
Tasks:  75 total,   2 running,  46 sleeping,   0 stopped,   0 zombie
%Cpu(s): 26.8 us, 58.7 sy, 11.7 ni,  0.0 id,  0.0 wa,  0.0 hi,  2.8 si,  0.0 st
KiB Mem :   360520 total,    85740 free,   101000 used,   173780 buff/cache
KiB Swap:        0 total,        0 free,        0 used.   228792 avail Mem

  PID USER      PR  NI    VIRT    RES    SHR S %CPU %MEM     TIME+ COMMAND
  297 osmc      20   0  676348 128936  57088 S 58.7 35.8   1:59.68 kodi.bin
   73 root      20   0       0      0      0 I 10.9  0.0   0:10.76 kworker/0:3
  676 osmc      20   0    5536   3020   2448 S  4.8  0.8   0:04.09 tmux: server
  756 osmc      20   0    6444   2844   2364 R  1.9  0.8   0:01.42 top
  625 osmc      20   0   11428   3980   3240 S  1.3  1.1   0:00.84 sshd
    7 root      20   0       0      0      0 S  1.0  0.0   0:00.87 ksoftirqd/0
   51 root       1 -19       0      0      0 S  1.0  0.0   0:01.39 vchiq-slot/0
 1916 osmc      20   0    1872   1224   1072 S  1.0  0.3   0:00.03 byobu-status
    8 root      20   0       0      0      0 R  0.3  0.0   0:00.72 rcu_preempt
  155 root      20   0       0      0      0 I  0.3  0.0   0:00.20 kworker/u2:2
 1914 osmc      20   0    1872   1156   1084 S  0.3  0.3   0:00.01 sh
    1 root      20   0   26884   6028   4996 S  0.0  1.7   0:02.80 systemd
    2 root      20   0       0      0      0 S  0.0  0.0   0:00.00 kthreadd
    3 root      20   0       0      0      0 I  0.0  0.0   0:00.00 kworker/0:0
    4 root       0 -20       0      0      0 I  0.0  0.0   0:00.00 kworker/0:0H
    5 root      20   0       0      0      0 I  0.0  0.0   0:00.00 kworker/u2:0
    6 root       0 -20       0      0      0 I  0.0  0.0   0:00.00 mm_percpu_wq
    9 root      20   0       0      0      0 I  0.0  0.0   0:00.00 rcu_sched
   10 root      20   0       0      0      0 I  0.0  0.0   0:00.00 rcu_bh
   11 root      20   0       0      0      0 S  0.0  0.0   0:00.01 kdevtmpfs
   12 root       0 -20       0      0      0 I  0.0  0.0   0:00.00 netns
   13 root      20   0       0      0      0 I  0.0  0.0   0:00.17 kworker/0:1
   14 root      20   0       0      0      0 S  0.0  0.0   0:00.00 khungtaskd
   15 root      20   0       0      0      0 S  0.0  0.0   0:00.00 oom_reaper
   16 root       0 -20       0      0      0 I  0.0  0.0   0:00.00 writeback
   17 root      20   0       0      0      0 S  0.0  0.0   0:00.00 kcompactd0
   18 root       0 -20       0      0      0 I  0.0  0.0   0:00.00 crypto
   19 root       0 -20       0      0      0 I  0.0  0.0   0:00.00 kblockd
   20 root       0 -20       0      0      0 I  0.0  0.0   0:00.00 watchdogd
   21 root       0 -20       0      0      0 I  0.0  0.0   0:00.00 rpciod
   22 root       0 -20       0      0      0 I  0.0  0.0   0:00.00 xprtiod

hi,

same issue here with rpi1 b

frames while idle average only around 8fps while cpu usage is around 90%

here goes top:

osmc@osmc-rpi1:~$ top
top - 20:24:55 up 13 min,  1 user,  load average: 1.05, 1.65, 1.31
Tasks:  74 total,   2 running,  45 sleeping,   0 stopped,   0 zombie
%Cpu(s): 17.2 us, 23.2 sy, 39.5 ni,  9.2 id,  0.0 wa,  0.0 hi, 10.8 si,  0.0 st
KiB Mem :   360520 total,    20764 free,   140044 used,   199712 buff/cache
KiB Swap:        0 total,        0 free,        0 used.   190308 avail Mem

  PID USER      PR  NI    VIRT    RES    SHR S %CPU %MEM     TIME+ COMMAND
  357 osmc      20   0  731412 161044  57248 R 80.3 44.7  10:07.17 kodi.bin
 1354 osmc      20   0    6444   2860   2408 R  1.6  0.8   0:00.32 top
    7 root      20   0       0      0      0 S  0.6  0.0   0:03.99 ksoftirqd/0
    8 root      20   0       0      0      0 I  0.6  0.0   0:04.19 rcu_preempt
   51 root       1 -19       0      0      0 S  0.3  0.0   0:04.92 vchiq-slot/0
    1 root      20   0   26912   5928   4872 S  0.0  1.6   0:02.83 systemd
    2 root      20   0       0      0      0 S  0.0  0.0   0:00.00 kthreadd
    4 root       0 -20       0      0      0 I  0.0  0.0   0:00.00 kworker/0:0H
    5 root      20   0       0      0      0 I  0.0  0.0   0:00.07 kworker/u2:0
    6 root       0 -20       0      0      0 I  0.0  0.0   0:00.00 mm_percpu_wq
    9 root      20   0       0      0      0 I  0.0  0.0   0:00.00 rcu_sched
   10 root      20   0       0      0      0 I  0.0  0.0   0:00.00 rcu_bh
   11 root      20   0       0      0      0 S  0.0  0.0   0:00.01 kdevtmpfs
   12 root       0 -20       0      0      0 I  0.0  0.0   0:00.00 netns
   13 root      20   0       0      0      0 I  0.0  0.0   0:03.55 kworker/0:1
   14 root      20   0       0      0      0 S  0.0  0.0   0:00.00 khungtaskd
   15 root      20   0       0      0      0 S  0.0  0.0   0:00.00 oom_reaper

logs:
https://paste.osmc.tv/wuyewuwifa

Same prb here
Shuttering audio and video and cpu @100% during play

RP1 mod b

Here is the top output

top - 23:42:00 up 24 min, 1 user, load average: 0.32, 0.67, 0.75
Tasks: 84 total, 1 running, 55 sleeping, 0 stopped, 0 zombie
%Cpu(s): 22.4 us, 2.3 sy, 1.0 ni, 74.2 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
KiB Mem : 360520 total, 47072 free, 117328 used, 196120 buff/cache
KiB Swap: 0 total, 0 free, 0 used. 200872 avail Mem

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
403 osmc 20 0 628712 128104 55252 S 23.3 35.5 7:09.20 kodi.bin
1314 osmc 20 0 6444 2772 2232 R 1.9 0.8 0:10.57 top
8 root 20 0 0 0 0 I 0.3 0.0 0:01.59 rcu_preempt
51 root 1 -19 0 0 0 S 0.3 0.0 0:10.53 vchiq-slot/0
538 ntp 20 0 8024 3508 3056 S 0.3 1.0 0:00.62 ntpd
1280 osmc 20 0 11428 4340 3588 S 0.3 1.2 0:00.95 sshd
1 root 20 0 26984 6096 4940 S 0.0 1.7 0:04.81 systemd
2 root 20 0 0 0 0 S 0.0 0.0 0:00.00 kthreadd
4 root 0 -20 0 0 0 I 0.0 0.0 0:00.00 kworker/0:0H
5 root 20 0 0 0 0 I 0.0 0.0 0:00.28 kworker/u2:0
6 root 0 -20 0 0 0 I 0.0 0.0 0:00.00 mm_percpu_wq
7 root 20 0 0 0 0 S 0.0 0.0 0:00.69 ksoftirqd/0
9 root 20 0 0 0 0 I 0.0 0.0 0:00.00 rcu_sched
10 root 20 0 0 0 0 I 0.0 0.0 0:00.00 rcu_bh
11 root 20 0 0 0 0 S 0.0 0.0 0:00.01 kdevtmpfs
12 root 0 -20 0 0 0 I 0.0 0.0 0:00.00 netns
14 root 20 0 0 0 0 S 0.0 0.0 0:00.00 khungtaskd
15 root 20 0 0 0 0 S 0.0 0.0 0:00.00 oom_reaper
16 root 0 -20 0 0 0 I 0.0 0.0 0:00.00 writeback
17 root 20 0 0 0 0 S 0.0 0.0 0:00.00 kcompactd0
18 root 0 -20 0 0 0 I 0.0 0.0 0:00.00 crypto
19 root 0 -20 0 0 0 I 0.0 0.0 0:00.00 kblockd
20 root 0 -20 0 0 0 I 0.0 0.0 0:00.00 watchdogd
21 root 0 -20 0 0 0 I 0.0 0.0 0:00.00 rpciod
22 root 0 -20 0 0 0 I 0.0 0.0 0:00.00 xprtiod
23 root 20 0 0 0 0 S 0.0 0.0 0:00.00 kauditd
24 root 20 0 0 0 0 S 0.0 0.0 0:00.00 kswapd0
25 root 0 -20 0 0 0 I 0.0 0.0 0:00.00 nfsiod
47 root 0 -20 0 0 0 I 0.0 0.0 0:00.00 kthrotld
48 root 0 -20 0 0 0 I 0.0 0.0 0:00.00 iscsi_eh
49 root 0 -20 0 0 0 I 0.0 0.0 0:00.00 dwc_otg
50 root 0 -20 0 0 0 I 0.0 0.0 0:00.00 DWC Notificatio
52 root 1 -19 0 0 0 S 0.0 0.0 0:00.63 vchiq-recy/0
53 root 0 -20 0 0 0 S 0.0 0.0 0:00.00 vchiq-sync/0
54 root 20 0 0 0 0 S 0.0 0.0 0:00.00 vchiq-keep/0
55 root 10 -10 0 0 0 S 0.0 0.0 0:00.00 SMIO
56 root 20 0 0 0 0 I 0.0 0.0 0:00.05 kworker/u2:1

Just updated my RPI2 this evening and also experiencing the sound stuttering, except mine is happening from the very start. Looking at the System Info, the CPU is permanently running at 100% and ‘Memory used’ just continues to creep up. Prior to doing the debug option to generate the log files, the RPI2 had been running for just over one hour and memory used was up to 49% with it not doing anything at all.

The log files are here: https://paste.osmc.tv/icahoyuduz

Is there any way to revert back to the July update in the meantime, as nothing is watchable at the moment?

I downloaded and installed the July version to a fresh card and then put back the OSMC settings backup. You can find the images at the bottom of the download page.

Hi All,

I’m not sure if my issue is related, but thought it worth mentioning.

I have experienced a similar issue after this update on my pi3… symptoms were OSMC gui ran fine but audio and then video freezes after approx 2-3 mins of playback. Cpu levels all look ok and I could still ssh in to reboot.

My issue seemed very similar to another issue I had after an update back in January… back then @sam_nazarko advised me to roll back to the previous kernel version… Please see this thread for details:

https://discourse.osmc.tv/t/all-videos-hang-after-jan-update/

After experiencing this again with 2018.08 update I revisited this thread and followed the instructions again to roll back the kernel version. This time to rbp2-image-4.14.34-4-osmc

This seems to have fixed the issue for me… videos now play again with no freezing.

My logs, in case they are useful…
https://paste.osmc.tv/kavuyonure

Hopefully this might assist in finding the root cause of these issues…

Good luck all

Does the OSMC backup contain all the thumbnail images for the movies and shows that I have on my NAS drives, or will I have to let it scan everything again? Have never had an issue with the RPI2 until now, so not familar with the backup option.

Should do, yes. You can scroll down to see all the portions that can be in/excluded.

I can verify that I had this problem on my Pi 2. Did a downgrade of the kernel and the problem is fixed. It’s an easy fix, just ssh in: https://osmc.tv/wiki/general/accessing-the-command-line/

and run this command:

sudo apt install --reinstall rbp2-image-4.14.34-4

and then reboot

sudo reboot

Of course that’s for a Pi2, not a Pi1.
I assume Pi1 needs ‘rbp1-image-’ etcetera

Yes.

Reverting to the previous kernel seems to solve the problem. No more stuttering :smile: