Stuttering after 2018.08 update

It makes it much easier for me to identify the users affected by a specific issue, as well as update the users of the specific issue when it is resolved, instead of everyone who subscribed to notifications on the release thread by making a post.

I am working on a solution now.

hey guys
just a quick one

my sd card failed today, so i had to do a reinstall.
got my network shares back and can stream shows and music from my server, but there is a problem.

no matter if its mp3 or a video (x264) the sound is jerky and also in the video files, the video is jerky too.

can anyone maybe shed some light on what i might have missed on setup?
i am using a b+ pi with osmc.tv.

regards,
goat

Hi,

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Regards Tom.

https://paste.osmc.tv/facodoquso

A post was merged into an existing topic: Pi3 stuttering with August update

Hi mangoat1,

There is a proper fix on the way, in the mean time I suggest trying this:

Thanks Tom.

Hi

Hopefully the issue is now addressed

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

First, @sam_nazarko, thank you SO much for RaspBMC and all the work you have done since a long long time back. Been a lurking fan since my first Pi B. Second, I tried the above with a Pi Zero and it did not solve the issue. :frowning: Sorry to be the bearer of bad news.

Logs Here: https://paste.osmc.tv/ekehetixas.vhdl

cat /proc/cpuinfo shows:

processor : 0
model name : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS : 847.52
Features : half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xb76
CPU revision : 7

Hardware : BCM2835
Revision : 900093
Serial : 0000000017c26e34

This is the first report of someone with a Pi Zero reporting the issue. The fix was for Pi 1/2, so it would be good to post logs.

@Tom_Doyle thanks, once i figured out how to use ssh, i did as you said and its rectified the situation.

cheers.
goat

1 Like

Added logs to original message. Let me know if you want me to do another “upgrade” back down to the original version to run it.

Instead of :

How do I get a list of valid packages that match this? I didn’t see anything for Pi Zero searching for

apt-cache search rb

nor

apt-cache search zero

Just confirming that the development update (4.14.34-6-osmc) appears to be working without issue on a Raspberry Pi B+.

Thanks for the quick turnaround on this Sam. :+1:

Answering my own dumb question, the Pi Zero uses the same image as the Pi 1, therefore

sudo apt install --reinstall rbp1-image-4.14.34-4

Works fine and in fact fixed my issue also.

Note: I think I ran 4.14.34-5 not 4.14.34-6 in my test on the Zero. 4.14.34-6 Was not available at the time.

Yes, seems to solve the problem on my Pi B rev 2.
Thanks @sam_nazarko

4.14.34-6 Confirmed working on RPi Zero.

Raspberry Pi Model B Rev 2 works well with the 4.14.34-6.
Thanks @sam_nazarko

I’ve pushed these fixes as an update now. Thanks for testing.