Stuttering at start of video, then lip sync loss

I have played this file on my PC using VLC, it plays fine, on Vero V it stutters at the start , if I pause it cures it when restarted but gradually looses lip sync over the next few minutes (the other files in the series behave the same). Any reason why?

Unique ID :
Complete name : T:xxxxxxxxx .mkv
Format : Matroska
Format version : Version 4
File size : 2.16 GiB
Duration : 51 min 14 s
Overall bit rate : 6 037 kb/s
Frame rate : 25.000 FPS
Writing application : mkvmerge v74.0.0 (‘You Oughta Know’) 64-bit
Writing library : libebml v1.4.4 + libmatroska v1.7.1

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4
Format settings : CABAC / 2 Ref Frames
Format settings, CABAC : Yes
Format settings, Reference frames : 2 frames
Format settings, GOP : M=3, N=50
Duration : 51 min 14 s
Bit rate mode : Constant
Bit rate : 6 000 kb/s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 25.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.116
Stream size : 2.11 GiB (98%)
Default : Yes
Forced : No

ID : 2
Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Codec ID : A_AAC-2
Duration : 51 min 14 s
Bit rate : 125 kb/s
Channel(s) : 2 channels
Channel layout : L R
Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 SPF)
Compression mode : Lossy
Stream size : 45.9 MiB (2%)
Language : English
Default : Yes
Forced : No

Text #1
ID : 3
Format : UTF-8
Codec ID : S_TEXT/UTF8
Codec ID/Info : UTF-8 Plain Text
Duration : 49 min 19 s
Bit rate : 47 b/s
Frame rate : 0.197 FPS
Count of elements : 583
Stream size : 17.1 KiB (0%)
Language : English
Default : No
Forced : No

Text #2
ID : 4
Format : UTF-8
Codec ID : S_TEXT/UTF8
Codec ID/Info : UTF-8 Plain Text
Duration : 49 min 19 s
Bit rate : 52 b/s
Frame rate : 0.234 FPS
Count of elements : 694
Stream size : 19.1 KiB (0%)
Title : SDH
Language : English
Default : No
Forced : No

Can you post logs, please, so we can see your setup.

Yes but not until later, frame rate is 25, Vero V showed it as 50 when I checked info last night

I just tried a .vob from the same file, Vero V shows 25fps and it plays perfectly, its getting the .mkv frame rate wrong ( I have checked the files on a few video converters, they all see 25fps) why 50fps on Vero V, nothing to do with my setup!

Those two are contradictory. There’s a setting which makes Kodi prefer double refreshrates.

Does that Kodi setting only affect. MKVs then?

That’s not expected. Without logs, I couldn’t begin to speculate why your two files are playing differently.

We know some 25Hz videos can be troublesome. Make sure the option to use double refreshrates is turned off in settings and let us know if that cures it.

Cant find that setting anywhere

You need to set the settings level to ‘Expert’ and specify a whitelist under Display. IIRC without a whitelist double refreshrates are always used for framerates less than 30Hz.

Have a look here for everything on whitelists

Thanks for that, still no good, logs here /udecohoseb

Thank you. The video is playing at 50Hz beacuse your TV doesn’t support 1080p25hz. And there’s this in the logs

2024-03-17 21:01:12.831 T:3318    debug <general>: CalcFrameRate counted 1000 frames without being able to calculate the framerate, giving up

I can’t recall ever seeing that before. Maybe someone else can shed some light on that.

Possibly bad rip.

As regards, bad rip, the files have been through ffmpeg, tsmuxer (in my experience very fussy as regards bad rips) AV2HDR and then played perfectly on a 2008 Humax Foxsat HDR (also very fussy) one of these would have flagged errors, VLC plays the original.mkv files perfectly on my PC. I have run them through Aiseesoft HD converter and the.vob files play on my Vero V perfectly at the same frame rate (the TV will play 25fps after all)

From your logs it would be output at 50Hz

Have you looked at the screen shot Sam?

There is the problem,.vob plays at 25fps, mkv at an erroneous 50fps

The screenshot shows decode frame rate not output frame rate. Your display doesn’t support or advertise support for 25p output. It advertises:


So why does the vob play fine?

Maybe a clue, if I allow refreshrate doubling even the vob gets jerky but audio sync is still fine

The whitelist does not list 1080p 25hz