Stuttering video 25hz tvshows

Since november update I’ve been experiencing serious issues trying to play TV Shows with 25 fps framerate.

It seems unable to keep the sync/pace.

Zero issues before update.

A non trivial issue since I usually see a lot 25 fps european content

Logs are here, at the end you can check the log while playing such kind of media

Thanks in advance.

Add the other 1080p refresh rates to your whitelist and your problem should go away. I assume by your settings that your trying to force upscaling to 4K and currently that is not possible outside of manually setting it. With your settings as they are now Kodi is figuring your desktop resolution and frame rate is the closest match so it is playing the 25fps resampled to 60 and causing problems. If you have 1080p 50 in your whitelist it would use that and should display flawlessly.

Your TV very likely has a better upscaler so best to use that. If you want to avoid double scaling then you can whitelist lower resolutions to avoid this.

Nothing is solved. Still the same issues.

Updated logs

Please, keep in mind that just minutes before the update I had zero issues with this kind of content. The issues arose just after applying november update. And this update came with some new firmware for the video codec, if I’m not wrong as it’s stated in release notes.

Thanks in advance.

Although there was changes to the video codec there was also changes to how the whitelist works and that seemed to me to be more likely to be the issue. I did however make a mistake when I glanced over your logs as somehow I was reading them as a 60hz desktop and two different 4K resolutions at various frequencies as being whitelisted. On a second look I see that before you actually had various frequencies whitelisted in Full HD and 4K. Sorry about that.

Can you put one of these files that is not playing back correctly in a thumb drive or something and see what happens playing it back locally.

No network issues. I can play flawlessly 4k HDR big files.

24fps material works great.

Is it possible to go back to to the previous version without full reinstall ?


Well. I hope in the next days some solution or guide could be provided to solve this.

You could try the staging repository to see if it improves things.

I’m having a similar issue. Before upgrade everything was smooth, but after it I’ve got a lot of stuttering problems.

Full logs here:


I can add a “me too”. Also watching same 25 Hz Videos, they stutter terrible. I’ve made some observations, which might be useful:
Before the relevant Update in late November I used the same whitelist as now. To get rid of some micro stutter, only noticeable if waiting for it, I had to disable the doubling of the refresh rate in Settings->System->Display.
After the late November update it is a pain to view the same videos in this setting. My Samsung TV connected to a Vero 4k+ is showing fine at 25 Hz (as shown by the TV-set itself) for the first 1-2 seconds. Then the sceens blacksout shortly and after coming again the refresh rate is 50 Hz and stutter is unbearable.
If refresh doubling is enabled in Kodi stuttering is back to microstutter as before the update.
It seems as if refresh doubling is in effect, while with a 1-2 seconds delay, when disabled in Kodi and then disturbing the whole timing.
Another weird effect: The behavior described above is applicable only to content up to FHD. If I show 4k@30Hz I have to disable refresh doubling because of stutter aŧ the doubled 60 Hz. On 4k@30Hz and refresh doubling disabled all is fine, the refresh rate stays at the lower value as long as the video is played.
The setting adjust refresh rate in Player->Video to “at start/stop” or always has no effect on this behavior.
UI is set to 1080p@60hz, whitelist is allowing all resolutions till 2160p@60hz. The standard resolutions according to EDID allow:

Hope this helps to single out the cause.

Edit: The EDID-Info seems to have changed. Actually it reads
for FHD up.

I’ll be really glad to test in next hours if some work in the next revision has been put in video engine pipeline related to compatibility or refresh rates.

I’m afraid I could finish having more issues than I already have for nothing. I’d need a good amount of time to reflash and to reconfigure the whole unit.

Thanks in advance

Sorry, edited …

Any news ? Something I could check/test ?

You can update to the staging repository, but I don’t anticipate any improvements.

I hope this issue has got some priority, and work will be put into this in the following days.

I’m not the only one who has detected the problem.

As soon as any change is merged n the stagging repository toward solving this, please tell us to check it.


Have you tried disabling whitelisting?
Do you have a sample file to reproduce the problem?

I can add a me too here as well…

In my case the problem occurs on 1080p50hz content which worked flawlessly before the November update.

“Problem” settings:
Whitelist disabled, sync refresh rate on “always”…

Weirdly enough the only way I was able to fix the issue is if I add 1080p50 to the Whitelist, then the video plays without stutters and slow motions and audio suddenly is back in sync again…

There was an update showing up for me today, I already installed it and the problem still persists with Whitelist disabled…

I’m getting the same behavior as CestLeBob: new upgrade appeared today but the problem still persist, and whitelisting 1080p 50hz works at least for some videos (I’m still testing).

If I have time I’ll try to send some samples tomorrow.

I can imagine that’s your problem. ‘On Start/Stop’ is recommended.

Try turning off ‘sync playback to display’.