Stuttering video (source NAS), good iperf speed


#1

Hi,

i have the Vero 4K+ and i have an issue with streaming higher bitrate files from my NAS (for example the 140Mb Jellyfish, which stutters like crazy if played from the NAS). If played locally, the 300Mb Jellyfish plays without any issue. I have tried to see if the network speed is the issue, but according to the Iperf3 test, this should not be an issue:

osmc@osmc:~$ iperf3 -R -c 192.168.0.31
Connecting to host 192.168.0.31, port 5201
Reverse mode, remote host 192.168.0.31 is sending
[ 4] local 192.168.0.20 port 34524 connected to 192.168.0.31 port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 112 MBytes 941 Mbits/sec
[ 4] 1.00-2.00 sec 112 MBytes 942 Mbits/sec
[ 4] 2.00-3.00 sec 112 MBytes 942 Mbits/sec
[ 4] 3.00-4.00 sec 112 MBytes 941 Mbits/sec
[ 4] 4.00-5.00 sec 112 MBytes 942 Mbits/sec
[ 4] 5.00-6.00 sec 112 MBytes 942 Mbits/sec
[ 4] 6.00-7.00 sec 112 MBytes 942 Mbits/sec
[ 4] 7.00-8.00 sec 112 MBytes 942 Mbits/sec
[ 4] 8.00-9.00 sec 112 MBytes 942 Mbits/sec
[ 4] 9.00-10.00 sec 112 MBytes 941 Mbits/sec


[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 1.10 GBytes 944 Mbits/sec 0 sender
[ 4] 0.00-10.00 sec 1.10 GBytes 942 Mbits/sec receiver

logs: https://paste.osmc.tv/zajeyokaca

i have also put the NAS and Vero on a separate gigabit switch, to make sure the problem is not in the router, but still the issue exists.


#2

Which version of the Jellyfish clip are you playing? Do you have a link to the specific 140Mbps one? There are a few variants.

Cheers

Sam


#3

The files are from the http://jell.yfish.us site. the 120 Mb files (both 264 and hevc) play fine.

specific file from the logs:
http://jell.yfish.us/media/jellyfish-140-mbps-4k-uhd-h264.mkv


#4

The H264 decoder may be struggling with the 140Mbps clip.
Try an HEVC 10-bit 140Mbps clip instead for comparison.

H264 is usually 1080p Blu-ray which caps out at 40Mbps; so it’s less optimised.

Sam


#5

the HEVC 10-bit has the same issue, but i still think it has something to do with the network as all files play fine from the Vero itself, also the 140 Mb 264 file.


#6

I’ve checked the log. There is some buffering.

The SMB source may be too slow; or there may be some overhead from Kodi’s built in SMB mounts. I notice you are also scraping your library as well; which may be causing network overhead or even CPU overhead if you have a large library. If your library is up to date already; then the additional scanning may be because of nofasthash in your customised advancedsettings.xml.

Sam


#7

I did some teste with jellyfish videos on Vero4k in the past.
From 500GB HDD connected through USB 2.0, it plays jellyfish until about 180Mbit/s bitrate.
Over 200Mbits, its USB 2.0 wont manage to play it smoothly. But from internal 16GB storage, even 250Mbit/s bitrate ones plays fluently. This may give you some insight about what bitrate can Vero4k handle. Even in case that no one even uses such high bitrates in real life.


#8

It depends on the format.

HEVC can play 300Mbps easily; but the H264 decoder is less optimised. As there is no real world H264 content hitting this bitrate, we didn’t look in to this much. Everything H264 that is real world content (that isn’t hi10) will play fine.


#9

The 300Mb file plays fine from internal storage (as i mentioned in the OP), but stutters a lot when played from my NAS (DS218+), just wondering why that is, as everything should work fine and the network speed should not be the issue, but you are right, i have not found any real world content that the vero 4K+ cannot handle over the network (i did find a few files that the Vero 4k could not play over the network)


#10

This file played fine on my 4K+ served via SMB from a Windows 10 PC (also while the Windows PC was streaming content from elsewhere at the same time) so it looks like you were right about a network issue


#11

thanks for confirming. I’ll have to check with another UPT cable to see if thats the issue.


#12

If you are getting a good speed via iperf, then it probably won’t be that.
Can you try remove fasthash temporarily or let the library scan settle?


#13

thanks

the iperf continuously gives 940Mb both ways…

you mentioned this before:
nofasthash in your customised advancedsettings.xml.

It’s a while since i setup my Vero (copied the config of the 4K to the 4K+), but i think i never set up the advanced_settings.xml file, at least i cannot find it in the userdata folder… Is that what you meant?


#14

Yes. It should be in your home folder under ~/.kodi.

Sam


#15

unfortunately removing the line from the advancedsettings.xml did not have any impact and the library scan was also finished…


#16

Do you have another network share you could test from?


#17

I tried it from an NFS share(my NAS is the only wired storage i have), and the performance is much better! the 140 Mb files play flawlessly, the 250 and 300 Mb files also play fine after short buffering. Should i increase the buffer size in advancedsettings for better performance? i think it buffers about 10 seconds max right now.

thanks for your quick support! very helpful!


#18

Well the duration depends on the bitrate of the file, but basically the values are already optimized for the RAM available


#19

ok, I will keep it as is then… At the moment i have no real-world content i cannot play flawlessly, so it’s not an issue…

thanks for all your quick replies!


#20

Hi,

Same problem on my Vero4K with 4K video.

I access to my NAS with NFS protocol
Iperf result
[ ID] Interval Transfer Bandwidth Retr
[ 5] 0.00-10.03 sec 115 MBytes 95.9 Mbits/sec 0 sender
[ 5] 0.00-10.03 sec 113 MBytes 94.2 Mbits/sec receiver

I can’t read video with a bitframe of 81Mbit/s stuttering all time

Better with a 61 Mbit/s bitframe

Files are m2ts extension (4K bluray)

Thanks
Julien