Stuttering with certain videos

Hello everyone.
I have just received my Vero 4k+, after waiting for 2 months. Great little thing, made it play a few h265, 10 bit, 1080p videos over my network and it worked flawlessly.

However, I found out that there seems to be a problem with playing h264, 10bit 1080p files. Is it normal? Could the bitrate be too high or something?

Whenever I play either of those files (scroll down to see the mediainfo of three files, one which worked flawlessly and the two other that were stuttering), all 4 cores are maxed out, staying between 96-100% at all times. I have tried getting those files on my USB 3.0 drive: no change in the outcome. Putting the resolution to 720p and the framerate to 30 FPS had no impact whatsoever.

Am I at fault here for not getting proper files or is the 4k+ just not able to handle those videos?
I must add that my Vero 4k+ is up to date (August update), fresh out of the box. I do not know as much about video as I’d like, but anyways.

Thank you for taking the time to read.

Here are the promised files mediainfos (I wasn’t sure if spoilers were possible here, so I preferred not to take the risk):

Links to
Stuttering file #1
Stuttering file #2
Working file #1

(Yes, I do watch anime, it’s okay to make fun of me :grin:)

If you do a search on the Forum (see example below) you will see that there are unfortunately problems with 10Bit Anime encodings. You can try to disable Hardware Acceleration and see if that help

Thank you. I read through this thread and I now understand why it cannot be played.

Another solution would be to reencode them into h265, correct? If not, do I really need to find different files for those shows?

Thank you.

Also forgot to add the hardware acceleration did not improve the video in any way.

You mean with Hardware Acceleration being disabled it is also not working?

If we detect 10-bit, we will refuse to accelerate it via HW anyway.


Then the solution would be to get h265 10bit or h264 8bit in this case?