Subtitle Preference to 'ON' not saved

I just tested this. While watching a TV episode, I brought up the OSD, went to subtitles and turned them on and selected “Set as default”.

Watched another episode and got subtitles. Rebooted and still got subtitles.

What skin are you using? Debug logs may help us see why you are not getting the subs.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Oooer. That might be a bit too advanced for this blonde brunette, but I’ll try.
The skin is, I think, the default Estuary one :wink:

Maybe it’s an issue with the skin. Try the default OSMC skin and see what happens.

Just re=read that previous post. I am getting subtitles ok, it’s just that I have to turn them on every time I start a movie. Which is every time cos I always have a subtitle with my vieos,

So it’s only movies that you see this with? I’ll try that.

OK, I can confirm, looks like a Kodi bug. The setting works fine for TV shows, but not for Movies.

Sorry, no. I use subtitles for every video I watch through the Vero, whether they be movies, docos, TV shows etc.

“OK, I can confirm, looks like a Kodi bug. The setting works fine for TV shows, but not for Movies.”

Well, I’d call ‘Disenchanted’ (Matt Groening) a TV show rather than a movie, and the same thing happens with that. As well as any other TV show :sob:.

I guess it’s not about of what you would “call” it but if it is in the Library under Movies or TV Shows.

I saw comments on the KODI website about someone with the same problem, and there was a suggestion that his problem was caused by him using the File Explorer and not the Library.

I also use File Explorer, maybe that’s the problem.

That could explain why it’s not working for TV shows, but I do think that there is a bug for Movies from my limited testing tonight.

Try setting up a library and see if that helps.

bmillham, thanks, but, as I explained in my last post, which was about not being able to search for specific movies by name (which turned out to be a function of the Library but not the File Explorer), that I prefer not to use the Library.
So, like doing without a Search function, I’ll put up with turning the subtitles on manually.
Both items are only niggles.
Thanks to all who’ve answered. :relaxed:

I never use the search feature, but just tried it and it works fine. Found all kinds of hits on the word I searched on, including the movie I had in mind. You may want to try the library again.

You don’t need a library for this and it works just fine regardless of where you start the video from (including file explorer). I think you might have gotten tripped up in your testing method. If you enable or disable subs when your playing a video that gets stored in the database even for files that are not in the library. Thus you can only test whether it works with files that had not had their sub setting touched while playing them. Any files that had been touched will have to be manually switched as I am pretty sure there is no way to force an override of a saved sub state.

Check .kodi/userdata/guisettings.xml and make sure it shows <showsubtitles>true</showsubtitles> under <defaultvideosettings> (or post a log so we can check for you).

The problem people normally have is that the name of their prefered subtitle does not match the exact name of a subtitle. If someone had their UI set to ‘english (US)’ and prefered sub set to ‘user interface language’ then it will not find an english sub as those are always titled ‘english’.

When I was testing, I played a movie, set subs to on and then set default for all. Stopped the movie and started again and no subs. Went to watch a TV Show (that I had already watched) and got subs. There is a bug in Kodi here.

All my subs are embedded.

I tested it as well. All virgin videos worked according to the what was set in guisettings, and all videos that had the sub state stored in the db reflected their previous state (both on and off). I only revisited this to try to confirm the bug, but I only found everything to be working as expected.

Me again :relaxed: I started a thread about this back in October 2019
Subtitle Preference to 'ON' not saved - #22 by darwindesign but the problem wasn’t resolved, so I’ve been switching the subs on manually ever since.
However, last night I discovered that if the subtitles are separate files that I’ve downloaded (and renamed, of course :smile_cat:), the subs display automatically when the show starts.
But if video has built-in subtitles, I have to manually switch them on.
Does that provide another clue as to why this could be happening?
Hope everyone is ok. Isn’t this bug awful!
Cleo :heart:

Hi,

It could be that the internal subtitle is marked as forced rather than default. You can check with mediainfo.

Thanks Tom.

1 Like

I’m not sure this isn’t a configuration issue rather than a bug. Can you reboot twice, turn on debug logging, play a few seconds of a working and not working file, and then upload logs please.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks, I’ll try. Might take me a while to work out how to do that :thinking: