Subtitles rendering across multiple frames

After the update to Kodi 19 I notice that subtitles get rendered across two frames occasionally. By this I mean that I sometimes see the bottom half of a subtitle line (e.g. 30 pixels or so) and then next frame the rest of the subtitle becomes visible.

It’s a bit like the tearing you get when vsync is disabled, except the video itself shows no artifacts, it’s just the subs.

This happens with srt subtitles and with embedded subtitles alike. This worked fine in the previous version of Kodi.

Check your display settings and make sure you didn’t get switched to interlaced output. If that isn’t the issue you would need to provide logs…

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I’ve confirmed my screen is not set to interlaced (and I would’ve expected issues with the video itself as well, if that were the case).

I’ll try to sort out some logs.

I have some logs here. I started playback of a movie, scrolled around a bit and once the glitch was visible I stopped and went directly to the log uploader UI.

I had that on many movies too till someone told me that i just can use the subtitle adjusting function. Just put
vertical position of subtitles higher in settings. Then click Back until you’re back in the video and test if it looks better. Depending on movie you sometimes often have to adjust them. My settings is always 900.

How to do it ? Go into a movie, click on
Video settings then on Video calibration then click two times till you get on "Subtitle positioning and scroll up till 900. Then click back till you back in the video and play it again. Subtitles will be higher. If they too high just go again same settings and scroll to 850 or so…just try it out.

Read my old thread here

1 Like

Using video calibration settings is a good way to set a default subtitle position. You can also use the KeyMap Editor to map “subtitle up” and “subtitle down” to keys on the remote - perhaps the volume keys.

Might have something to do with this Kodi screen calibration you have done…

            <description>1920x1080 @ 60.00 - Full Screen</description>

I would reset the calibrations in Kodi back to default (ie no adjustments) and then in your TV settings find the setting to disable overscan which should be labeled depending on the TV as something like just scan, 1:1, or native. That should also give you better picture quality overall.


Thanks for the suggestions, all. However, my issue is not that the subtitles are in the wrong place.

The rendering of the subtitles is incorrect in that it sometimes takes two frames for the full subtitle to render, a bit like they’re being rendered too late for the first frame to fully show them.

As someone who watches everything with subs, I am surprised I’ve never heard of or seen this issue.
Can you take a short video clip of it happening with your cell phone or something?

1 Like

I can try, or maybe mock up what it looks like. To be clear, this never happened with the previous version of Kodi. It started happening after the upgrade to Kodi 19.1 in the recent Vero 4K+ update.

I’ve had to work out a few kinks here and there with the new update.
Which was expected.
As an example, all my audio sounded like static after the update.
Went into settings and changed it from HDMI/Optical to just HDMI and everything returned to normal.
There’s something going on for sure.
You could try setting your configuration to defaults and go from there.
But I prefer to try things one by one because I like to know exactly what it was that caused the issue instead of doing full resets, but sometimes full resets make sense.
I had my home screen configured with Recently Added Movies instead of Random Movies, but that go broken in the update.
Went into the options and made sure everything was correct, and it was, but issue persisted.
Told the skin to restore defaults, went back to the home screen so it rebuilds, then redid the option for Recently Added and it worked.
Go figure.

I’m having the same issue as @Roy
I tried resetting video settings to default values, can’t notice it anymore but will try with a few more videos.
It’s kind of difficult to notice because it doesn’t always happen, at least for me.

I, too, started having that issue right after I upgraded my Vero 4K+ to Kodi 19.

I recorded a quick video. You can see the subtitle disappear in multiple frames.
I think it also happens when subtitles appear.
If I rewind the video it won’t happen again on that specific subtitle.

Thanks for this video, it’s exactly the same as the issue I have.


I just saw this happen when watching my remux of The Boys S01E07.
It happens pretty quick and not always in the same spot.
I backed up the video and watched the same lines display without issue after seeing it.
So far it appears very random to me, but it’s definitely there.
I saw it happen about eight times in one episode.

I’ve just noticed this too. Occasionally the second line appears fractionally before the first. I don’t think my wife has noticed so I wont mention it to her. I bet there are a few people that have this but don’t know.

I believe the following could somehow be related:
if I press back while watching a 24fps movie, the UI remains at 24fps too (normal, happened on v18, too). But with v19 there seem to be a problem with v-sync.
This is very noticeable if the screensaver kicks in while a movie is paused (I’m using picture slideshow screensaver): the tearing is very visible when pictures are panning.

Anyone managed to get this sorted yet? I also have this issue since the v19 release, never had this before. Tried using a different skin, but that made no difference.