Subtitles wrongly positioned

This might be a Kodi issue rather than an OSMC one, but I’d quite like confirmation of that…

There’s a problem I sometimes get when watching videos with the output resolution below 1080p, where the subtitles seem to overflow somehow, and end up displayed in the wrong place.


All of the yellow text here should be being displayed below all of the white text. Instead it appears farther up the screen and displaced to the left.

This is from an episode of Miranda on iPlayer. To reproduce, whitelist 720p/50, then find Miranda in the iPlayer add on, season 2, episode 6: there are several instances in a row between 03:25 and 03:50.

This behaviour is definitely not restricted to a single add-on - I’ve seen it on Netflix, and Disney+ as well. (And it’s not a Widevine issue, because iPlayer doesn’t use that). I don’t recall seeing it on a locally stored video, but then I don’t really have any local videos at 720p.

It can be worked around by setting the output resolution to 1080p/50 instead, but that has implications to the playback quality, because the Vero is doing some of the upscaling instead of the TV.

The Kodi default in settings>player>language>subtitle position on screen> is fixed which uses the setting from video calibration to place where they are. It looks to be rolling over so I would think the choice to fix would be to move the calibration up to allow more room or else change the preference to something like bottom of video.

Since I never bothered with subs I got a no idea how it works, but I have a few thoughts:
Does kodi have font size setting?
Is such a setting based on resolution and scaled automatically?
Would it be posible to set the size lower depending on resolution?
Is it just Vero4k(+) or pi as well?


Also, yes.

(Although, if I may digress for a moment, this doesn’t actually work quite the way it should. It’s scaled automatically by output resolution, when it should be scaled automatically by the size of the window the video is being rendered in. Usually those are the same thing - if the video is playing full screen - but if, for example, you’re playing a 720p video with 1080p output and you switch View Mode from Normal to Original Size, what ought to happen is that the subtitles are automatically moved upwards and scaled down as is appropriate to the size of the window the video is being rendered in. Instead the subtitles are displayed full size below the bottom of the video. However, all this isn’t connected to the problem I was complaining about!)

In terms of the size of the characters, it already does that.

I don’t know. My Pi 3 keeps trashing its SD card, and I don’t have time to reinstall OSMC on it right now. If it matters, I can try and find some time tomorrow.

Changing the fixed position doesn’t help. The position you specify there is for the bottom of the lowest line of the subtitles, and all other lines in the current block are displayed an appropriate distance above that (when everything is working correctly).

Here’s a seven line subtitle rendered correctly with the vertical position set to 694:

And here’s a four-line subtitle rendered incorrectly with the vertical position set to 540:

It’s possible that there’s a horizontal overflow going on…?

As I noted above, if I change the output resolution to 1080p, then everything renders more or less correctly (although if you look closely there is slightly too large a gap between the last two lines):

EDIT: Oh, and switching from Fixed to Bottom of Video makes things even worse - note that one of the lines of text here is only half displayed: