Suddenly can't playback many files

Hi,

I have been a very happy owner of Vero 4K+ for a long time and never had any issues with it.

However today suddenly it can’t play back most of my files. It will open the file and start for a few seconds, then choke up to a complete halt. I have tried several files both 1080p and 2160p and same issue. It acts like it’s not powerful enough, but I have previously played back really large 2160p files without issue - now suddenly it can’t.

I have rebooted both the Vero and the NAS the files are on as well as the router, but same issue. I also cleaned the library but not that.

I remember updating not so long ago. Has something happened with the update that makes it not play back certain formats?

That could suggest that hardware video decoding has been turned off.

Since you’re using a NAS, try to play a file from local storage (eMMC) and see if that makes a difference.

Of course, logs would always be useful. :wink:

That was my thought too, but going into settings all hardware accelerations are on and “always”. It would also be very mysterious why these settings would suddenly go “off”.

I have tried going into Event Log, but it looks completely empty. What do I need to do to get into a log of what happens here?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thank you very much for this explanation.

Very weird but I enable debug logging, reboot twice, and now it suddenly plays the files no problem… As mysteriously as it suddenly wouldn’t play them now it suddenly does again…

Very sorry for the inconvenience. :slight_smile:

Let’s keep an eye on things.

Now it just did it again, and I tried resetting all network etc. and nothing helped.

Did the log and reboot twice and the log is here:

https://paste.osmc.tv/xedakehiya

It’s like the network is choked, og it can’t accelerate the video. It completely freezes when trying to playback a video. Very weird since I have had it for such a long time without issue and now it suddenly can’t play anything above 2Gb files.

The logs show that we are unable to get any data from the NAS
Does rebooting the NAS solve the problem?

I could use the NAS from other devices without any problems.

If it’s a data issue it must be with the network. I’ll have to do deeper analysis of it, though it’s weird that everything else is working including the NAS from other devices.

Try change SMB minimum version to SMBv3 (in Settings)

Hi All,
Ive been experiencing similar issues, no playback at all. The unit crashes when you press play button. My issue started when i installl new nbn, static ip, have nas connected to network via LAN
Have tried:
Reboot NAS
Plays from other devices - from my tv
SMBv3

Any suggestions?

Logs!

1 Like

So I have gone through the following:

Complete shut-down and reset of all network devices.
Reboot NAS
Unplugged LAN cable from Vero and gone on WiFi instead
Changing minimum SMB to SMBv3

None of the above helps. It’s like there is no network connection at all. Meanwhile Kodi on all other windows devices on the same network can play back the files without any issues. It’s just Vero that suddenly chokes on network?

Has there been an update that changed the network protocols or something like that?

It can play back tiny low-quality files, but anything at higher quality (even 1080p files) will make it choke down to a freeze.

Weird thing is it has worked perfectly and I haven’t changed anything except accepting updates when prompted.

Nothing has changed in terms of networking in this update.

Did the NAS get a firmware update?

No it’s been a while since the NAS was updated. And all other devices (Windows PCs) can play back in Kodi (for Windows) and transfer files without any issues.

A hammer approach would be to configure an fstab mount, which would give better performance anyway.

You could check your sources.xml on your Windows PC. The thing is that Windows isn’t a great test, because I believe that Kodi uses Windows built in SMB support and not libSMB which is what’s used to support SMB for Kodi on other platforms.

Is there a way to do a factory reset of the Vero and start it over? Maybe some cache or some hidden setting somewhere is preventing something?

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

Yes - you can reinstall OSMC from osmc.tv/download. But you could try @ActionA’s instructions first

Sam

Just tried the first - setting it back to default settings. Had to re-configure network source etc so it was reset. However the problem persisted. Almost no network throughput, and choking on almost all files.

I have also tried to manually set IP address in case that could have something. Didn’t help either.

Going to try the next one now with the restore.