Suddenly can't playback many files

Try change SMB minimum version to SMBv3 (in Settings)

Hi All,
Ive been experiencing similar issues, no playback at all. The unit crashes when you press play button. My issue started when i installl new nbn, static ip, have nas connected to network via LAN
Have tried:
Reboot NAS
Plays from other devices - from my tv
SMBv3

Any suggestions?

Logs!

1 Like

So I have gone through the following:

Complete shut-down and reset of all network devices.
Reboot NAS
Unplugged LAN cable from Vero and gone on WiFi instead
Changing minimum SMB to SMBv3

None of the above helps. It’s like there is no network connection at all. Meanwhile Kodi on all other windows devices on the same network can play back the files without any issues. It’s just Vero that suddenly chokes on network?

Has there been an update that changed the network protocols or something like that?

It can play back tiny low-quality files, but anything at higher quality (even 1080p files) will make it choke down to a freeze.

Weird thing is it has worked perfectly and I haven’t changed anything except accepting updates when prompted.

Nothing has changed in terms of networking in this update.

Did the NAS get a firmware update?

No it’s been a while since the NAS was updated. And all other devices (Windows PCs) can play back in Kodi (for Windows) and transfer files without any issues.

A hammer approach would be to configure an fstab mount, which would give better performance anyway.

You could check your sources.xml on your Windows PC. The thing is that Windows isn’t a great test, because I believe that Kodi uses Windows built in SMB support and not libSMB which is what’s used to support SMB for Kodi on other platforms.

Is there a way to do a factory reset of the Vero and start it over? Maybe some cache or some hidden setting somewhere is preventing something?

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

Yes - you can reinstall OSMC from osmc.tv/download. But you could try @ActionA’s instructions first

Sam

Just tried the first - setting it back to default settings. Had to re-configure network source etc so it was reset. However the problem persisted. Almost no network throughput, and choking on almost all files.

I have also tried to manually set IP address in case that could have something. Didn’t help either.

Going to try the next one now with the restore.

How are you determining this?

I’m not - it was based on our discussion here that I was told from the log that there was struggling with the connection to the NAS. So assuming that it’s a problem with the throughput. And I can play tiny files but not the larger (5GB+) files where it will just stutter to a halt.

Just realized the second “blue” section was to restore back to what I had and no the reset. So the reset didn’t help unfortunately. I’m at my wits end here what it can be. The network works fine and the files play fine on other devices on the network, but Vero just completely chokes on it like it’s not hardware accelerated or has very limited network (the same for cable or wifi).

Hi,

I would try with kernel mounts such as fstab as sam suggestion or an alternative is:

Which has a better recovery success that fstab, if they the network is a bit flaky and IMHO is easier to setup than fstab.

Thanks Tom.

Just tried setting up the NAS for NFS and made a new connection using NFS. Same result unfortunately. Is there a place to test network speed? I can’t see connection speed - just settings for IP and gateway etc.

At this point, I would definitely do an iperf3 test.

Gonna have to go through my entire network again. There must be something going on…

Thank you all for the help!

An update to this case. I have been through my entire network, changed cables and some old switches. Now everything works as normal, so it must have been somewhere on the network. Very weird that it would do this to just the Vero and not other clients on the network. But fingers crossed that it stays working. Thank you all for your help and support! :slight_smile:

2 Likes

Thanks for reporting back