Switch SPDIF output on and off?


I’m using the optical output to connect my audio system and that works great, except this thing in the soundbar manual that fails, they call that “auto power down”.

It’s just a shutdown timer if no audio is transmitted for 5 minutes, pretty nice I thought, and It’s supposed to work with every inputs. It does with aux but got no luck so far with spdif.

Is there something I could do like a settings I missed (the keep sending audio setting is switched off in system settings) ?
I thought about writing a script that would switch off the optical ouput when the vero is on standby though I don’t know if there’s such a switch.

AutoPowerDownFunction : The unit turns off automatically in the following situations.
D.IN / HDMI / BT / USB Mode : If there is no audio signal for 5 minutes.
AUX Mode : If the Audio (AUX) Cable is disconnected for 5 minutes. If there is no KEY input for 8 hours when the Audio (AUX) Cable is connected. (Auto Power Down function can be turned off only in that case.)
To turn off Auto Power Down function, blablabla the device is samsung hw-N550

Have a nice day


could you first check whether keep audio alive is active in your audio config?

Checked: keep audio alive and send send low volume noise are already disabled

If you power down the Vero (or just disconnect the TOSLINK cable), does the soundbar turn off?

Just tried and yes the soundbar turns off after 5 minutes when I powered down vero from interface

It could be that the soundbar is just looking to see if the connected device is powered on, not if there is any active sound.

You could try setting the Vero to suspend.

I’m thinking of the same scenario since the opposite function automatic powering on does work when vero is turned on after being plugged off.
Problem stays for automatic power off: suspend mode is always active after some time and switching manually to suspend mode does not trigger the soundbar neither.
I’m thinking of a cable issue so I’ll try another

Try what happens if you disable Kodi. Easiest login via ssh and run sudo systemctl stop mediacenter check if it switches off after 5 minutes

checked: does not power off the speaker

Ok, then I think there is not much that can be done unless someone has an idea how to physically switch off the SPDIF port

@mrtnn Hi Martin, your soundbar has an HDMI port and an HDMI TV ARC port; a typical configuration is to connect a mediaplayer to the HDMI port and the TV to the HDMI TV ARC port.
In this configuration you’re not limited by any bandwidth using toslink … and the Vero’s HDMI port would be switched off if you “suspend” the Vero.
Is there any reason why you try to use the spdif connection (perhaps already connected another device to the soundbar’s hdmi port)? In that case this audio solution seems to be somewhat “small” …

Hey @JimKnopf , yes HDMI is the obvious solution. HDMI and CEC was my first choice and I should have benefit from volume control with this. Problem is volume control on HDMI+CEC is messed up on my setup: it creates audio issues. I had support feedback here but it looks impossible to fix, I’ve got last drivers on my devices and checked all settings, dead end. here is the discussion Audio distortion with Samsung SoundBar + Vero remote / HDMI - #20 by mrtnn in the end the spdif output let me have the control of power on/off TV with CEC without messing around with the audio.