Synology NAS won't connect

I installed osmc 2021.08-1 on my RPi 3B+ got it up and running by doing a restore and did a backup immediately thereafter. That Pi died so I decided to go for the Pi4. I have tried both versions of osmc for the Pi4 and after the restore all looks good BUT neither can connect to my NAS after the restore.

So I started from scratch and tried to add video links. I can see my NAS and get down to the main directory but cannot get the subdirectories. In the past Kodi has asked for user name and password to authorize entry but no that doesn’t happen.

How do I log into my NAS to see the subdirectories?

How are you connecting to the NAS? NFS or SMB?


I had an old Pi3 that was still working and did a fresh install/restore and it worked just fine. It appears that you cannot restore from a Pi2/3 backup to a Pi4 install.

Are they using the same IP address? Because with NFS security is based on IP Addresses.

Check this thread, sounds similar

That made me look at my NAS settings. I found that the NAS had picked up the MAC and assigned IP from the first time I turned on the the Pi4 and had written it to the Authorization table with the first IP address. All I had to do was set up the DHCP IP address in the router to the one in the NAS and almost all of the directories were available. Still cant get past the Music subfolder to add it to Kodi but I’m working on it.

Not quite solved but almost.

Thanks for your help!