Vero4K won't navigate in a NFS share from synology

I read a lot a subjects on the forum(especially: dillthedog wrap-up), but apparently I am missing something which makes it not running so I’m sorry to bother everyone again with this subject…

  • Vero 4K with OSMC 2017.07-1 running Kode 17.3
  • Synology DS1515+ running DSM 6.1.3-15152 Update 3

I just received the Vero4K and I am trying to configure it to connect to the synology shares to access Movies…
I succeed on getting the Vero4K to detect automatically the synology, he finds the shares but I am not able to “enter it”

I read a lot a subjects on the forum, but apparently I am missing something which makes it not running so I’m sorry to bother everyone again with this subject…

A bit of context:
The share is this one on the synology: /volume1/Films. This share is already daily accessed by an AppleTVv2 without any problems.

With the Vero, I detect the “/volume1/Films” but it won’t go further.

The share looks like this
/volume1/Films$ ls -l
drwxrwsrwx 3 guillain users 12288 May 17 2016 DivxsAnglais
drwxrwsrwx 11 guillain users 69632 Aug 20 09:44 DivxsFrancais
drwxrwsrwx 11 guillain users 20480 Jul 11 06:34 Documentaires

The movies are in the subfolders.

I base my tests according to this tutorial:

1/ Step 1:
Control Panel -> File Services
Enable NFS (v4 support not enabled)
Advanced:Settings: Apply default Unix permissions.

==> This is OK, not very complicated…

2/ I open “NFS Permissions” of the Share Folder “Films”
I set the following parameters:

  • Hostname or IP*: 192.168.1.*
  • Privilege: “Read only”
  • Squash: “No mapping” (I tried other option but with no success…)
  • Security: “sys”
  • “Enable asynchronous” is ACTIVATED
  • "Allow connections from non-privileged ports (ports higher than 1024) is ACTIVATED
  • “Allow users to access mounted subfolders” is ACTIVATED

=> Saved.

3/ I remotely connect to the synology through SSH:

For info:
uid=1024(admin) gid=100(users) groups=100(users),101(administrators)
uid=1025(guest) gid=100(users) groups=100(users)
uid=1027(UserAppleTV) gid=100(users) groups=100(users)
uid=1026(guillain) gid=100(users) groups=100(users),101(administrators)

Then, since I could not navigate in the NFS share, I tried on the possibilities shown by dillthedog (Using NFS with Synology)

I did try a lot with uid=1025 & uid=1026 with no luck.
I tried twice with uid=1026 with no luck but maybe I didn’t choose the correct line…
Both user “admin” & “guest” are active and both have access to the share folder at least in read-only.

The AppleTV connects to the share with the user “UserAppleTV” without any problems.

When I finish doing the modification in vi of /etc/exports, I run “sudo exportfs -a”, check that is appears in “sudo exportfs”.
I do not reboot the Synology.
I do not reboot the Vero 4K, I just relaunch the procedure to add a new source…

If you need more info, please don’t hesitate to ask…

Could someone help me out in order for me to understand what I am doing wrong?
Thank you in advance


This will probably help:

As reported on the kodi forums, setting the permissions for user and group to everybody; helps accessing the shares on kodi.

It also may be worth if you could post:

/etc/exports for the synology


showmount -e 192.168.1.* on the vero4k; * is the ip of the synology,

Thanks Tom.

I think it is a permission issue, this helped me out.

On first reading, one thing stands out:

Wildcards don’t normaly work on IP addresses, so you should normall use (CIDR) notation. (Of course, you say that the ATV successfully accesses the data!) I just checked the Synology site and it confirms my belief.

Since you’re sharing /volume1/Films, it would have been more useful to show the output from ls -la, just to be sure.

Also, as Tom mentioned, please show us the /etc/exports file from the Synology box.

As an aside, there’s generally no need to enable "Allow connections from non-privileged ports (ports higher than 1024) " for Linux access, though I guess it could be required for the ATV

HI All,

Thank you for your help!

I got curious about dillthedog remark on the fact i set “192.168.1.*”. I changed it to “”
I also desactivated the “Allow connections from non-privileged ports (ports higher than 1024)”
And everything started to work !!

I modified also the nonuid to set the same user as AppleTV. I don’t masterise unix enough to know what is the impact, nevertheless, it kept working.

So here is the version of /etc/exports:

I am unsure what you guys meant by “setting the permissions for user and group to everybody”. Was to do a chmod 777 on all files?

Thank you

Excellent news!

I think it meant allow “world” read permission to the files.

Your /etc/exports file looks good and you should be able to see files that are:

  • readable by user guillain (UID 1027); or
  • readable by group users (GID 100); or
  • readable by “the world”.

but 777 should work just fine. :wink: