Teething issues and questions

I got my Vero2 a few days ago, and am loving it. I’ve got a few questions, and am having a few issues too. Please excuse me if I’ve missed something in the forums that I should have seen, or am being plain old silly.

  1. The dongle that comes with the Vero remote. Is it an RF dongle? Does it make any difference which of the 4 USB ports I choose to plug it into?

  2. Speaking of the USB ports - are all 4 effectively the same? They’re not labelled at all. I seem to remember that the one at the back is different somehow, something to do with external HDDs?

  3. There are 2 x unlabelled 3.5mm sockets on the back of the Vero 2. What are they, what do they do? I am hoping that one of them outputs stereo sound, which I can connect to my 2nd amp that powers outside speakers.

  4. My Vero2 is connected to my Onkyo TX-NR626 AVR via HDMI cable, but when I go to select my audio output device, HDMI is not listed as an option.


    What’s up wi dat? When I play movie files that are encoded in DTS, my AVR says that it’s coming through as DTS, but still it seems wrong that HDMI is not recognised as an audio output option. I still see an option to allow passthough (obviously I’ve left that enabled) and a few options underneath, but not as many options as I used to see on my ATV1.

  5. Speaking of audio, there are some weird new DSP add-ons that start out as disabled. When first setting up the VeRo2 I enabled them, but every now and then when I change between profiles (I have a “kids” profile with different sources than the master user), I get a message on screen that they’re somehow disabled again.


    I’ve never dealt with these DSP add-ons before, when I was running CB2 and Kodi 14.3 on my ATV1. HDMI was recognised as the audio output, and I had all the regular passthrough settings and whatnot.

  6. I was watching a documentary where the audio lagged behind the video, and then realised that I no longer have the option to adjust audio delay. It’s just not there!


    Haaaaay, what’s up wi dat? :slight_smile:

  7. Is there any possibility of adding ProjectM or Milkdrop2 or any other cool visualisations to my sweet sweet Vero2?

  8. I’d like to get my Harmony remote working with the Vero2, but I’ve asked that question on another forum post. For this post, can I just confirm that the IR receiver is on the front of the Vero2 unit. Is that correct?

Thanks in advance guys.

All the best,
Phil

Keep it in the rear USB port

Physically yes – but they are configured differently in software. The rear one runs at Full Speed to avoid Split Transactions and improve remote performance.

One is electrical SPDIF, one is a CVBS port which can provide composite video and two audio channels.

Select S/PDIF. This means audio will be passed through.

My guess is it means one of the profiles has DSP add-ons by mistake.

I think this may be caused by DSP add-ons being active.

I am going to add more screensavers in the future. We dropped some to get Jarvis out of the door quickly. There are some shadertoy screensavers included.

Yes.

Hope this clears things up

Sam

That may be so, but it is certainly none of my doing. These 2 addons seemed to just appear (in a “disabled” state) after my inital setup, fresh out of the box. I had never even heard of them before that. I have tried uninstalling both of them, and they just keep coming back. Any time I swap profiles, I get that same pesky “No audio DSP add-on enabled” pop-up. I have uninstalled 2-3 times, they just keep coming back. Whether I have them installed, enabled, disabled, or uninstalled, I still have no audio delay option when I access audio controls whilst playing a video file. Interesting, my other Vero2 (other end of the house) DOES have the audio delay option! Both units purchased at the same time, both set up by me. The only difference I can think of is that my one is connected to an AVR via HDMI, and the other one connects directly to a TV via HDMI. Neither of them recognises HDMI as an audio output option.

Any ideas? I can keep ignoring this pesky pop-up, but it seems to be indicative of some kind of trouble at mill, don’t you think?

Also, of the 2 x 3.5mm sockets on the back, you said: “One is electrical SPDIF, one is a CVBS port which can provide composite video and two audio channels.” Which one is which? I have a cable in my box of tricks in the garage that looks like this:


If I bung that into the CVBS port, will it output stereo sound right away? Or do I have to mess around with some settings?

Thanks,
Phil

Possibly a bug: Audio DSP Addons disabled when switching Kodi user profiles · Issue #25 · AlwinEsch/kodi · GitHub. Shouldn’t be anything to worry about, if you can tolerate the dialog for now.

Check audio settings – if you have passthrough enabled, then I don’t think you’ll be able to configure an offset. Make sure you’re playing the same file and audio settings (and selected output device) is exactly the same on both devices.

The one that is nearest to the rear USB port is the one you want. Then select ‘Analog’ audio and you should get audio out. Some people are just using a standard 3.5mm cable without the the splitter.

Let us know how you get on.

Not the end of the world, although I’d like to know why those 2 addons appeared in the first place. I did not install them, nor can I successfully uninstall them (they just come back when I change profiles). Am I correct to assume you have a handle on the issue, and will rectify with an upcoming update?

I checked my audio settings. Passthrough was not enable on the unit which did have the audio delay option, and passthrough was enabled on the unit which did not have audio delay option. I tried disabling passthrough, and no change, still no audio delay option. Both units accessing the same mediafile, on the same NAS drive.

I tried selecting ‘Analog’ audio and plugged my headphones into the 3.5mm socket nearest the rear USB port. Nuffink. Then I tried the other 3.5mm socket - got sound in one ear! I then tried my CVBS cable (as per my photo) in the same socket, connected to my amp - still, only sound one channel.

Any ideas?

The DSP add-ons are part of Kodi. It seems to be a bug (when switching profiles) in Kodi, so it will likely be addressed in the near future.

Did you disable passthrough for all videos, or just that one? Adjusting the audio offset is not possible with passthrough.

You could compare ‘guisettings.xml’ to make sure that the settings are exactly the same across both of your devices.

The CVBS cable may not be the correct one – does leaving the cable slightly plugged out of the Vero give you audio in both ears?

Sam

It’s pretty darn buggy! One of my profiles can see a 1920x1080 JPG that I transferred to the Vero2, and displays it as a background no problem. The master user profile, however, displayed a JPG in the same folder no problem for a start, but after changing profiles, doesn’t seem to “see” it any more. It lists the filename no problem, but doesn’t preview it whilst selecting, nor displays it as a background. The other profile continues to display the JPG as a background without issue. When I was using Kodi via my ATV1 running CB2, I never had any issues of the sort when doing exactly the same thing. Between that issue and the DSP bug, I’m very much looking forward to a fix. Is that something within your domain, or a Kodi issue?

I disabled passthrough for all videos. Why is adjusting audio offset no longer possible with passthrough? I used to do that without issue on my ATV1 - that seems like a serious loss of functionality, whereas I thought that Kodi got better with each iteration. Your thoughts?

Yes! I tried unplugging my headphones slightly, and I got sound in both ears. I need to test it with some video/audio with clearly discernable differences between left and right channels, to make sure that I’m not just getting mono across both ears. It’s not really the ideal solution though, having a 3.5mm stereo plug half-pie inserting into a CVBS socket. If a CVBS cable/plug is not the right one for the job here, do you know what is?

Cheers,
Phil

That sounds like a Kodi problem. I did make some changes to how add-ons are updated a few days ago, so some improvements there may fix this profiles issue, but I’m not necessarily convinced. Are you sure you haven’t got library mode on one profile and it disabled on another?

Show me the GUI Settings so I can see what’s set. Ideally it would be bettter to avoid sync issues in the first place.

Sam

I have uploaded both guisettings files to the web.

http://homepages.slingshot.co.nz/~philangela/files/guisettings_1.xml

http://homepages.slingshot.co.nz/~philangela/files/guisettings_2.xml

The 2nd one seems to allow adjustment of audio delay, whereas the 1st one does not. Any ideas?

The 1st device has passthrough enabled, correct?

If this is the case, and you are playing material being passed through, you will not be able to configure an audio offset. You may be able to do this with AC3 transcoding.

Sam

No, that is not true. I tried enabling passthrough on the 2nd device, and could still adjust audio offset. Audio offset was unavailable on the 1st device whether or not passthrough was enabled. The first device is the one upon which I have 2 different profiles set up. Maybe it’s an expression of the bug that causes the DSP issues, and also prevents my 1080p JPg file from being used as a custom background on the master user profile.

Anyhoo, since an OSMC update over the last couple of days, the audio offset issue has gone away. I can now adjust audio offset again, with passthrough enabled, as I had always been able when using Kodi 14.3 via CB2 on my ATV1. Fingers crossed for the profile issue to be sorted on an upcoming update too. :slight_smile:

cheers,
Phil

Hi

I assumed guisettings_1 meant the 1st device.

That device appears to have passhrough enabled.

If you want to avoid the possibility of an issue caused by DSP add-ons etc, you can attempt a reinstall, but I am glad the offset is resolved now. Fixing the need for offset is always more important

Sam

Yes, guisettings_1 means 1st device, guisettings_2 is the 2nd device. Both devices are brand new Vero 2’s, purchased at the same time.

Yes, 1st device has passthrough enabled. As I mentioned, I had been using Kodi 14.3 via my ATV1 running CB2 for aaaaaaaaages, always with passthrough enabled, and always being able to adjust audio offset. The audio offset seemed to “disappear” after I swapped over to my Vero2 box, although the audio offset WAS still available on the 2nd device (also a Vero 2).

With regard to attempting a reinstall - I am not convinced that will solve the problem. I had never heard of these DSP add-ons until I started getting error messages each time I swap profiles. I certainly did not install or otherwise choose to have them installed. Any time I try to uninstall them, they just return from the dead the next time I swap profiles. What’s to prevent them from reappearing on a reinstall?

Unfortunately reinstalling OSMC would be be the next thing to try, until that’s done we can’t rule out a problem introduced by an addon

If you are happy with things in the interim however there is no need to do this

Thanks

Sam

I have the same issue: a half plugged in 3.5mm gives me sound on both ears but significantly louder in one of them. I used the following cable that i bought assuming my other cable was broken (see picture). What is the right cable to connect to this amp: Denon | Enhance the Entertainment Experience (it has to chinch entrances and a digital in) ?

Cheers bendsch

Personally i think its a bit strange that you cant use a normal audio cable (like in the picture).
Even stranger is that this is nowhere documented. Since the vero comes with no handbook, no description sheet or any other instruction document i guess the only way to find answers to this ist the forums.
In this sense, waiting for answers.

Bendsch

Hi

We didn’t document this in detail because most cables should work. I use Sennheiser headphones (as the chord is quite long), and they worked fine for me.

The DSP on the Vero 2 is pretty good. I believe you can also set gain values via /sys/class/amaudio2 for each channel.

Sam

hmm in total (together with the cables i already had) i tried 4 different cables ( all chinch to 3.5mm). None of them worked. My headphones on the other hand work as well.

Could you name me a brand of cable that should be working?

cheers bendsch

Any of these should do the trick:

https://www.amazon.co.uk/s/ref=nb_sb_noss_2?url=search-alias%3Daps&field-keywords=3.5mm+to+rca

Sam

as explained above: i really tried 4 different cables. the result was allways the same:

  • if fully plugged in > sound only on one side
  • if half plugged in > sound on two sides but one significantly louder than the other
    is there maybe another trick to make it work properly?