[TESTING] 4K HDR playback with banding & flickering fixes

Read the hotfix for yourself: [deprecated]

sudo wget "https://paste.osmc.tv/raw/edawoyazuh" -O /etc/rc.local
sudo chmod +x /etc/rc.local


# rc.local
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
# In order to enable or disable this script just change the execution
# bits.
# By default this script does nothing.

echo '444,10bit' > /sys/class/amhdmitx/amhdmitx0/attr

exit 0

This is exactly what it does.


Thanks for the info, so it sets the output to 10 bit then, for people that are not able to do that themselves in SSH.

@sam_nazarko Will the setting of 444,10bit in rc.local still enforce BT2020 colorspace for all 4K content like the GUI which is displayed in BT709?

I got it working great now, but at first I still had some slight banding, though that has been resolved by choosing the closest HDMI port on my Denon X3300 !! So, it is pretty darn important to check that you put it in a port closest to the output HDMI port.

Hi Sam.

Thanks for the good luck, it’s very much appreciated.

Reading back my previous post I realise ‘destroy’ was not quite the word I intended to use!
I’ve read up on the recovery process now; all looks fine.
Many thanks for the assistance.

@sam_nazarko I understand you really want to close this thread, but is there gonna be a new thread for the colorspace issue or is it already resolved?

There will be a new thread when we have made improvements to test.

This thread was about banding and flickering however, which is resolved.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.