Audio Drop Outs/Clicks


I sat down to watch my 4K rip of Dunkirk and noticed a lot of banding. So I looked online and found some advice in the following threads

I applied the following hotfix which seemed the simplest solution

Hooray the banding was gone, but boo I started getting audio drop outs and clicks all over the place.
I went off to ssh in from my Ubuntu box.
I may have originally been on a funny release as my sources.list still had stretch instead of jessie in the paths, but it was fully up to date before I applied the hotfix.
I’ve tried correctly the sources.list back to default

, updating and installing and still the hotfix issues persists.
After I applied the updates again the banding was back so I applied the banding fix detailed here

That fixed the banding but the audio was still dropping out.

I’ve restarted the film where the audio was definitely OK and it’s still clicking and I’ve tried a few other films that are also doing this now.

Has anyone got any advice for me?

You can find my logs here

Stretch superceded Jessie. Not the other way round.

1 Like

I would send you the right sources.list, but I think the best thing to do is take a backup of your kodi settings and start again with a new image.


Ah right, cheers.

I’ve reinstalled OSMC on the Vero again to make sure it’s all correct.
The sounds seems OK but the banding issue is back.
Will apply the banding patch and see what happens.

I think that patch is a bit old.

Not sure if it works with the latest image.

1 Like

I installed the patch
sudo wget “” -O /etc/rc.local
sudo chmod +x /etc/rc.local
And it seems to have fixed my banding and the sound seems good too.

However if there’s a more up to date patch I should be using I’ll switch to that.

The patch downloads something. I wondered if it was still there but it is, so all good.

The patch is no longer needed.

Thanks Sam, what’s the current recommendation for fixing banding in HDR on the latest software?

Enable HDR auto switching or 10-bit output


1 Like

Hmm, I’m still getting odd pops and clicks, although not as bad as yesterday. I don’t think it’s the to as I find a it’s in a different place.
It was playing fine until it suddenly changed the resolution to 720p HDR which ended up in a black screen. I stopped the film and started it again and it started popping occasionally.
Log file at
Well try restarting the Vero to see if it clears it.

Edit:still doing it after a reboot. Going to try playing the film via my PC instead

Edit2: the film played fine in Kodi on my PC, so I’m confident the rip is OK

@sam_nazarko: does HDR auto do anything else regarding banding compared to setting the Vero 4K manually to 4:4:4 10bit ?

It does not – but it will do in the near future.


1 Like