OSMC's February update is here - OSMC

OSMC's February update is ready with a wide range of improvements and fixes to keep your OSMC device running in tip-top shape. Team Kodi have now announced that they have started the official alpha release cycle for Kodi v18 (Leia). Test builds for Raspberry Pi and Vero devices are available in our forums.

This is a companion discussion topic for the original entry at https://osmc.tv/2018/03/osmcs-february-update-is-here-2/

Nice one :slight_smile: Will check it tonight :+1:

No fix for the official OSMC DVB-T2 dongle not supporting HD channels?

Was hoping this was part of this update.

So were we. It’s a tough nut.

i got “an error occured while installing the following package: (unknown package)”. It then tells me to report this on the forum. I don’t have logs enabled and after reboot it says i got February update installed.


2018-03-05 17:09:03 install vero364-image-3.14.29-61-osmc:arm64 61

tried :
root@osmc:/home/osmc# sudo apt-get update && sudo apt-get -y dist-upgrade
Ign:1 http://ftp.debian.org/debian stretch InRelease
Hit:2 http://ftp.debian.org/debian stretch-updates InRelease
Hit:4 http://security.debian.org stretch/updates InRelease
Hit:5 http://ftp.debian.org/debian stretch Release
Hit:3 http://ftp.fau.de/osmc/osmc/apt stretch InRelease
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

After the installation of this update and after a reboot, no IP address is assigned. It says Internet is not working, although it could download the update and install. Now it is not reachable.

Using My OSMC: I see the Wired network adapter is disabled. Tried enabling it without success. Don’t know why. This is bad.

It looks like the update went through fine. You may have had a network problem when the update was first initiated.

If you continue to have issues please start a new post.

Unfortunately it’s hard to advise what the issue is as you haven’t told us which device you’re running OSMC on or whether you’re using WiFi or a Wired connection.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Please start a new post as this thread is not intended for troubleshooting.

so there is just one package to install?

No – the update consisted of multiple packages.

Please start a new post if you continue to have issues.

Please see this thread for more information, it’s going to need a bit of testing and work.


I had to turn off the wired network to get the update over the wireless, but it worked much easier than the last few. (VERO 2)

Thanks for all of your work, folks!

It seems this update has broken my Bluetooth dongle (official dongle, bought from the OSMC store). After the update the Bluetooth menu item was missing from MY OSMC/Network but I could make the system recognize it by plugging out and in. Still, turning on the device does not work. Neither from the GUI nor using bluetoothctl (power on command).

I get a generic error:

[bluetooth]# power on
Failed to set power on: org.bluez.Error.Blocked

A post was split to a new topic: AVR passthrough not working after February update

Please start a new thread for this and post debug logs.

Indeed — we would need to know what device you’re using and see a log


For some reason I can not update osmc on vero4

10:47:44.563 T:3063935744 DEBUG: OSMC settings sending response, update
10:47:44.564 T:2709517056 DEBUG: OSMC UPDATES END
10:47:44.567 T:3063935744 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<–
Error Type: <class ‘socket.error’>
Error Contents: (2, ‘No such file or directory’)
Traceback (most recent call last):
File “/usr/share/kodi/addons/script.module.osmcsetting.updates/resources/lib/call_parent.py”, line 18, in
File “/usr/lib/python2.7/socket.py”, line 228, in meth
return getattr(self._sock,name)(*args)
error: (2, ‘No such file or directory’)
–>End of Python script error report<–
10:47:44.574 T:4080566864 DEBUG: ------ Window Init (DialogNotification.xml) ------
10:47:44.577 T:3063935744 INFO: Python script stopped

Sorry after restart everything working

Please post complete logs in a separate thread

Hi Sam

Thx for update and hard work but…

There is a chance to restore January version of OSMC? On February version banding is a lot more visable than in January :frowning:

Best regards

You can indeed. See https://osmc.tv/download.