[TESTING] 4K HDR playback with banding & flickering fixes

This thread

“As explained, this is a temporary fix.”

From the other thread, linking to this thread.

“Please try the permanent fix: [TESTING] 4K HDR playback with banding & flickering fixes”

So is this a temporary or permanent fix ?

I think Sam means “permanent” because until yesterday, the only way to remove banding was using a parameter manually every time the player starts playing some file. He doesn’t mean “permanent” in the “forever” way, as far as I know due to Sam words, AMLogic is working on the fix.

I updated and am now running latest kernel 78.
Out of the five times I ran the test file from Martorias (the 15sec file), the banding disappeared only the first time after 5 seconds or so.
Since it is really hard to spot with normal movies, I use that one as a reference.

If you still want the debug log, I can provide you one.

Im on -75 and starting (and pausing) my clip i always get rid of banding within one minute.

I guess if you don’t pause my clip it some times won’t work as the one minute timer is outside the clip lenght…

In the latest version there is no one minute timer anymore.
The timer for setting round1 is now defined as:
Start= 1s after bootup
After start= every second

So theoretically banding should disappear max 1s after playback has been started which is not the case. Even 15s and later the banding does not disappear in most cases.
There has to be something that interferes the timer (unlikely because i checked the runtimes) or the setting of round1.

Yes im aware I too can see the numbers, still, the timer trigger around a minute regardless of whats in the service. Why? No clue. Shouldn’t matter as this is more a test to see that it can be set automatically.

Here’s a new test video that’s 5min long. Start it and you’ll see it changes within one minute, every time.

Hdr flicker test video 5min 24fps 10bit 4k

There’s definitely a matter of timing, which is why the original kernel fixes didn’t work as expected.

I wonder if we want to set all of this up before the GLES context is established.

I would suggest wait for the final fix and until it’s ready link to the guide from Martorias using the callback addon.

Thanks, that indeed worked all the time.

I had twice a no signal, but have had that a few times before when switching to 444,10bit.
Had twice an instant no banding, once it was sorted in 10 seconds and the rest of the times it was sorted after 30+ seconds.

I could live with this for awhile, knowing it will be sorted better in a future update.

Why? This seems to work, save for the fact that it takes up until 1 minute to adjust the value. I think that’s ok!

Yes it works but only with delay. Why use a workaround with delay when there is a better workaround without delay? Personally I do not want to wait up to 1 minute until banding disappears after starting a movie.

Because it works out of the box, and as such is better for the product.
There’s nothing stopping you from using callbacks as well or any other solution but this seems like a decent thing to push to live as the banding will usually be gone before the intro logos on movies are over :slight_smile:

Two people, two opinions. I do not think that this is a good workaround for the product.
If the Vero4k was a product of mine I would not release it because it would not fulfill my quality requirements.

The flickering issue was only discovered on a small number of sets many months after the release of the Vero 4K. This flickering issue was also seen using other devices, such as Blu-ray players, with LG OLED sets.

No one suggested that this banding fix was finalised: but we are making progress. The majority of users use the Vero 4K day in, day out, without ever even visiting this forum.

I believe you misunderstood my posting: It was solely related to the actual banding workaround via timer discussed in this thread and not related to the Vero4k in general!

I understand what you mean now.

This isn’t release ready – which is why we’ve made it a testing thread. This is just a test for those that want to see how we are progressing with the issue.

Getting closer – thanks for your patience :slight_smile:


„Not release ready“: That Is my opinion too and what I tried to say before. From my side no hurry because there is a good workaround available.

Following this thread closely as I have the banding issues on my LG oled B7. I tried the temp fix without luck and the manual sudo systemctl start hdr but then I get Failed to start hdr.service: Unit hdr.service not found. What am I doing wrong?

Tja! Have you updated to the latest “test” update as instructed in the first post?

Yep, I think so. On version 3.14.29-78-osmc
and the command “echo round1 >/sys/class/amhdmitx/amhdmitx0/debug” actually breaks the hdmi connection completely and the LG tv says that it lost the connection to the input