[TESTING] 4K HDR playback with banding & flickering fixes


Have you enabled the deep color something lg feature on that hdmi port you have the vero connected to?




Aha! Do you have sudo echo 444,10bit > /sys/class/amhdmitx/amhdmitx0/attr in /etc/rc.local?

Perhaps you could provide logs, it’ll help the more technical guys here. Are you connected straight to the TV?

Im using a lg b6 so shouldn’t be much difference


not in rc.local but tried it manually. log is here: https://paste.osmc.tv/usitodonuw

reinstalled osmc. updated according to first post. After fresh install went through these steps:
1.echo “444,10bit” | sudo tee /sys/class/amhdmitx/amhdmitx0/attr
2.sudo systemctl status hdr.service

and now it seems to work :grinning:


I used the fix script and it does fix the actual problem, but i’ve found the LG C7 i have is pretty horrific for banding even with the fix in place. I don’t think its a problem with the V4K though, i think its just a poor TV, which is disappointing given the great reviews it got.


I have the ATV 4k and there’s now banding issues there on the same media files.


Yeah, I’ve tried files played back directly on the TV, its just not a very good TV.


Sorry. typo, should say that there are NO banding issues when playing the same files on ATV 4K


The banding i’m seeing is present even when played back directly on the TV.


I see my box downloading an update at the moment. Is it anything related to this banding? I shall find out very soon I suppose.


Unless you got the developer build in your source it’s the regular March update which doesn’t solve banding unfortunately.


I’m using the fix which runs a script on playback. Is this likely to be as good as content looks or is there still work to be done around banding? Trying to decide if my TV is faulty.


Difficult to photo, but the sky in “planet earth 2” looks horrendous, like a 300mb SD copy from 15 years ago, and thats from a10GB 4k HDR.


That’s definitely not right. Which part of planet earth 2 i think i have it and can compare


Just any bits of sky really during the first minute of the first episode. The titles too, around the sun especially as it flashes.

I actually think the script thing I set up as per the other thread may have stopped working, looking at other files some are back to flashing in the sky.


I checked around the same parts and without the round1 i get similar results as you but with it set it looks ok

Edit: looks like banding in the thumbnail a bit but it’s the mountains in the back lol


Thanks. I’ve tried disabling the script and it doesn’t change anything. I think it’s stopped working somehow but I’m not sure how. I retraced all steps and redid everything but it doesn’t work,that is to say it doesn’t improve the banding, K Callbacks appears to call the script OK.


Weird. Try adjusting the sleep perhaps, do you have longer time when resolution switching? Set sleep to 5 or something. Can you set the round1 manually while a video is playing, does that help?


Is the setting going to get undone if I seek through a file that’s playing?


No i don’t think so, not unless you stop it. You can pause and trigger it paused as well.


Did you set the bitdepth to “444,10Bit” too?