[TESTING] 4K HDR playback with banding & flickering fixes


I didn’t, I’ll look into doing that


Thanks, that was the key.


I’ve got a LG OLED55C7D TV and tried this fix because i had banding issues while playing UHD content (especially HDR).

This Test build didn’t fixed it for me unfortunately.

The opposite happened: The image is now even worse. I have now problems with banding, as well as problems with flickering. And the image quality is bad, e.g. when looking at the sky - one can see “patterns”, it just looks not good and poor.

The stable channel build didn’t had the “poor image” and “flickering”-problems (but banding).

Any advices from the community or Sam? :slight_smile:

I can try to make a video of the flaws, if needed.

Thanks in advance


Hi. With this build you shouldn’t have flickering, so make sure you’re fully updated. You can check version via uname -a in a ssh connection.
If you have this latest version, and add the 444,10bit thing to rc.local you should have flicker free 10bit hdr, and the banding should go away within one minute. It’s still being worked on so hopefully soon we’ll have a live build that doesnt need any tinkering


OK, after one minute, the “patterns” in the sky go away and the banding seems fixed, too. I see some flickering in a few scenes, though.

Do i have to run the command everytime again? or what do you mean with the rc.local part?

Well, i’m curious for a permanent fix :slight_smile:

Much appreciate your help, thanks!


No need to do anything again.
Check your /etc/rc.local file, It should contain

echo “444,10bit” | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

Before exit



So this should be right.

Why do one have to wait up to 1 minute until the effect becomes visible?


Yeah that should be fine. Currently it’s a workaround, a timer that sets the round1 attribute which gets rid of the banding. The real fix won’t have that delay.


Hi Sam, any ETA for pushing avg Joe’s fix ? I have my box sitting around for almost a month now i guess waiting for some not DIY workaround when you get back from long days at work. No disrespect, but my time is short home so i only need to play my files not to push some command lines especially if i have some company… Meanwhile, i don’t play 4K hdr movies on it.

Personnal note: HDR issue got discovered “many months later” only because “hdr rips” weren’t that spread before and i personnaly learned about V4K only in december when looking at a different solution than my old PC and Kodi Xbox One for playing them…
What would be interesting is to see if people with different oled brands (like sony, philips or panasonic) are getting the same issue but hard to tell if many are same situation as me (not having time for forums, command lines etc…), so not reporting or bothering for the few owners who got a V4K.

Anyway, thanks for supporting your product, i chose yours after long days of debating against NV Shield TV so i hope for the best.


Hi! Some users have issues with projectors so it’s not exclusive lg oleds I believe. Also, not the solution you want perhaps but running this build and adding one line to rc.local will get you flicker free banding free hdr stuff at any hz, without any fiddling while playing. The only downside is it can take up to one minute before the banding dissapears.

Hopefully we’ll have a better solution soon :slight_smile:


You can update for now and it should work reasonably well. No command line intervention is needed



It should be fixed properly now.
I’ll also fix banding on the Kodi menus shortly as that has been brought to my attention.

Awaiting feedback from @Martorias @mule @chamelious et al.

Thanks for the testing and feedback.


No update available for me.


Are you updating via the staging repository?
This hasn’t been pushed as a general update just yet.


Just got the new update and can confirm: Banding is now fixed!
@Sam: Great Work!


No, if someone posts a link to how, i’m happy to try

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.


Did some testing today … works like a charm :+1:


I already told Sam but it works fine for me as well


How long before the general update OTA for everyone? (approx timescale)