[TESTING] 4K HDR playback with banding & flickering fixes


It will be in the next OSMC update, so before the end of April.
There are a few other other improvements I’d like to get in this update window.



I completed the update from the staging repository and I still have banding (which began after the March update). Can someone please confirm the EXACT steps needed just so I can be sure I’m doing this properly?


The exact steps are listed as above. Nothing further should be necessary. Could you run uname -a to confirm that you updated successfully, and can you confirm if you’ve ever updated rc.local to set 10-bit output manually?

Some logs via My OSMC will definitely give clues



I’m out for work whole week, hopefully there ll be such an update next weekend :slight_smile:


For me settings 444,10bit with rc.local is no option because I got 4K files with BT709 colourspace, like the kodi menu … only option for me is to set 444,10bit with every 4K file that has BT2020.

Any solution for that on the horizon?


Can someone post some proper instructions of how to do this temporary fix please, for example Sam’s instructions state “Edit the file /etc/apt/sources.list”…
How does one do this exactly. How do i a gain access to this file

I’m on windows and using putty to login the Vero,



It’s now fixed properly, so just a matter of waiting for it to be included in the next stable release.

You can use sudo nano to edit files. I believe this is covered on the Wiki



Ahhh sudo nano to edit the files, clear as mud. How could I not know how to do that.

After doing what i think is the temporary workaround (cant be sure due to lack of decent instructions) i see no difference, terrible banding in 4k HDR files.

Looks like i’ll have to downgrade to Jan release which was last properly working update for me.

I ran login ‘uname -a’ and gave me this.

‘osmc@Vero4K:~$ 3.14.29-80-osmc #1 SMP Wed Apr 4 16:26:25 UTC 2018 aarch64 GNU/Linux’


Perhaps you don’t have 10-bit output active?

Have you ever edited rc.local?

I should have a build that makes setting this redundant in the next day or so

In the interim: please clarify where the instructions are lacking / where you are getting stuck. I don’t think it has updated properly. Copying and pasting the output from Putty may help.



Where does one set 10bit output active ? Does the device no longer do this itself. I’m coming from Jan update that played 10bit HDR files with no banding.

No I’ve never edited that file you mention.

Your instructions would be so much clearer for average users if you included the nano sudo part. I updated (I think) by just adding ‘nano sudo’ to the start of step 2 and then copy and pasting the line into putty, I then copy and pasted line 3 and exited, choosing yes to save file.
Finally I ran the code at line 4 and the device updated and rebooted.

That is where I’m at now, Banding still present, and yes I waited over 1 minute for it to work upon playback but it never did


Yes sudo nano, common Linux stuff covered in the wiki as well https://osmc.tv/wiki/general/working-with-osmc-via-the-command-line/

You seem to have the latest test build installed so that’s good.
Do sudo nano /etc/rc.local and make sure you have this line before “exit”
sudo echo 444,10bit > /sys/class/amhdmitx/amhdmitx0/attr

Same here, press CTRL+X, Y, Enter to save.

Like Sam is saying, this is a test build and a proper release will be out later (this month) which won’t requires any tinkering.

Edit: these test builds general aren’t for average users as they can be more buggy and contain possible worse errors than before.


You don’t need to wait a minute anymore

10-bit has always been supported, but it’s always been necessary to edit this file for proper 10-bit output.

If you still have problems I will see if I can come up with a better solution.



I will try and work out what Mattorias has posted regards setting 10bit output and see if that helps. Things.

But I may just go back to Jan update and stick with that, worked fine for me.


Ok so I added the line ‘sudo echo 444,10bit > /sys/class/amhdmitx/amhdmitx0/attr’ to my rc.local file and rebooted the Vero.

Sadly banding still present.

Vero>Denon 2400>Philips 65PUS7601

No banding upto and on Jan update with all same kit and settings :frowning:


Weird! If you start a video, and via ssh type “sudo cat /sys/class/amhdmitx/amhdmitx0/attr” what do you see? You should see 444,10bit meaning the 10bit flag has been set


Did you read the comment at the start of rc.local?

# In order to enable or disable this script just change the execution bits.
# By default this script does nothing.

On my Vero 4K the bit was not set. So just run
sudo chmod +x /etc/rc.local
and reboot.


That was it !!
I did what Marc.breuer said and now banding has gone !!

Thanks to you both for helping.

Last question is setting this going to have a negative effect on any other files I play ?
I have a mixture of 4K 10bit HDR files, 4K non HDR files and then standard 1080p files.

Do I need to keep manually changing this setting depending on what I watch ??



No, just leave it as it is.
As far as I have read there is some automatism coming with the next update.


I’m glad to hear this is now working as expected for you. It’s a shame you did run in to these issues – but we are working on improving things.



Banding gone here as well on LG Oled B7. The command sudo systemctl status hdr.service gives me Unit hdr.service could not be found. Is that ok?