[TESTING] Debian Stretch upgrade for OSMC

For the brave: there is no downgrading.

We have now completed the OSMC migration to Debian Stretch and we’d like your feedback.

We’ll soon produce new OSMC images based on Debian Stretch as well. However – in the interim we’d like to get as much feedback as possible, and we’d like to test that the upgrade scenario works smoothly. Most users will be updating rather than installing fresh.

We need feedback before we can make this available in the next OSMC update.

To try this:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv jessie-devel main
  4. Check for updates via My OSMC → Updater.

NB: jessie-devel instead of stretch-devel is intentional. This is a large update (about 500MB in downloads) and will take a while to install on your system. Don’t change this to ‘stretch’ until the update is deemed stable (announced on blog)

While you can update via the command line, this is a less likely upgrade scenario. We’d prefer to check that updating via My OSMC works as expected. Updating via My OSMC will also update you to Stretch automatically instead of requiring you to run upgrade commands again after the initial upgrade.

List of potential issues:

  • Some binaries built on Jessie manually may not work as expected without recompilation.
  • OSMC may not wait for the upgrade to Stretch on reboot if connected to WiFi. There is no ill effect from this, but you may need to check for updates via My OSMC → Updates again.
  • You may see a sad face when OSMC has updated for a few seconds. This is expected and does not infer an issue with the system unless it is displayed on the system repeatedly
  • Those using @gmc’s nightly builds may have issues until a Stretch build is produced.
  • NOOBS installations may not have enough space to complete the upgrade

After updating, you may wish to edit /etc/apt/sources.list again. Change stretch-devel to stretch to revert back to OSMC’s stable update channel

Thanks for your testing. I’m looking forward to your feedback.


1 Like

Hi I have upgraded through the command line. Worked fine no errors, rebooted and the system restarted as should with kodi process running. The kodi log file was ok, no errors.
My system is rather standard with no additional components loaded. Only connected to a mariadb database for the music database

DMESG showed this:
[/lib/systemd/system/connman-wait-for-network.service:9] Invalid escape sequences in line, correcting: "/bin/bash -c “if grep -q nfsroot /proc/cmdline; then exit 0; fi; count=60; while [ $count -gt 0 ]; do if connmanctl state | grep -iq ‘ready|online’; then break; fi; sleep 1; let count-=1; done; exit 0"”

Updated with OSMC Updater
time needed 20 minutes (wired Lan, Internet ADSL)
Update ok
When I start a first movie -->Sad face —> KODI restart —> next time movie played fine.

I make some more test later in the afternoon.


Reboot or just Kodi restarted?

sorry Kodi restart

Can you paste a copy of that file - looks like file corruption to me as the connman-wait-for-network.service script hasn’t been changed in two years.

paste-log /lib/systemd/system/connman-wait-for-network.service

Description=Wait for Network to be Configured

ExecStart=/bin/bash -c “if grep -q nfsroot /proc/cmdline; then exit 0; fi; count=60; while [ $count -gt 0 ]; do if connmanctl state | grep -iq ‘ready|online’; then break; fi; sleep 1; let count-=1; done; exit 0”


For me after Strech and Kodi 17.6 update it’s works like before the update. H264 play forward/back works with the same cache settings, music playing etc

For Kodi 17.6 Scrap work’s better,
and for osmc I’have allways the ffmpeg warning
ffmpeg[F32AC250]: [swscaler] Forcing full internal H chroma due to input having non subsampled chroma
and scrapping stop after.
But this warning I think wasn’t into the update.

Sam & Co, good works for the stretch migration.

As mentioned before, I don’t think this is causing any issues on the system.
I understand you have a library scraping issue but don’t think it’s related to this.

Not only also for first “seeing” of photos and *.ts files, but it’s perhaps my configuration.

Just upgraded my Vero4K following the procedure. Used My OSMC as requested (usually do it CLI). Upgrade took about 30 minutes and worked like a charm. Kodi did not crash (no sad face) and worked after the upgrade was completed.
I expected my Hyperion to be broken (due to changed dependencies) but even that worked.

Great work Sam!!!

PS: will verify tonight on RPI as well.

Updated as suggested using MyOSMC.

Unfortunately after the update no DTS-HD, TrueHD pass-through working anymore. AC-3 and normal DTS pass-through seem to still function. AVR displays “no stream”.

Log set playing “T2_TRAINSPOTTING_2017.mkv”

Also all radio channels from TVheadend not working anymore means no sound but AVR gets LPCM 2.0.

Additionional info of env:
Sony STR-DN840 AVR
all pass-through flags enabled

I’m aware of this problem and now building a solution. There are some audio improvements and they’re in a state of flux but should all be wrapped up tonight. I’ll let you know when a fix is in the repository.

Upgrade through My OSMC on RPI1 was also successful.

Next step: Leia :yum:

Just updated on a RPI2 via My OSMC. Took around 1 hour and everything seems to be working fine.

Great work Sam.

Can you try updating again and let me know if the issue is resolved?


Hi Just updated My Vero 4K trough the OSMC updater and everything went fine.

Unfortunately i still can reproduce my issue due noise and plopping while toggling stereoupmix on/off.

Also for me dts hd and true hd passtrough is not working

@sam_nazarko: Currently no update available.

root@osmc-vero4k:~# more /etc/apt/sources.list
deb http://ftp.debian.org/debian stretch main contrib non-free

deb http://ftp.debian.org/debian/ stretch-updates main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free

deb http://apt.osmc.tv stretch main

deb http://apt.osmc.tv stretch-devel main

For me too

Try checking again please. The mirror can take an hour to synchronise