[TESTING] Debian Stretch upgrade for OSMC


#34

Well, it hasn’t worked in my case. I used exactly this update method after a new installation of 2017.10-1 yesterday in the morning MEST but did the stretch update after the announcement of this thread.


#35

That’s why this is called TESTING


#36

Don’t want to annoy you; testing means the testers should mention obvious malfunctions … what I’ve done with this.


#37

Sorry, I mistook your post as a complaint, not a bug report.


#38

No; this thread is about just having upgraded to Stretch… Next step will be Stretch with Leia. As 17.6 was the last release of Krypton I expect we’ll be getting some beta’s en RC’s in the next months.


#39

Leia test builds are around for quite some time. The just need to be changed to stretch which is happening as we speak



#40

I specifically said beta’s and RC’s. Currently I don’t think these builds are even considered Alpha. They are “nightlies” or development builds. I prefer some more stable releases or I will get in trouble with my bosses (wife and daughter)… :laughing:


#41

Since upgrading the Pi, which shares its USB drive via nfs, nfs-kernel-server is not starting because it can’t find the share at /media/*. I assume this must be an ordering thing in systemd. Which units and/or udev rules are involved here?


#42

It’s not actually appropriate for My OSMC to autoremove packages. It’s up to the user to do this.

Only old kernels are pruned.

Sam


#43

Vero 4K
Just upgraded by method advised.
No issues to report.
Tested:
Files over NFS from NAS OK
YouTube Addon OK
BBC iPlayer OK
TvHeadend DVB-T USB Dongle OK, but no DVB-T2

RPi3
Upgraded without issues
Tested:
Files over NFS from NAS OK
YouTube Addon OK
BBC iPlayer OK
TvHeadend DVB-T/T2 USB Dongle OK

Not sure if this is an OS/Drivers or a Kodi problem
Would be good if the issue over drivers for your DVB-T/T2 Stick could get into the next update as well!
Still no DVB-T2 showing in tvheadend on Vero 4K.

Thanks for all the hard work.


#44

Hi Sam,

To try this:

Login via the command line6
Edit the file /etc/apt/sources.list
Add the following line: deb http://apt.osmc.tv jessie-devel main
Check for updates via My OSMC -> Updater.

It found an update. Installed, black screen. Again blue screen waiting for a connection to the OSMC update server. After a minute or so the message, “No internet connection”.

Now rebooting and trying again.

Update have been downloaded, would you like to exit and install the updates now?

Yes

Installing packages.

0% - 100%

Reboot

Sad face
Restarts automatically
Starts normal

Mysql database connection works

Check for updates again

There are no updates available

After updating, you may wish to edit /etc/apt/sources.list again. Change stretch-devel to stretch to revert back to OSMC’s stable update channel

I think you mean jessie-devel to stretch? You stated,

“NB: jessie-devel instead of stretch-devel is intentional.”

Ahh in the sources it is now stretch-devel. Changed.

Works.

Will post here if there are any issues.

Kind regards,

Duncan.


#45

Thanks for the report. I suspect it might be useful if people could say which devices have been tested.

You mean MySQL server on your device or elsewhere?


#46

Device is a Vero 4K.

Connection is to a MySQL database running on a Synology docker for the videodatabase and musicdatabase in advancedsettings.xml.

Also the CIFS shares to the Synology come up just fine. I configured this in systemd/system.


#47

Hi. Everything goes ok except:

  1. NFS Server

nfs-kernel-server tries to go up before mounting media, despite the systemd policies

  1. OpenVPN

openvpn server starts ok (in systemctl and logs) but I cannot connect until restart server

I think it’s a systemd problem (dependencies with old configurations) and both services were installed by me “manually” without OSMC help.

All about OSMC works ok with stretch

Thank you Sam and team!


#48

Have updated 2 of my systems, both via My OSMC.

Pi0 - WiFi connection, Standard install: Update process took a loooong time (didn’t actually time it but was 1 hour+), but all went smoothly and everything seems to be working OK.

Pi2 - Ethernet connection, Standard install + TVH: Update process was quicker, although still took a while. Again, all went smoothly and everything seems OK, although I’ve not done much testing of TVH as it is for backup/testing purposes on this system and doesn’t get used much.

I have noticed that on both of these systems dmesg shows the following:

systemd[1]: [/lib/systemd/system/connman-wait-for-network.service:9] Invalid escape sequences in line, correcting: "/bin/bash -c “if grep -q nfsroot /proc/cmdline; then exit 0; fi; count=60; while [ $count -gt 0 ]; do if connmanctl state | grep -iq ‘ready|online’; then break; fi; sleep 1; let count-=1; done; exit 0"”

I will be updating another system later tonight that is far more complex with lots extras installed, will report how that goes.


#49

Hey – it’s been a while since we heard from you. Hope all is well.

We are aware of this and will look in to this. Thanks for confirming that you also experience this problem.

Keep us posted


#50

Was OpenVPN installed via apt-get?

Can you elaborate on this one?
I assume you’re sharing a drive.

UDisks is likely starting after nfs-kernel-server. I believe that in Jessie nfs-kernel-server was still an init.d script. It should now be a systemd unit, but this would indeed change ordering and timing.

Have you made changes to the ordering of nfs-kernel-server manually? Out of the box, nfs-kernel-server’s systemd unit won’t be aware of udisks, and as a result, not know that it should be waiting. Some disks may also take some time to spin up, and they may not necessarily be present, so this will require some thought.

Sam


#51

I may have just found something that doesn’t work. I have a2dp-app-osmc installed on the Pi2 to connect to a BT speaker I can use round the house. Was working earlier today, but after upgrading to stretch there is no option to set the Audio output device to Bluetooth, only options are HDMI, Analogue, or HDMI and Analogue. (which, I notice, are not how they used to be named). I know that a2dp is also still testing so it not working with another test is understandable, but might be something to look into.


#52

The current implementation of A2DP is being scrapped as it isn’t sustainable for the long term.

Sam


#53

Hey, it HAS been a while. Been pretty chaotic recently, and moving house last month didn’t help, but things are calming down now. Hope you are good.

Back to topic

Fair enough. It’s not something I use very often, just occasionally when out in the garden or when I want music in the bath. :smiley:

I have now updated the next system again via My OSMC.
Pi3 - Ethernet connection, customised install with TVH (with 2 DVB-T tuners and 1 DVB-T2), MySQL server (now MariaDB???), Samba, FTP server (app store version but with some customisation), nfs-kernel-server, ffmpeg (from deb-multimedia), deluge… probably other stuff too, but I can’t think of anything else right now:

Update process completed smoothly. Quick check so far and MySQL/MariaDB, Samba, nfs and ffmpeg are all working fine.

TVH has lost my DVB-T tuners, but I suspect that is a firmware loading issue that sometimes happens with them and just requires unplugging and replugging, will test in a bit when I can be bothered to reach them.

FTP server was not working as expected, have checked and my customised vsftpd.conf has been overwritten by the standard one (not surprising). Putting my customised version back and restarting vsftpd has fixed it.

Deluge has started, but all my torrents have ‘Error: Missing or invalid torrent data!’. I notice that the deluge version has gone from 1.3.10 under jessie to 1.3.13 under stretch and a ‘Force Re-check’ seems to be fixing the torrent, will let them all re-check and then try restarting, hopefully all will be OK.

Everything else seems to be working well. Will update if I find any other issues. I have 4 more systems (2xPi3, Pi1, Pi0w) that I can test on, but will have to update them via CLI as they are installed at my parents house and I don’t fancy the 2.5 hour drive just to get physical access to them.