[TESTING] Kodi 16 (Jarvis) test builds for OSMC


#30

I’ve had chance to upgrade to Jarvis now after the fresh install. Everything went well this time. I’ve put Mimic skin back on which after a reboot needed me to reboot with SSH as it seemed to lock up but after that everything seems good. All the text and menu options are present and long videos seem to be working. Now to reinstall my addons one by one to see if any of them caused the previous video issue or if it was just a generally broken install.


#31

to not mix too many topics here, I opened a new thread for my airplay problem, I would be happy if guys could have a look: Airplay audio-only streaming not working on Jarvis


#32

Thanks for looking popcornmix.

All files that i’m playing are in this format.

Openelec has no problems playing this files


#33

Are you tesing an OpenELEC Jarvis build though? A lot has changed.

Sam


#34

I upgraded from Jarvis to kodi 17 alpha milhouse testbuild on my rpi 2 and both played all my files good no skipping frames.


#35

That’s Kodi 17, and builds here are based on Kodi 16 (Jarvis).

Kodi 17 Milhouse builds are based on newclock5 branch. Converely our Jarvis builds backport only a subset of newclock5 changes. If you want to try a Kodi 17 alpha build with newclock5, much akin to Milhouse builds, then you’d be better off using builds in this thread [TESTING] Kodi 17 test builds for Raspberry Pi

Sam


#36

Thanks Sam


#37

Hello,

i just installed this test version and at least on my TV, CEC is not working anymore. Do you have tipps for me to test what is wrong or what has changed in between the versions?

Felix

PS just installed on my 2nd Raspberry Pi 2 and it does work there, going to reinstall it on the first, maybe something broke.

Yeah, somehow messed up the first install now CEC does work as it should on both systems


#38

I didn’t mention it, but my CEC kept working (Sony Bravia)


#39

Hi,

I moved to this Jarvis build with no problem. :clap: :clap:

Despite my first statement,I have a small issue with the skin I used ‘Aeon Nox Silvo’. They use a Repository (installed on my RP2). With that configuration, no skin update is found on their repository and no compatible skin for this Jarvis build. Of course, a Jarvis compatible version exists and is available.

I asked the skin team and they asked me to check if the current Jarvis build of OSMC identifies itself as a Jarvis build or not.

Bottom line, my question is if the Jarvis build of OSMC identifies itself as a Jarvis version to enable updates of addons/skins? In particular, the author tells to be sure of the value for minversion tag.

Thanks in advance for your help.

M.

EDIT: Addition of the minversion tag precision


#40

Hi,

after starting with OpenElec on the Raspi2 and then giving XBian a shot I’ve tried the OSMC test build with Kodi 16 today. Looks for me like the best distribution so far :slightly_smiling:

But back to the thread: I’m using the RasPi frontend for nothing but live TV and recordings via TVHeadend. In that build there seems to be a Kodi startup issue relating to the TVHeadend plugin. In most cases with activated plugin the complete system freezes during the start of Kodi. I just see the background wallpaper of the confluence skin, no menus, no text - nothing. I’m not able to SSH into the device in that state.

As soon as I remove the LAN cable everything starts smooth. Once Kodi is up and running I can plug the LAN back in and all is fine. So no definite showstopper but very confusing until you found out how to get the box up. And not very convenient if a restart is needed.

No problems with Jarvis and the TVH plugin version on PC/MAC … looks like some “special timing issue” during startup.


#41

Not sure if it will help but try turning on “wait for network” in MyOSMC>Network


#42

@Dilligaf: Yap, I’ve tried that yesterday and so far that seems to work. :wink:


#43

Yes – OSMC’s Jarvis builds will correctly identify themselves as other Jarvis builds would:

WEBSITE http://kodi.tv
VERSION_MAJOR 16
VERSION_MINOR 0
VERSION_TAG BETA5
VERSION_CODE 159805
ADDON_API 15.9.805

#44

I have fixed that and will include it in the next Jarvis test build:

Sam


#45

Hi Guys, please tell me once we are on this test builds is there any option to revert/update on the latest stable Kodi version ?


#46

yeah it looks like the bug I reported will be solved.

Thanks for letting us try Jarvis early to report bugs.


#47

Firstly thank you for making these builds available. The upgrade from Kodi 15 is a welcome improvement.

I wanted to mention that I’m also seeing buffering and jerky playback, similar to what Marciano mentions. This only appears to affect Live TV, and only SD (mpeg-2), not HD (mpeg-4). What appears to happen is that the video buffer empties, so the stream stops while it fills; but as soon as it fills, it plays all the video in the buffer very quickly and starts buffering again. Pausing the stream for a few seconds, and then resuming, fixes the problem.

I’ve posted a section of debug log at http://xbmclogs.com/pexpyb7pp.

Any ideas?


#48

Hi there!
Can you please provide complete debug logs? Have you purchased and installed the mpeg2 codec from the Raspberry Pi foundation?

Thanks! :+1::laughing::point_up:


#49

Sure. Full log at http://www.xbmclogs.com/pd3uzlfiv. Interestingly I also discovered that it doesn’t happen on the first channel which is played - the problem only starts once I switch channel (at 11:34:33 in this log).

Yes I’m using the hardware mpeg2 codec.