[TESTING] Kodi 16 (Jarvis) test builds for OSMC

I am having some regressions regarding PVR but i think it is more related to kodi itself. I have started a thread on kodi forum here and hopefully it will be solved before final release.

Are we likely to be upgraded to the rc for me to test to see if the bugs are solved ?

Certainly. I’ll update this thread regularly as Kodi Jarvis is further developed


wow upgrade to the stable version?


yes, your’re right, I never realized that I was still runnning one of the early alphas. But it just worked, so I didn’t care :slight_smile: No, I updated and am looking forward to the newest OSMC.
@RubenSoares: You cannot update via Auto updater, instead you should do a backup of your settings in the OSMC program app and then flush your SD card, install the new version and reimport the settings.

1 Like

I am testing the test build now, so far I have not encountered any bugs, good work!
My main motivation for testing jarvis, however, is for using airplay again. It stopped working after I updated my iPad to ios 9.x. Unfortunately it’s not working for me. I enabled airplay in osmc and disabled the airplay support for Video&Pictures. This way I should be able to play from iPad to OSMC. When I try to stream any ipad app to osmc, it stops local playback for one second (no sound plays on OSMC) and then switchs back to playing locally. My logs are here: http://paste.osmc.io/eduvililah
When I try using airplay it reflects in these errors:

17:11:15 671.919373 T:1958089264   ERROR: Init: Error opening file pipe://9/
17:11:15 671.919617 T:1958089264   ERROR: CAudioDecoder: Unable to Init Codec while loading file pipe://9/
17:11:15 671.919739 T:1958089264 WARNING: PAPlayer::QueueNextFileEx - Failed to create the decoder
17:11:16 673.002563 T:1778258928  NOTICE: Skin Helper Service --> Video database changed, refreshing widgets....

any idea how to fix that?

Thanks. A quick look seemed to have a visible stutter with a skipped frame about once a minute.
I’ll need to dig further to see if there’s anything suspicious in the file (e.g. spurious timestamps).
However normally web-dl files are well encoded and don’t cause any issue.

I’ve just tried updating and am having major problems. I seem to have a recurrence of the the problem from August / September (iirc) of menu items / text disappearing (much more missing this time though) but also some very long pauses. I have a backup but when I get chance I’ll try a clean install on another SD as I did have some oddness previously going on with sound playing for large MKV’s but the frozen menu being the only thing on screen.

Yes, I was expecting this, from the fact that skin changes require a Kodi restart, which is not intended behaviour. Changes in the way Kodi sends information from one thread to another (ApplicationMessenger) means that my rebase probably needs a bit of work. It was very much ‘compile tested’ only. I’ll let you know when I’ve improved upon this and I’d appreciate it if you could let me know if the issue is resolved when this is done.



No problem, I think I was due a reinstall anyway so have just done a fresh install. I seemed to be having a problem with large videos not playing properly, the audio would start but the screen would freeze on the menu. Bizarrely I’d tried a few restarts after updating to Jarvis but powering off fully and then starting again seemed to fix most but not all of the missing text. When everyone has done with the TV I shall have a play with the fresh install

I’ve had chance to upgrade to Jarvis now after the fresh install. Everything went well this time. I’ve put Mimic skin back on which after a reboot needed me to reboot with SSH as it seemed to lock up but after that everything seems good. All the text and menu options are present and long videos seem to be working. Now to reinstall my addons one by one to see if any of them caused the previous video issue or if it was just a generally broken install.

to not mix too many topics here, I opened a new thread for my airplay problem, I would be happy if guys could have a look: Airplay audio-only streaming not working on Jarvis

Thanks for looking popcornmix.

All files that i’m playing are in this format.

Openelec has no problems playing this files

Are you tesing an OpenELEC Jarvis build though? A lot has changed.


I upgraded from Jarvis to kodi 17 alpha milhouse testbuild on my rpi 2 and both played all my files good no skipping frames.

That’s Kodi 17, and builds here are based on Kodi 16 (Jarvis).

Kodi 17 Milhouse builds are based on newclock5 branch. Converely our Jarvis builds backport only a subset of newclock5 changes. If you want to try a Kodi 17 alpha build with newclock5, much akin to Milhouse builds, then you’d be better off using builds in this thread [TESTING] Kodi 17 test builds for Raspberry Pi


Thanks Sam


i just installed this test version and at least on my TV, CEC is not working anymore. Do you have tipps for me to test what is wrong or what has changed in between the versions?


PS just installed on my 2nd Raspberry Pi 2 and it does work there, going to reinstall it on the first, maybe something broke.

Yeah, somehow messed up the first install now CEC does work as it should on both systems

I didn’t mention it, but my CEC kept working (Sony Bravia)


I moved to this Jarvis build with no problem. :clap: :clap:

Despite my first statement,I have a small issue with the skin I used ‘Aeon Nox Silvo’. They use a Repository (installed on my RP2). With that configuration, no skin update is found on their repository and no compatible skin for this Jarvis build. Of course, a Jarvis compatible version exists and is available.

I asked the skin team and they asked me to check if the current Jarvis build of OSMC identifies itself as a Jarvis build or not.

Bottom line, my question is if the Jarvis build of OSMC identifies itself as a Jarvis version to enable updates of addons/skins? In particular, the author tells to be sure of the value for minversion tag.

Thanks in advance for your help.


EDIT: Addition of the minversion tag precision


after starting with OpenElec on the Raspi2 and then giving XBian a shot I’ve tried the OSMC test build with Kodi 16 today. Looks for me like the best distribution so far :slightly_smiling:

But back to the thread: I’m using the RasPi frontend for nothing but live TV and recordings via TVHeadend. In that build there seems to be a Kodi startup issue relating to the TVHeadend plugin. In most cases with activated plugin the complete system freezes during the start of Kodi. I just see the background wallpaper of the confluence skin, no menus, no text - nothing. I’m not able to SSH into the device in that state.

As soon as I remove the LAN cable everything starts smooth. Once Kodi is up and running I can plug the LAN back in and all is fine. So no definite showstopper but very confusing until you found out how to get the box up. And not very convenient if a restart is needed.

No problems with Jarvis and the TVH plugin version on PC/MAC … looks like some “special timing issue” during startup.