[TESTING] Kodi 16 (Jarvis) test builds for OSMC

Not sure if it will help but try turning on “wait for network” in MyOSMC>Network

@Dilligaf: Yap, I’ve tried that yesterday and so far that seems to work. :wink:

Yes – OSMC’s Jarvis builds will correctly identify themselves as other Jarvis builds would:

WEBSITE http://kodi.tv
ADDON_API 15.9.805

I have fixed that and will include it in the next Jarvis test build:


Hi Guys, please tell me once we are on this test builds is there any option to revert/update on the latest stable Kodi version ?

yeah it looks like the bug I reported will be solved.

Thanks for letting us try Jarvis early to report bugs.

Firstly thank you for making these builds available. The upgrade from Kodi 15 is a welcome improvement.

I wanted to mention that I’m also seeing buffering and jerky playback, similar to what Marciano mentions. This only appears to affect Live TV, and only SD (mpeg-2), not HD (mpeg-4). What appears to happen is that the video buffer empties, so the stream stops while it fills; but as soon as it fills, it plays all the video in the buffer very quickly and starts buffering again. Pausing the stream for a few seconds, and then resuming, fixes the problem.

I’ve posted a section of debug log at http://xbmclogs.com/pexpyb7pp.

Any ideas?

Hi there!
Can you please provide complete debug logs? Have you purchased and installed the mpeg2 codec from the Raspberry Pi foundation?

Thanks! :+1::laughing::point_up:

Sure. Full log at http://www.xbmclogs.com/pd3uzlfiv. Interestingly I also discovered that it doesn’t happen on the first channel which is played - the problem only starts once I switch channel (at 11:34:33 in this log).

Yes I’m using the hardware mpeg2 codec.

Turns out pausing and restarting only solves the problem briefly. It starts happening again after a couple of minutes.

Can you switch from “PLL adjust” to “resample audio” as sync method. The PLL method is not good with live TV.

Sure. I tried PLL adjust because it seemed to make things marginally better than Resample Audio.

Updated log at http://xbmclogs.com/pfyrkr8qf.

For the record: this does also happen with MPEG-4. Maybe slightly less frequently.

And different without your advancedsetting.xml file?

Not really. The advancedsettings were an attempt to solve the problem. The only thing they achieved was making it a bit more obvious what was going on by forcing the playback to stop for longer, and slowing down the loop.

Is the tv server backend up to date?

Is the tv server backend up to date?

It’s running tvheadend 4.0.8 - the latest from the tvheadend 4.0 pre-release repository. This seemed to be working ok before I upgraded osmc, so the backend wouldn’t be my first suspect. Happy to try with a different version if you think it might help, though.

Are updates to these builds delivered through My OSMC or do we need to update manually?

Beta 5 is out… getting ready to update :slightly_smiling:

1 Like

You’ll need to update manually