[TESTING] Kodi 17 (Krypton) Beta Builds for all platforms


No but you can easily work this out by moving them away one at a time


I deleted addons folder and still sad faces shows up… I went even further and deleted all kodi folders, still the same problem. I think I messed up big time. Probaby I will need to reinstall SD card


I have moved to my desktop the folden “Add-ons” and the deleted the folder

I have deleted the folder into the following paths:

The bootloop persist
How Can I resolve this problem?
Thank You


Well by doing so you have destroyed your kodi installation.
You should have only removed the /home/osmc/.kodi folder


Good. I had not deleted the folders. I had Just renamed.

.Kodi is a hidden folder
Non I try
Thank You


I probably should post this in a Kodi forum, but I’ll try here first:
When adding to music library my mp3 files, where artist has a colon sign in the tag, it’s being split into two different Artists in library. For example (as in my log here: http://paste.osmc.io/iqokalatev) I was trying to add a band called “Operation: Mindcrime”, and in the library it’s split into “Operation” and “Mindcrime”. Both of the entries point to the same album and it’s playing from both entries as well.

I’ve tried with other artists, as weel (Sixx:A.M. became A.M. and Sixx).

P.S. I’ve set debugging on, i don’t know why it says “Disabled debug logging due to GUI setting”.

P.P.S. I’m using Sam’s latest Krypton build.


Check out the itemseparator tag here http://kodi.wiki/view/Advancedsettings.xml#musiclibrary for whatever reason Kodi is interpreting the colon as a separator, I’m not sure if you can disable this or not


Hi, I’ve tried to add
<advancedsettings> <musiclibrary> <itemseparator> / </itemseparator> </musiclibrary> </advancedsettings>
like in Your example, but it didn’t work (i’ve deleted the database and added items once more).


This is probably a good reason to go back to the stable build.


Yeap you are right.

I got v17 on clean osmc latest built - everything works great, new look suits more for me. If I got any crash I will post logs here.


Sadface Loop:

Install the latest v17 on latest OSMC stable release. Works fine until Kodi tries to update OSMC addon. Update fails and sadface loop begins.

Move .kodi and Kodi runs fine again until the addon update. Rinse and repeat.

Current build is unworkable.

Edit: Install is clean install on pi3


Kodi shouldn’t be trying to update the OSMC add-on, as we don’t update this through a Kodi repository.

Can you post a debug log of this issue?


After update to RC1 I had sad face - it seemed that one of experimental add-ons was broken so I removed repository but it didn’t help. But after removing Addons26.db everything is fine. Thanks.


Hi again, if anyone else has a solution to this, I would be much obliged :wink: The itemseperator tag didn’t work.


This really is a kodi issue and you should search for a soluition on their forums.


Thanks for the reply, I found out here that it’s not a bug it’s a feature :slight_smile: so @Dilligaf was right, but i think in v17 the syntax of the musiclibrary tag was changed. So I’ve got it working properly. Thanks for all your work, people.


Echoing ma6cb’s issue…

I am using an RPi3 setup.

First, Thanks so much for all the work done by the osmc team to fork kodi for the RPi. I have always been a longtime kodi user and the osmc dork is all i user on my Pi, which is now my primary mediacenter.

I recently updated to the beta/rc V17 and everything seemed ok after I deleted the addons26.db and addons20.db to get past the initial sadface bootloop.

Since doing so I have had my hidden menu items (radio, tv, etc) reappear as if they were never hidden in skin settings and I have had the Video Calibration settings reset to remove my overscan adjustments.

I changed everything back then downloaded the two settings files, guisettings and the skin settings file. The changes did in fact save to those files.

I have fixed it multiple times, changing between skins in order to “work around” as ma6cb linked to did not seem to work.

It does not do it every time. Does not seem to necessarily follow a rhyme or reason. I do have my Pi plugged into a master/slave surge protector scenario so it turns on when my tv turns on and removes power when the tv turns off. I do always properly shut it down first, giving ample time for power down before powering off the tv (effectively unplugging the Pi).

If it happens again (reset of settings) I’ll upload the logs created directly after.


Be very certain of this because, the behavior you describe is exactly what would be expected when not gracefully shutting down.



after using Kodi 16 for a year I’ve just successfully upgraded to Kodi 17 on a Pi2. All looks good so far - thanks for all the work!

Just one question: using my remote control via cec worked on 16 but stopped working for me after the upgrade. I found out it starts working again if I ssh into the OSMC box and start cec-client manually. However, the cec adapter in the input device settings is activated, so I’d expected to have the cec-client run automatically. I’d rather not set up the start of the cec-client on the OS level. How is this supposed to work via OSMC?



I’ve the same problems regarding settings since gmc test builds. I’m now on Beta 7.
The problem appears from time to time. Configurations disappear or old ones appear after reboot.
I shut down / reboot by using Yatse, a physical button connected to GPIO calling a script including “sudo shutdown -h now” or by using ssh. Changes in guisettings.xml and settings.xml from skin directory disappear. Neither changing settings by using the gui nor changing the files directly after stopping mediacenter make any difference. I even wrote little script to backup settings:

sudo systemctl stop mediacenter
sudo cp /home/osmc/guisettings_backup.xml /home/osmc/.kodi/userdata/guisettings.xml
sudo cp /home/osmc/settings_kueche_backup.xml /home/osmc/.kodi/userdata/addon_data/skin.kueche/settings.xml
sudo systemctl start mediacenter

First I thought I messed up the skin because I modded the original Estouchy skin to fit my needs. But after upgrading another installion with original Estuary skin the problem also appears sometimes.