[TESTING] Kodi 17 (Krypton) builds for Raspberry Pi (continued)


You need to use OSMC.
I suspect HomeAssistant will run on OSMC


thanks I will need to find another solution then.


https://osmc.tv/download is all you need.


thanks but I also want to run homeassistant on the same rpi.


I checked, and HomeAssistant only depends on Python 3.

This is available in OSMC. So you can run HomeAssistant under OSMC without issue.



do you know if i can get the filmon app on osmc? just installed the img amd messing with it but cant find that addon (the only one I really want )


OSMC has the FilmOn PVR add-on yes.

I suggest you familiarise yourself with it and start a new forum post if you have any further questions



ya Im trying but I cant finds any info on installing it


It’s under Add-ons.

Start a thread if things are not as expected.



May I add another possible bug in the Krypton betas? :stuck_out_tongue:

Video playback in combination with .edl files seems to be broken. When a file is played with a corresponding edl the starting points of cuts are recognized correctly. 10 sec before the cut an info message is displayed (this is new with Krypton and I find it very helpful).
Then the video player jumps from the beginning of the cut, but doesn’t end at the correct time. Instead it jumps much further than the file actually defines.

I uploaded a shortened excerpt from the logs to the pastebin, but have honestly no idea how to link it here.


When you upload a log, you will be given a URL.

Please post this here.


This is the only link I got, hope I got it right.


The log doesn’t look suspicious to me. In line 20758 for example you can see one skipping, showing the right times. Seektime does show a slight variance but I guess that is ok.


Thank you

Debug logging is currently very comprehensive.
This will change when newclock5 is rebased to backports proper.

For now I would say that your issue will likely be resolved soon. VideoPlayer improvements are being made regularly.

If the issue still persists after the next release, please ping me and we’ll take a further look.




@sam_nazarko are you ignoring me or what? :confused:
You did asked me for log, I did take time to reproduce the interface randomly reseting after reboot using other PI, other SD , clean intalled everything etcc… and uploaded logs 2 times.

Since I have zero feedback I can’t know if my log are showing something related or not to the issue.



Very few hours in the day for me. Many users, and many reports.

Your log shows the issue is present with TVHeadend.

Are you ignoring me ;)?

Seriously though: lighten up. If settings revert on a reboot, it’s almost always a hardware issue.

Try another SD / power supply, and let me know if the problem persists. We have good ones at https://osmc.tv/store.

If you ever need to get in direct contact just PM me. I read almost every post on this forum now, but don’t always reply, as often enough, someone can chime in with some advice and it saves me a little bit of time.

Try Jarvis first. If you still get problems, it’s worth exploring your setup / peripherals.



CONTACT! :joy:
As I told you I have already change the SD card and even change the Raspberry pi 3 with new one.

I didn’t try to change the PSU, but I will do tomorow even if it is the official 2.5A brand new one.

Edit : Ok I will go back to Jarvis and test
Edit 2 : one thing I did forget to mention is that each time I do a dist-upgrade and reboot the first time with the new build, kodi starts, sit for 1 or 2 second then crash, reboot and then it never crash again.


Follow Jarvis recommendation above first.

My bad. I read a lot of posts and with a thread this long it can be tricky to stay on top of things.

You are describing a bug that has been covered frequently throughout this thread, and this forum in general. The good news is it will be solved soon.


Thank you for your quick reply. :smiley:

Just to make sure I got it right: what do you mean with next release? The next nightly, next beta, RC or v18?


The next Kodi Krypton build will be Beta 6.

It will be posted here.


Then could it be related? Since those crash may lead to sd corruption maybe?
But why other doesnt have the issue…

Addon Errors - no connection possible