[TESTING] Kodi 17 (Krypton) builds for Raspberry Pi (continued)


These are two different approaches to install Kodi 17 (Krypton). In this thread nightly versions are provided and discussed.
You are using the beta stable approach which you should stick to as it is more stable. For that one you will get updates (when they are provided) via sudo apt-get update && sudo apt-get dist-upgrade


Thank you, finally figured out that all my problems and frustrations have been from a bad WinSCP install, getting things moving again now.


Ok that makes sense thanks :slight_smile:


16.8-198, 01 Dec 2016: Based off OSMC commit (b9120ae19) and newclock5 (a1d171f)

Build Highlights:
Temporarily removed peripheral.joystick due to build errors.

Controller fixes (PR:10630, 12 commits, 27 files changed)
aml: Support for 4K H264 on S905X (PR:10944, 2 commits, 4 files changed)
rbp: Don’t close the display here it should be closed by the opener (PR:11006, 1 commit, 1 file changed)
fixed: tighten vcd .dat file checks to avoid unwanted filtering (PR:11004, 1 commit, 1 file changed)
remove unused variables / members (PR:10980, 1 commit, 14 files changed)

Tweaked backgrounds (PR:137, 1 commit, 19 files changed)
videoinfo: increase helperlabel width (3813fc0c)
settingscategory levels button (3ac2bfd2)
streamline playlist window (1120f02f)
videoinfo grouping (27528adc)
eventlog tweaks (b8d69931)
eventlog work (9e82c6bb)
tweak fav animations to be consistent with rest (c0d1c274)

Fix EPG after API change (PR:59, 1 commit, 3 files changed)


New commits in this build:
Revert “[hifiberry] Hack: force it to be recognised as IEC958 capable to enable passthrough options” (a1d171ff)

Commits no longer in build:
rbp: Don’t close the display here it should be closed by the opener (0951bbb4)


Inputsteam.adaptive is now correctly built with version 199.


Thanks - I could activate the addon. My Amazon prime addon does not start any streams. Need to figure out why … Could be an issue with one of the plugins (obviously).

.199 seems more unstable, I have some sudden reboots. I will see if I can figure out in what situation this happens and post a log then.


You need Widevine libraries installed.


I know … I had it working from .160 to .197 … I never had to re-install widevine after upgrading. But I will check this for .199. I do not think it is OSMC related (so out of scope for this thread); I just mentioned it here because the only change I noticed in this regard was the new inputstream addon.

But as we are talking about this: widevine could not possibly be part of OSMC, right? I assume it’s due to licensing issues?


You need to install the Widevine libraries yourself at this time.


Thanks very much for the quick reply!

and though it makes me feel rather dumb - happy to report that so far it actually does work on raspbian.
I ignored the error and started testing - not done much yet, no addons or playback, but seems fine.
Most importantly, scaling of the touchscreen coordinates works a charm.
The only issue I have noticed so far is the infamous black screen on exit.

Thanks for all the work on this


i’m wondering does this branch include the bootcode.bin and start.elf for USB only booting, i’ve already enabled the mode using the guide on RPI foundation and checked the OTP and i have indeed enabled it in, eager to test out OSMC running on my OCZ in a USB3.0 caddy.


These builds no not interfere with OSMC’s shipped firmware.

OSMC’s firmware includes changes required for USB boot.

IMHO, this is a waste of an SSD. A good SD card will be fine.


thanks for the lightening fast reply Sam, so i would be good to go by simply writing the latest stable release to a USB drive? its more a test and tinkering than a long term use just wanna test it out. was considering moving my TVHeadEnd backend over to the Pi and need move storage locally so decided to try a sole USB build, i am aware that the USB and Ethernet are on the same bus so i might experience some issues but still i’ll give it a go. Thanks again man.


Yes – but you’ll need to know what you’re doing (how to configure cmdline, fstab etc), as the current OSMC installer still configures /boot to exist on an SD card.

But some people have mentioned this in the forum already

For storing content such as TV, an SSD is complete overkill.


Ok as on Sam_nazarko advise ! 3 days ago loaded Krypton to my Raspberry Pi-3
HDhomerun with cable card RUNS PERFECT !! love the gui for live tv !! Spent 2 days scanning in my library from Mycloud over nfs gig network TV shows and Movies all scanned in…
before I put up a log maybe you already know of these issues.

  1. Small percentage of my movies are missing cover art. All my movies have been scanned by Ember Media so I have all nfo, art in the folders when I manually go in to set the art it doesn’t show.

  2. On my Personal Home family videos which the format is mpg have a lot of buffering. The fix for me was changed the folder location from nfs to smb and it fixed the play back problem

  3. No weather addon ? Couldn’t even try to get one nothing shows up

  4. Any Video addons no way to get them ?

Everything else LOOKS GREAT !!


Probably need to enable your add-ons first.


I installed the HD addon been all over the interface even have 3rd party turned on haven’t seen a button say enable your add-ons

Under Font settings we used to have Large Fonts I gone now ?



[UPDATE: I found the respektive inputstream thread; I did not get it working, but it’s quite obvious add-on related. Seems that the adaptive add-on is still under heavy development. ]

widevine is installed properly … It seems to me that the inputstream addon is not working.

I cannot find anything about “inputstream.adaptive” in peak3d GIT thread. I only find inputstream.mpd and inputstream.smoothstream. inputstream.smoothstream depends on inputstream.mpd and requires libssd_wv.so. I cannot find the libssd_wv.so anywhere in .199 …

There is a folder, but the lib-subfolder is empty:

osmc@osmc-Preston:~/.kodi/cdm/kodi/addons/inputstream.mpd/lib$ ls -al
insgesamt 8
drwxr-xr-x 2 root root 4096 Aug 14 09:14 .
drwxr-xr-x 3 root root 4096 Dez  2 17:21 ..

I tried to copy libssd_wv.so in /home/osmc/.kodi/cdm directly (the dirty way …) but that did not work, too.

I tried to deactivate inputstream.adaptive and to install inputstream.mpd and inputstream.smoothstream from zip repository, but there was a conflict with kodi.inputstream and it did not work either.


In previous version setting AZERTY french keyboard was effectively setting keyboard to AZERTY in Kodi’s interface (but not in the command line interface wich makes any command a nightmare to enter).

In the last version setting keyboard to AZERTY only change the on screen displayed keyboard but NOT the hardware layout that remains QWERTY inside kodi and of course inside command line…

For me the libCEC 4.0 is broken, doesnt start AVR nor stop it. Stoping the video when turning off TV effectively stop the live TV or movie from playing and the TV goes into standby. Resuming from standby gives a blank screen (and doesnt wake up the AVR) and only pressing special colored touch key on the remote bring kodi’s inteface back.

To sumurize in my home I am now the only one to know how to turn on my TV and use it… :wink:


Dumped 17 nothing works went to 18 Everything WORKS !!!