[TESTING] Kodi v18 release builds

#22

No image files will normally only be produced a couple of days after the stable release. So Image of December plus this test upgrade is currently the way to go.

1 Like
#23

Update went well, only issue I had was that the resolution changed to 480p@60Hz

osmc@vero4k:~$ cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 3
VIC: 3 720x480p60hz
Colour depth: 10-bit
Colourspace: YUV444
Colour range: limited
EOTF: SDR
YCC colour range: limited
PLL clock: 0xc00002e1, Vid clock div 0x000b0000
audio config: on
3D config: off

osmc@vero4k:~$ cat /sys/class/amhdmitx/amhdmitx0/disp_cap
480p60hz
576p50hz
720p60hz
1080i60hz
1080p60hz
720p50hz
1080i50hz
1080p30hz
1080p50hz
1080p24hz
2160p30hz
2160p25hz
2160p24hz
smpte24hz
smpte50hz
smpte60hz
smpte50hz420
smpte60hz420
2160p50hz
2160p60hz
2160p50hz420
2160p60hz420

#24

Known issue when going from v17 to v18. Just re-set it.

#25

After some tests I noticed that the HDR_Flicker_10bit24fps.mp4 we used in previous tests doesn’t work anymore, I get a blue screen from my AVR.
But other 10bit HDR movies are playing fine, maybe a mp4 file issue?

Resolution switching after whitelisting all modes works perfectly!

#26

Did that, didn’t know it was known, maybe add it to the known issues?
Was ofc no problem to set it :slight_smile:

#27

It was only known since yesterday and only happens on upgrading. I’m not sure if it’s worth trying to fix it.

#28

Does it play with “enable Force 422” in settings->system->video ?

#29

I’m not saying you have to fix it, just mention it.

1 Like
#30

This sounds like it might be an issue we had a long discussion about last year:

The short version is that there is a bug in Kodi (rather than OSMC). If the material is 576i, 576p, 480i, or 480p, and has a 4:3 aspect ratio, and if the device is set to output it at 576p or 480p, then instead of telling the display to use 4:3 mode, Kodi tells it to use 16:9 mode and horizontally downscales the picture.

Most people don’t spot this, because as long as the display is either locked to 16:9 or set to switch aspect ratio dynamically, the eventual picture has the correct aspect ratio - it just loses horizontal resolution from being downscaled and then upscaled again.

I did try starting a thread about it on the Kodi forums, but the Kodi devs simply ignored it, so I doubt it’ll ever be fixed. Just got to remember to switch to “Stretch 16:9”.

(It’s worth checking that the source video actually is 720x576, though - some stuff on Netflix, for example, is actually 720x540; for that, an alternative is to set the output resolution to either 720p/50 or 1080p/50, and set the video display mode to “Original Size”. You then get an unscaled image, but your VP won’t upscale it to full screen. Personally, I prefer to watch SD material at less-than-full-screen upscaling anyway, because I find blowing it up to 65" makes it intolerably soft, even with state of the art upscaling. YMMV.)

#31

From a fresh install and upgrade to Kodi 18.2RC1 I noticed that My OSMC -> App Store and Services is not working. When you enter both App Store and Services, you can not scroll up/down, the only thing you can do is press Escape to leave.
Hardware: Vero 4K+

Debug Logs are here.

1 Like
#32

@thansen_dk Thx, we already detected this in the afternoon.

1 Like
#33

It does, but then I see banding again :frowning:

#35

@angry.sardine sounds exactly as what I am experiencing and the devs are aware of this issue, although it is a Kodi problem. They might hopefully try to address it after 18 is released :wink:

#36

Updated from latest 17.6 release last night on my Raspberry Pi2B. No issues whatsoever so far! Except for the Amber Skin add-on not being compatible with Kodi 18 (didn’t know I still had it) so I removed it.

Thanks Sam to you and the team for your hard work on this and for making this process as professional and pain free as possible.

#38

I’m having issues playback with the Netflix addon and my Vero4k rebooted after i made a backup.
Anyone else?

#39

Should be fixed now, can you update again?

Sam

#40

Thanks for feedback so far – will follow up shortly

Sam

#41

@andre3030, did you have netflix installed previously? Try uninstalling Netflix addon, and answer yes to remove all settings, then reinstall it.

I did a clean install, image 2018.12-1 then upgraded to Leia 18.2-rc1 and installed Netflix with one issue, libwidvine needed some missing libs, which was simply fixed, you can read about it here: [HOW-TO ALL PLATFORMS]Can I use Netflix on OSMC?(post 4)

1 Like
#42

Yes, it is fixed :slight_smile:

Thanks

1 Like
#43

I upgraded my Vero4k+ yesterday to test these builds before official release. I was previously running the gmc-19 builds without any problems.

I also noticed a kernel bump when i upgraded (from vero364-image-3.14.29-140-osmc:arm64 to vero364-image-3.14.29-142-osmc:arm64)

I watched some livetv and recordings last night without any problems. However, this morning I tried to play both livetv and recordings and the Video was frozen on the last few frames of the last recording we watched last night; although the Audio was playing correctly.

I was able to hit stop to return to the gui, but whenever I tried to play anything it just showed those same last few frames from previous recording last night.

Here are the logs: https://paste.osmc.tv/cedecekoda

I rebooted and this cleared the problem. I also took some screenshots should you need them.