[TESTING] Kodi v18 release builds


As Sam wrote:


I assume this was aimed at me.

No problems - I’ve raised my issue in a new post here:

1 Like

Tested for 3 hours, I have just experienced 1 issue in the “My Osmc” menu where my remote (minix a2 lite) does not make any effect.
Thanks for the update : )


Did you try to update again to the version provided this morning?


Just installed it, problem’s gone :slight_smile:


Is there any changelog to check any OSMC upgraded/updated features (not just the ones related to the Kodi 17->18 app upgrade)? HDR Metadata ?



That will come with 4.9 which will come after this update.

We don’t want to change too many things at once



Thx Sam & team, everything worked so far. Will test it more over the holidays. Besides v18 starting in 480p, I encountered nothing broken. Migration worked perfectly and very fast.

Being able to finally install Estuary Mod v2 was already worth it, what a great skin mod.


Oh there was one minor issue, no idea if that was just me… after migration Kodi opens a screen and tells me which addons could not be migrated… I could not leave that screen by pressing „ok“, neither my harmony remote nor my osmc remote was able to leave that screen by pressing „ok“. I had to restart device and thankfully the screen was gone and my harmony remote worked immediately.


So far so good on my reserve V4K+. The GUI stuck at 480p for a while, did not like my first attempt to change it to 1080/60 but it stuck after a couple of attempts.

Encouragingly, the Vero can now play one of my TVH .ts files that previously only played back on a Pi, so it might now be more resilient against poor TVH authoring. Also ok with a R1 episode of Start Trek DS9 that was causing frame-rate switching issues before, that’s now gone.

Think I’ll run this for a week or so before migrating my in-service Vero’s, but ok so far. Thanks for everyone’s efforts on this.


These two issues were most likely fixed by:

Glad to see this fix is proving fruitful :wink:


I was hoping to get some clarification on this; I have a Vero 4 attached to an AV unit that pipes to a 4k projector and frequently switch resolutions. I never turn off the Vero but always do so with the AV and projector. Will I experience this issue you’ve described? I’d love to test this but am hesitant if I’ll be hit by this known problem. Thanks!


It’s only an issue if the 4K reboots while the AVR/Projector are off. Once the 4K is running, you can turn off the AVR/Projector with no problems. I do this all the time with my AVR/TV connected to my 4K.


Raspberry Pi B+ upgraded without issue.

Some notes:

  • ‘Games’ option appeared on Estuary skin when previously disabled?
  • Some general minor interface lag (no doubt will improve with time).
  • PVR - tvheadend - noticeable stutter/pause/stutter when beginning playback - once playing appears okay (buffering/performance issue?).

Thanks for the update. it went smoothly.
I’m running the software on RPI 3.
One thing I noticed as not working is the music visualizations. I remember having shadertoy running from popcornmix repo. So, I tried to reinstall it, on both skins (osmc + estuary) : not ok.
Do you also have this issue , or is something not ok on my side ?


There seems to have been an issue compiling them for Kodi 18

1 Like

Just updated my Pi and the setting I had to boost the center channel in the downmix to my speaker bar has disappeared from the expert view audio settings. Any ideas what’s happened?

EDIT: the missing options on the Pi are there on the updated Vero, so an issue with the Pi build?


So far everything works on my side, only once happened when started a video it crushed with sad face. After rebooting worked fine.


Just updated from 17 stable to kodi18 on RasPi3. Everything works fine except there are no Emulator-Addons? How do I get them?


The emulators were not included in this RC, but will be in next/stable.