[TESTING] Kodi v19 builds for Raspberry Pi 2/3/4

@darwindesign A have setup auto switching channel, but after setting to channel 36 still not working

@fzinken After installation of crda I tried sudo iw reg set cs I recieved response:
not a valid ISO/IEC 366-1 alpha2
Special non-alpha2 usable entries:
00 World Regulatory domain

Do you know, where I can find correct code for czech republic please? (cz also not working)
http://paste.osmc.tv/bonipejeco

Thanks Jan

sudo iw reg set cz for Czech

Already tried - same response like cs
Jan

Can you try capital CZ?

Not yet. I will try evening
Thank you
Jan

Just tried here, sudo iw reg set CZ worked

osmc@osmc-pi3:~$ sudo iw reg set CZ
osmc@osmc-pi3:~$ sudo iw reg get
global
country CZ: DFS-ETSI
	(2400 - 2483 @ 40), (N/A, 20), (N/A)
	(5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
	(5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
	(5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

A post was split to a new topic: MySQL Database missing movie_view

I found some posts that indicate that the pi 4 will never work for h264 4K videos. I went back and can verify that with the latest OSMC for the PI 4, I can play pretty much any h265 4K videos, and can not play h264 4K videos.
This should probably be in a stickly post somewhere.

That would be a pity :confused:
I’m still can’t get 4K playback to work on my Pi4, x265 or not. Did you make any additional changes?
I’ve used the “LaLaLand” sample file from here, which is 4K HEVC, can you confirm that this works for you?

Initially I thought it might be due to my network not being fast enough, but I saved the sample file locally on the SD card, so that should definitely be fast enough…

That’s correct. H264 is limited to 1080p

Hi, do you have any idea how to get the PVR Enigma2 Client add-on for this version?

I tried the “LaLaLand” sample you linked and it played without any issues in my Pi4.

I also didn’t know about the H264 1080p limitation. Will H264 4k be supported in the future or is this some sort of deprecation because of H265?

The 1080p limitation for h.264 would be a limitation of the hardware decoder. The h.265 codec was created specifically to address the previous codec’s ability to scale resolutions higher than full HD efficiently so this why you would normally only see 4K content encoded in more modern codecs. This is no different than how you wouldn’t normally see HD content encoded in Mpeg 2. I’m a bit confused why people would have 4K content in h.264.

Remote backup location doesn’t work while it is writeable. Any ideas?

http://paste.osmc.tv/akefipalab.xml

This should now be available.

3 posts were merged into an existing topic: [TESTING] Kodi v19 builds for Vero 4K / 4K +

Just for informational purposes: I set up a Raspberry 4 with OSMC and I could manage to get YouTube, Netflix and Addons from Slyguy to work.
Thank you OSMC

I made my first installation of v19 build yesterday.
It was a fresh install on RPi4

I updated with
sudo apt-get dist-upgrade

Then experimented with a few things.

HDMI CEC not working yet. I did power off (at the wall) the TV and Amp but I probably need to try that again.
One thing I did notice though.
The setting in the CEC peripheral page to indicate how it is connected - TV or Amp - is not preserved over a restart when set to Amp - it resets to TV.

I’ll do some more experiments with this during next week as I had to restore the old v18 on RPi3 for weekend use.

Is there a known issue on RPi4 with multichannel audio playback from recorded HD TV (was recorded from UK Channel 4 HD and adverts snipped)?
I get no sound on the primary channel unless I set the RPi audio output to 2.0 (should be 5.0 for my equipment and the original recording is 5.1).

If not known then I’ll try to find a shareable file and grab logs.

I’ve found that sometimes with updates or restarts My TV gets confused on what it should be doing CEC wise with the current input. By this I mean that my TV and AVR are set to my RPi and it is displaying but navigation through CEC to the RPi doesn’t work. I’ve found the fix for this is to just select a different input (on TV or AVR, it doesn’t seem to matter in my setup) and then switch back. I have seen this behavior with Kodi 18 on RPi 3 as well so I’m not sure if their is some new behavior here or not.