[TESTING] Kodi v19 builds for Raspberry Pi 2/3/4

Thanks for advice

I reverted back to the previous version and it works. :slight_smile:


I am testing OSMC on rPI4 and so far so good, but when I run the library refresh scan I have a notification “Move Database python error”.
I have checked logs and found this:

2021-06-08 14:54:57.052 T:602     ERROR <general>: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                                    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                                   Error Type: <class 'AttributeError'>
                                                   Error Contents: 'str' object has no attribute 'get'
                                                   Traceback (most recent call last):
                                                     File "/usr/share/kodi/addons/metadata.themoviedb.org.python/python/scraper.py", line 175, in <module>
                                                     File "/usr/share/kodi/addons/metadata.themoviedb.org.python/python/scraper.py", line 164, in run
                                                       enddir = not get_details(parse_lookup_string(params["url"]), params['handle'], settings)
                                                     File "/usr/share/kodi/addons/metadata.themoviedb.org.python/python/scraper.py", line 90, in get_details
                                                       details = get_tmdb_scraper(settings).get_details(input_uniqueids)
                                                     File "/usr/share/kodi/addons/metadata.themoviedb.org.python/python/lib/tmdbscraper/tmdb.py", line 57, in get_details
                                                       details = self._gather_details(media_id)
                                                     File "/usr/share/kodi/addons/metadata.themoviedb.org.python/python/lib/tmdbscraper/tmdb.py", line 66, in _gather_details
                                                       if not movie or movie.get('error'):
                                                   AttributeError: 'str' object has no attribute 'get'
                                                   -->End of Python script error report<--

Anyone can help?

Try checking the repository for updates to the scraper.

I have problem to connect to 5GHz wifi (2,4 GHz is running good)
I can see the 5 GHz network, but can´t connect.
RPi 4, 4GB, Kodi 19.1
Anybody have same problem?
Thanks for help
Edit: the network SSID is “pf-JanS_5G”

What channel are you using? I found on early non-public testing that I couldn’t connect to my higher frequency AP (channel 136) but I could to my AP set to channel 36. The solution was to set the country code via the underlying OS which involved installing a package (I forget which off the top of my head) and running a command I found with a web search. I think @sam_nazarko said he was going to look into it but I’m not sure if the country code issue had been looked into yet.

That would be crda, sudo apt-get install crda afterwards could try to set country with sudo iw reg set <2 digit ISO>

1 Like

@darwindesign A have setup auto switching channel, but after setting to channel 36 still not working

@fzinken After installation of crda I tried sudo iw reg set cs I recieved response:
not a valid ISO/IEC 366-1 alpha2
Special non-alpha2 usable entries:
00 World Regulatory domain

Do you know, where I can find correct code for czech republic please? (cz also not working)

Thanks Jan

sudo iw reg set cz for Czech

Already tried - same response like cs

Can you try capital CZ?

Not yet. I will try evening
Thank you

Just tried here, sudo iw reg set CZ worked

osmc@osmc-pi3:~$ sudo iw reg set CZ
osmc@osmc-pi3:~$ sudo iw reg get
country CZ: DFS-ETSI
	(2400 - 2483 @ 40), (N/A, 20), (N/A)
	(5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
	(5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
	(5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

A post was split to a new topic: MySQL Database missing movie_view

I found some posts that indicate that the pi 4 will never work for h264 4K videos. I went back and can verify that with the latest OSMC for the PI 4, I can play pretty much any h265 4K videos, and can not play h264 4K videos.
This should probably be in a stickly post somewhere.

That would be a pity :confused:
I’m still can’t get 4K playback to work on my Pi4, x265 or not. Did you make any additional changes?
I’ve used the “LaLaLand” sample file from here, which is 4K HEVC, can you confirm that this works for you?

Initially I thought it might be due to my network not being fast enough, but I saved the sample file locally on the SD card, so that should definitely be fast enough…

That’s correct. H264 is limited to 1080p

Hi, do you have any idea how to get the PVR Enigma2 Client add-on for this version?

I tried the “LaLaLand” sample you linked and it played without any issues in my Pi4.

I also didn’t know about the H264 1080p limitation. Will H264 4k be supported in the future or is this some sort of deprecation because of H265?

The 1080p limitation for h.264 would be a limitation of the hardware decoder. The h.265 codec was created specifically to address the previous codec’s ability to scale resolutions higher than full HD efficiently so this why you would normally only see 4K content encoded in more modern codecs. This is no different than how you wouldn’t normally see HD content encoded in Mpeg 2. I’m a bit confused why people would have 4K content in h.264.

Remote backup location doesn’t work while it is writeable. Any ideas?