[TESTING] Kodi v19 builds for Raspberry Pi 2/3/4

Apologies for missing your post.

I have a Pi4 running the development branch:

osmc@osmc:~$ uname -a
Linux osmc 5.10.32-1-osmc #1 SMP PREEMPT Wed Apr 28 05:45:57 UTC 2021 aarch64 GNU/Linux

and wireguard seems to work – though I’ve not actually tested its connectivity.

osmc@osmc:~$ sudo ip link add wg0 type wireguard
osmc@osmc:~$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,DYNAMIC,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000
    link/ether dc:a6:32:b7:81:4c brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,DYNAMIC,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DORMANT group default qlen 1000
    link/ether dc:a6:32:b7:81:4d brd ff:ff:ff:ff:ff:ff
4: wg0: <POINTOPOINT,NOARP> mtu 1420 qdisc noop state DOWN mode DEFAULT group default qlen 1000
osmc@osmc:~$ lsmod | grep wireguard
wireguard              73728  0
libchacha20poly1305    16384  1 wireguard
ip6_udp_tunnel         16384  1 wireguard
udp_tunnel             28672  1 wireguard
libcurve25519_generic    40960  1 wireguard
libblake2s             16384  1 wireguard
ipv6                  552960  33 wireguard
osmc@osmc:~$ grep -i wireguard /boot/config-5.10.32-1-osmc 

It might be working on Pi4, but on Pi2/3, the wireguard module is missing in the kernel.
Had the same issue, as nimbleguardian.
My solution in the end was, installing wireguard-dkms (from raspbian repo) and just commenting out the check for kernel >= 5.6 in /var/lib/dkms/wireguard/1.0.20210219/source/compat/compat.h and dpkg-reconfigure wireguard-dkms

We can add it in the next kernel.


1 Like

I’m also using pi2

would be great if you could add it to the kernel, so it’s available by default

Hey guys :slight_smile:

I’ve installed the latest build on my SD Card and it’s running fine for me. But, i usually run OSMC on my USB drive instead of my SD Card.

Do you know how i can copy my SD Card to my USB drive without losing data on it (and run system on the USB Drive) ? My USB Drive is partitioned like this :

  • sda1 : 32GB ext4 partition for the system, can be formatted if needed
  • sda2 : rest of the disk, ext4, contains /home and all my medias

Thanks for your help.

I’ve added support for Wireguard to the Pi 2 / 3 kernel.
Please verify.


Looks good. Removed wireguard-dkms, updated kernel and wireguard was working after reboot.
Thx :slight_smile:

Hello to @sam_nazarko and everyone involved in the development of the OSMC.
I have been an OSMC user and big fan since 2014.
Until today I use RPI 2, my freiends use RPI 3b and 3b +, also on OSMC. I am aware of the regression brought by Kodi Matrix, but unfortunately, the sad truth is that for RPI 2 to RPI 3b + users, the regression is very noticeable. The video player works much worse. I know why, I know what influenced it, but my question is as follows - will the OSMC on the Kodi Matrix be improved to such an extent that the video player will be usable at a similar level as in the Leia version (no issues with h264, even h265/10bit also playable)? What are the plans in this regard? What can RPI 2 / RPI 3b + users expect? My friends and I are unfortunately considering switching to Android devices.
Please be so kind and provide an exhaustive and reasonable answer. I am not complaining, but searching for answere.
Thank you very much for your work and support for all these years.

What issues do you have with H264 playback? I am using Kodi Matrix since half a year on a Pi3 and haven’t come across any problems.

H265 will continue to be software decoding only so there is no magic improvement on that.

You could stay on Leia as that works quite well or you could consider buying a Vero4k

In general, the video player is just a lot slower - starting/stopping and fowarding/backwarding works much worse. Caching takes much longer. This is how it works on three devices, the deterioration is obvious.
When it comes to h264, the experience is even worse, and I have files that sometimes show green glow on the screen.
H265 files, which were playable before, are not anymore - sound is playing, but no picture.
So are there any plans to improve the player?

How are you connected to your NAS? Could it be a network problem? Because caching should not be related to the Videoplayer.

This is not a NAS or network problem. Cache and player issues are related to USB drives / local files.
I’m not saying that the player doesn’t work or works with bugs, but the deterioration in quality and smoothness of working with files is noticeable. Video starts much slower, forawarding / backforwarding takes a lot of caching and when the video is stopped it takes much longer to get back to “file explorer”.
@fzinken thank you for your interest in the topic

This is also not a usb drive, nor SD card problem. I wonder if there are any planned works to improve the player itself and h264 playback (and perhaps h265)?

H264 should be playing fine - particularly if it’s progressive material.

I will check these problematic files again and will take a photo of this greenish like artefacts effect. Anyway, the player itself is much more laggy and not so responsive as it was in Leia. @sam_nazarko Sam is there any chance that you will introduce some improveents into player in comming weeks or months? Are there any works in progress in this area? Also, what is there future of widewine? Really no resolution until Debian Bullseye? How did they resolve this in Libreelec 9.2? Or have I missunderstood something?
With respect, domo

Debian Bullseye will final in August, then we will start to look at migrating.

There could be a number of reasons for this. Without logs, it’s hard to speculate.

I tried build for rpi4 today. dd’ed it to microSD, started, updated.
Looks good, 4k hevs @ 60fps plays smoothly.
But CEC not working. It’s critical feature for me.
I tried all HDMI ports on my Philips TV. I tried both HDMI ports on rpi4. Power on and power off both devices. Nothing… :frowning:
CEC on rpi3 works like a charm.

Maybe output from cec-client will be useful:

root@osmc:~# cec-client
No device type given. Using 'recording device'
CEC Parser created - libCEC version 6.0.2
no serial port given. trying autodetect: 
 path:     /dev/cec0
 com port: Linux

opening a connection to the CEC adapter...
DEBUG:   [              57]     Broadcast (F): osd name set to 'Broadcast'
DEBUG:   [              58]     CLinuxCECAdapterCommunication::Open - m_fd=3 bStartListening=1
ERROR:   [              58]     CLinuxCECAdapterCommunication::Open - ioctl CEC_S_MODE failed - errno=16
DEBUG:   [              58]     CLinuxCECAdapterCommunication::Close - m_fd=3
ERROR:   [              58]     could not open a connection (try 1)
DEBUG:   [              58]     CLinuxCECAdapterCommunication::Close - m_fd=-1
DEBUG:   [            1058]     CLinuxCECAdapterCommunication::Open - m_fd=3 bStartListening=1
ERROR:   [            1058]     CLinuxCECAdapterCommunication::Open - ioctl CEC_S_MODE failed - errno=16
DEBUG:   [            1058]     CLinuxCECAdapterCommunication::Close - m_fd=3
ERROR:   [            1058]     could not open a connection (try 2)

Did you stop Kodi before running the command?

Inputs on a TV should normally not make any difference. The HDMI port on the RPi 4 that you want to use is the one closest to the USB C power input port. To reset CEC you would normally need to unplug the TV from the wall, and not just turn it on/off with the normal power button. Be aware that it is also possible that the HDMI cable/adapter you are using is not passing CEC and trying a different one may be in order. See the following…

EDIT: Please note that if you run cec-client it will break CEC in Kodi until you reboot the device.

No. But on rpi3 I launched cec-client and kodi simultaneously and saw every event from remote.