[TESTING] Linux 4.9 for Raspberry Pi


I’d like to update OSMC’s kernel for Raspberry Pi to Linux 4.9.

Linux 4.9 is an LTS kernel, so we would like to make this the stable kernel for OSMC on Raspberry Pi for a while, as we did with 4.4.

Before this can be released, it needs a lot of testing to make sure things like DACs, WiFi etc continue to work as expected. I’d like to get this included in OSMC’s May update.

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.



No good here, Sam. On reboot I get Illegal instruction then A start job is running for Set Time using HTTP query then Sad face - repeatedly.

Tried to upload logs after dist-upgrade but before the reboot (for reference) but it didn’t give me a URL, just <html>

My config is in this log made just prior to reboot.

How big was the log? I wonder if you got this output because the log was rather large.
Which device did you test on?

I put it on dropbox for you ^^^ after saving it to the SD card. It’s RPi2.

Just installed 4.9 and rebooted successfully. Then on a whim I decided to try the A2DP experimental build.

It failed to install


I don’t think that’s related. I think that’s related to:

 cannot copy extracted data for './usr/lib/libpulsecore-5.0.so' to '/usr/lib/libpulsecore-5.0.so.dpkg-new': unexpected end of file or stream

Which is probably related to the preceding lines:

dpkg-deb: error: subprocess <decompress> was killed by signal (Illegal instruction)
dpkg: error processing archive /var/cache/apt/archives/pulseaudio_5.0-13_armhf.deb (--unpack):

I didn’t suggest my error was related to grahamh’s problem. But… there’s that Illegal instruction again, so maybe there’s a connection.

Yes – I’m investigating that

That gave me an idea - I copied the boot partition from the (failed) upgrade while leaving the / partition intact. Just in case there were other things in the staging repo which weren’t working. I got

Illegal instruction (probably - it scrolled off the screen)
Failed to start Load Kernel Modules

Then it had trouble mounting dev-mmcblk0p1.device (Start job timed out)

Emergency mode, but couldn’t run the suggested journalctl. /boot not mounted.

Warm reboot - a different set of error messages but starting with Illegal instruction and ending with the sad face as the first attempt. /boot is now mounted. Couldn’t upload logs - some message about not being able to get a URL, but I’ve posted them on dropbox.

Just for the record, starting mediacenter on my “test” Pi 3 fails with the “Illegal instruction” error.

May 25 18:24:17 osmc mediacenter[2006]: Kodi exited with return code 132 after 0 hours, 0 minutes and 1 seconds
May 25 18:24:17 osmc mediacenter[2006]: /usr/bin/mediacenter: line 121:  2609 Illegal instruction     /usr/bin/ply-image "$CODE"

(I don’t normally run mediacenter on my test Pi since it’s not connected to a TV.)

I have tried updating my rpi 3 and got the same illegal instruction upon reboot.

Sadly I waited too much and after many reboots the logs (both the current one and the “old” one) were totally empty.

Will try again tonight.

Even though I (sort of) reverted to the 4.4 kernel, something is pretty well borked:

osmc@osmc:~$ sudo systemctl status mediacenter
● mediacenter.service - media center application
   Loaded: loaded (/lib/systemd/system/mediacenter.service; disabled)
   Active: active (running) since Sat 2017-05-27 21:24:54 BST; 1min 3s ago
 Main PID: 735 (mediacenter)
   CGroup: /system.slice/mediacenter.service
           └─735 /bin/bash /usr/bin/mediacenter
May 27 21:25:48 osmc mediacenter[735]: ERROR: Unable to create application. Exiting
May 27 21:25:48 osmc mediacenter[735]: *** Error in `/usr/lib/kodi/kodi.bin': corrupted double-linked list: 0x02dfdef0 ***
osmc@osmc:~$ uname -a
Linux osmc 4.4.27-9-osmc #1 SMP PREEMPT Tue Mar 14 20:54:19 UTC 2017 armv7l GNU/Linux

Edit: The md5 of my kodi.bin (Pi 3) is:
cea59f22fcb833c13bcd0b61e5aac356 /usr/lib/kodi/kodi.bin

I tryed it on a fresh install and found this particular error in the crash log

  ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files

any suggestions?

It’s a red herring. That error is in all logs and has no symptoms.

As you can surely understand by the comments above, the new kernel is anywhere but ready to be released. If you can contribute please do so, otherwise please remove your post, this thread is meant for testing feedbacks only.

@sam_nazarko Managed to test the new kernel.

Here are the logs before rebooting: https://paste.osmc.tv/xadozucusu.vhdl

Here are the logs after rebooting: https://paste.osmc.tv/toyuyadumu.vhdl

After rebooting I had to post the logs using

cat /boot/uploadlogs.txt | paste-log

Because using grab-logs -A gave me this error:

osmc@osmc:~$ grab-logs -A
Illegal instruction
Illegal instruction
Exception Details:

Traceback (most recent call last):
  File "/usr/bin/grab-logs", line 783, in dispatch_logs
    raise ValueError('Upload Returned Empty String')
ValueError: Upload Returned Empty String

Failed to upload log files, copying to /boot instead. (Unable to verify)


If anyone wants to try the latest update, please follow the original instructions.

@popcornmix made some suggestions that now hopefully resolve this.


Hi Sam,

Just tested on a pi3

uname -r

From the quick testing I’ve done, videos and music from my nas seem to be playing correctly as well.

I can test more things tomorrow evening, if you require more information. As far as I can tell at the moment, all is good.

Thanks Tom.

Thanks for testing. The more feedback we get, the better :slight_smile:


And it’s a go here as well.

Before: https://paste.osmc.tv/sanokecodu

After: https://paste.osmc.tv/wiroxofeja

Will test more things tomorrow. Looks good so far!